]> git.pld-linux.org Git - packages/tcb.git/blob - tcb.spec
3a118bd8456caef2588431be9641071b262818f3
[packages/tcb.git] / tcb.spec
1 #
2 # TODO
3 # - Integrate crypt_blowfish into glibc (or an external lib?)
4 # - Depend on the new glibc or external lib
5 #
6 Summary:        The alternative to shadow
7 Summary(pl.UTF-8):      Alternatywa dla shadow
8 Name:           tcb
9 Version:        1.1
10 Release:        0.1
11 License:        GPL v2
12 Group:          Applications/System
13 Source0:        http://www.openwall.com/tcb/%{name}-%{version}.tar.gz
14 # Source0-md5:  b4ac25f22fd3bdc9eb32ff6f97f022cd
15 Patch0:         %{name}-make.patch
16 Requires(postun):       /usr/sbin/groupdel
17 Requires(postun):       /usr/sbin/userdel
18 Requires(pre):  /bin/id
19 Requires(pre):  /usr/sbin/groupadd
20 Requires(pre):  /usr/sbin/useradd
21 URL:            http://www.openwall.com/tcb/
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The tcb package contains core components of tcb suite implementing the
26 alternative password shadowing scheme on Owl. It is being made
27 available separately from Owl primarily for use by other
28 distributions.
29
30 %description -l pl.UTF-8
31 Pakiet tcb zawiera główne komponenty zestawu tcb implementującego
32 alternatywny schemat ukrywania haseł w systemie Owl. Jest dostępny
33 oddzielnie głównie do wykorzystania przez inne dystrybucje.
34
35 %package devel
36 Summary:        Headers for libtcb
37 Summary(pl.UTF-8):      Pliki nagłówkowe libtcb
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Headers for libtcb.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe libtcb.
46
47 %package static
48 Summary:        Static library for libtcb
49 Summary(pl.UTF-8):      Biblioteka statyczna libtcb
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static library for libtcb.
55
56 %description static -l pl.UTF-8
57 Biblioteka statyczna libtcb.
58
59 %package -n pam-pam_tcb
60 Summary:        TCB module for PAM
61 Summary(pl.UTF-8):      Moduł TCB dla PAM
62 Group:          Base
63
64 %description -n pam-pam_tcb
65 The alternative to shadow (TCB) PAM module.
66
67 %description -n pam-pam_tcb -l pl.UTF-8
68 Alternatywny dla shadow (TCB) moduł PAM.
69
70 %package -n nss_tcb
71 Summary:        TCB library for NSS
72 Summary(pl.UTF-8):      Biblioteka TCB dla NSS
73 Group:          Base
74
75 %description -n nss_tcb
76 nss_tcb is a C library extension (NSS module) which allows TCB service
77 to be used as a primary source of aliases, ethers, groups, hosts,
78 networks, protocols, users, RPCs, services and shadow passwords
79 (instead of or in addition to using flat files or NIS).
80
81 %description -n nss_tcb -l pl.UTF-8
82 nss_tcb to biblioteka rozszerzenia (moduł NSS) pozwalający na używanie
83 usługi TCB jako głównego źródła aliasów (aliases), adresów kart
84 sieciowych (ethers), grup (group), hostów (hosts), sieci (networks),
85 protokołów (protocols), użytkowników (passwd), RPC, usług (services) i
86 ukrytych haseł (shadow) zamiast płaskich plików lub NIS.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 %{__make} \
94         CC="%{__cc}" \
95         DBGFLAG="%{rpmcflags} %{rpmldflags}" \
96         SBINDIR=/sbin \
97         SLIBDIR=/%{_lib} \
98         LIBDIR=%{_libdir} \
99         LIBEXECDIR=%{_libexecdir} \
100         MANDIR=%{_mandir}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT \
107         SLIBDIR=/%{_lib} \
108         LIBDIR=%{_libdir} \
109         LIBEXECDIR=%{_libexecdir} \
110         MANDIR=%{_mandir}
111
112 mv $RPM_BUILD_ROOT%{_libexecdir}/chkpwd/tcb_chkpwd $RPM_BUILD_ROOT/sbin
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %pre
118 %groupadd -g 286 -r -f shadow
119
120 %postun
121 if [ "$1" = "0" ]; then
122         %groupremove shadow
123 fi
124
125 %post   libs -p /sbin/ldconfig
126 %postun libs -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %attr(755,root,root) /%{_lib}/libtcb.so.0.9.8
131 %attr(755,root,root) /sbin/tcb_convert
132 %attr(755,root,root) /sbin/tcb_unconvert
133 %attr(755,root,root) /sbin/tcb_chkpwd
134 %{_mandir}/man5/tcb.5*
135 %{_mandir}/man8/tcb_convert.8*
136 %{_mandir}/man8/tcb_unconvert.8
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libtcb.so
141 %{_includedir}/tcb.h
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libtcb.a
146
147 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chsh
148 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/passwd
149 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/useradd
150 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/shadow
151 #%exclude %{_mandir}/man8/pam_rpasswd.8*
152
153 %files -n nss_tcb
154 %defattr(644,root,root,755)
155 %attr(755,root,root) /%{_lib}/libnss*.so.*
156
157 %files -n pam-pam_tcb
158 %defattr(644,root,root,755)
159 %attr(755,root,root) /%{_lib}/security/*.so
160 %{_mandir}/man8/pam_*.8*
This page took 0.040358 seconds and 2 git commands to generate.