]> git.pld-linux.org Git - packages/taskwarrior.git/blob - taskwarrior.spec
noarch bash,zsh completions, vim
[packages/taskwarrior.git] / taskwarrior.spec
1 %define         shortname       task
2 Summary:        Taskwarrior is a command-line to do list manager
3 Summary(hu.UTF-8):      Taskwarrior egy parancssoros ToDo-kezelő
4 Summary(pl.UTF-8):      Taskwarrior - konsolowy manadżer rzeczy do zrobienia
5 Name:           taskwarrior
6 Version:        2.3.0
7 Release:        1
8 License:        MIT
9 Group:          Applications
10 Source0:        http://www.taskwarrior.org/download/%{shortname}-%{version}.tar.gz
11 # Source0-md5:  2c1d2c64311855f3519ad038ebd372ac
12 URL:            http://taskwarrior.org/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  cmake
16 BuildRequires:  intltool
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define bashdir %{_sysconfdir}/bash_completion.d
23 %define vimdir %{_datadir}/vim/vimfiles
24 %define zshdir %{_datadir}/zsh/site-functions
25
26 %description
27 Taskwarrior is an ambitious project to supercharge task (most
28 excellent CLI task manager by Paul Beckingham) with an interactive
29 interface, a powerful search tool, hotkeys, forms data entry, and a
30 host of new features.
31
32 %description -l hu.UTF-8
33 Taskwarrior egy törekvő project, amely a task-ot bővíti ki (a legjobb
34 CLI feladatkezelő Paul Beckingham-től) egy interaktív felületettel,
35 hatékony kereső eszközzel, hotkey-ekkel, űrlapokkal és új lehetőségek
36 tömegeivel.
37
38 %description -l pl.UTF-8
39 Taskwarrior jest ambitnym projektem mającym na celu ulepszenie
40 programu task (najlepszego konsolowego menadżera zadań stworzonego
41 przez Paula Beckinghama) poprzez dodanie interaktywnego interfejsu,
42 potężnej wyszukiwarki, skrótów klawiszowych, formularzy wprowadzania
43 danych i wielu innych ulepszeń.
44
45 %package -n bash-completion-taskwarrior
46 Summary:        bash-completion for taskwarrior
47 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla taskwarriora
48 Group:          Applications/Shells
49 Requires:       bash-completion
50 Requires:       %{name} = %{version}-%{release}
51 %if "%{_rpmversion}" >= "5"
52 BuildArch:      noarch
53 %endif
54
55 %description -n bash-completion-taskwarrior
56 bash-completion for taskwarrior.
57
58 %description -n bash-completion-taskwarrior -l pl.UTF-8
59 Pakiet ten dostarcza bashowe uzupełnianie nazw dla taskwarriora.
60
61 %package -n vim-syntax-taskwarrior
62 Summary:        Vim-syntax: taskwarrior
63 Summary(pl.UTF-8):      Składnia dla Vima: taskwarrior
64 Group:          Applications/Editors/Vim
65 Requires:       %{name} = %{version}-%{release}
66 %if "%{_rpmversion}" >= "5"
67 BuildArch:      noarch
68 %endif
69
70 %description -n vim-syntax-taskwarrior
71 Vim-syntax: taskwarrior.
72
73 %description -n vim-syntax-taskwarrior -l pl.UTF-8
74 Ta wtyczka dostarcza podświetlanie składni dla taskwarriora.
75
76 %package -n zsh-completion-taskwarrior
77 Summary:        zsh-completion for taskwarrior
78 Summary(pl.UTF-8):      Uzupełnianie nazw w zsh dla taskwarriora
79 Group:          Applications/Shells
80 Requires:       %{name} = %{version}-%{release}
81 %if "%{_rpmversion}" >= "5"
82 BuildArch:      noarch
83 %endif
84
85 %description -n zsh-completion-taskwarrior
86 zsh-completion for taskwarrior.
87
88 %description -n zsh-completion-taskwarrior -l pl.UTF-8
89 Pakiet ten dostarcza funkcje uzupełniania nazw powłoki zsh dla
90 taskwarriora.
91
92 %prep
93 %setup -q -n %{shortname}-%{version}
94
95 %build
96 %cmake
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{shortname}
105
106 install -d $RPM_BUILD_ROOT{%{bashdir},%{zshdir}}
107 install -p scripts/bash/task.sh $RPM_BUILD_ROOT%{bashdir}
108 install -p scripts/zsh/_task $RPM_BUILD_ROOT%{zshdir}
109
110 install -d $RPM_BUILD_ROOT%{vimdir}/{ftdetect,syntax}
111 for dir in ftdetect syntax; do
112         install -d $RPM_BUILD_ROOT%{vimdir}/$dir
113         install -p scripts/vim/$dir/* $RPM_BUILD_ROOT%{vimdir}/$dir
114 done
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog NEWS README i18n doc/rc
122 %attr(755,root,root) %{_bindir}/%{shortname}
123 %attr(755,root,root) %{_bindir}/tasksh
124 %{_mandir}/man1/*1*
125 %{_mandir}/man5/*5*
126
127 %files -n bash-completion-taskwarrior
128 %defattr(644,root,root,755)
129 %{bashdir}/task.sh
130
131 %files -n vim-syntax-taskwarrior
132 %defattr(644,root,root,755)
133 %{vimdir}/ftdetect/*.vim
134 %{vimdir}/syntax/*.vim
135
136 %files -n zsh-completion-taskwarrior
137 %defattr(644,root,root,755)
138 %{zshdir}/_task
This page took 0.072458 seconds and 3 git commands to generate.