]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- add /var/lib/systemd/coredump dir:
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_with     plymouth        # plymouth support
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
15
16 Summary:        A System and Service Manager
17 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
18 Name:           systemd
19 Version:        44
20 Release:        2
21 License:        GPL v2+
22 Group:          Base
23 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
24 # Source0-md5:  11f44ff74c87850064e4351518bcff17
25 Source1:        %{name}-sysv-convert
26 Source2:        %{name}_booted.c
27 Source3:        network.service
28 Source4:        compat-pld-media.tmpfiles
29 Source5:        compat-pld-var-run.tmpfiles
30 Source10:       pld-storage-init-late.service
31 Source11:       pld-storage-init.service
32 Source12:       pld-wait-storage.service
33 Source13:       pld-storage-init.sh
34 Patch0:         target-pld.patch
35 Patch1:         config-pld.patch
36 Patch2:         shut-sysv-up.patch
37 Patch3:         pld-sysv-network.patch
38 Patch4:         tmpfiles-not-fatal.patch
39 Patch5:         CVE-2012-1174.patch
40 URL:            http://www.freedesktop.org/wiki/Software/systemd
41 BuildRequires:  acl-devel
42 %{?with_audit:BuildRequires:    audit-libs-devel}
43 BuildRequires:  autoconf >= 2.63
44 BuildRequires:  automake >= 1:1.11
45 BuildRequires:  binutils >= 3:2.22.52.0.1-2
46 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
47 BuildRequires:  dbus-devel >= 1.3.2
48 BuildRequires:  docbook-style-xsl
49 BuildRequires:  gperf
50 BuildRequires:  intltool >= 0.40.0
51 BuildRequires:  kmod-devel >= 5
52 BuildRequires:  libcap-devel
53 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
54 BuildRequires:  libtool >= 2:2.2
55 %{?with_tcpd:BuildRequires:     libwrap-devel}
56 BuildRequires:  libxslt-progs
57 BuildRequires:  m4
58 %{?with_pam:BuildRequires:      pam-devel}
59 BuildRequires:  pkgconfig >= 0.9.0
60 BuildRequires:  rpmbuild(macros) >= 1.627
61 BuildRequires:  udev-devel >= 1:172
62 # not required for building from release (which contains *.c for *.vala)
63 #BuildRequires: vala >= 0.10.0
64 BuildRequires:  xz-devel
65 %if %{with gtk}
66 BuildRequires:  glib2-devel >= 1:2.26.1
67 BuildRequires:  gtk+2-devel >= 2:2.24.0
68 BuildRequires:  libgee-devel
69 BuildRequires:  libnotify-devel >= 0.7.0
70 %endif
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       %{name}-units = %{version}-%{release}
73 Requires:       /etc/os-release
74 Requires:       SysVinit-tools
75 Requires:       agetty
76 Requires:       dbus >= 1.4.16-6
77 Requires:       filesystem >= 4.0-2
78 Requires:       libutempter
79 Requires:       rc-scripts >= 0.4.5.1-7
80 Requires:       setup >= 2.8.0-2
81 Requires:       udev-core >= 1:175-5
82 Requires:       udev-libs >= 1:172
83 Requires:       virtual(module-tools)
84 Suggests:       ConsoleKit
85 Suggests:       fsck >= 2.20
86 Suggests:       kmod >= 5
87 Suggests:       nss_myhostname
88 # python modules required by systemd-analyze
89 Suggests:       %{name}-no-compat-tmpfiles
90 Suggests:       python-dbus
91 Suggests:       python-modules
92 Suggests:       service(klogd)
93 Suggests:       service(syslog)
94 Provides:       udev-acl
95 # systemd takes care of that and causes problems
96 Conflicts:      binfmt-detector
97 # sytemd wants pam with pam_systemd.so in system-auth...
98 Conflicts:      pam < 1:1.1.5-5
99 # ...and sudo hates it
100 Conflicts:      sudo < 1:1.7.8p2-4
101 # for prefdm script
102 Conflicts:      xinitrc-ng < 1.0
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         _libexecdir     %{_prefix}/lib
106
107 %description
108 systemd is a system and service manager for Linux, compatible with
109 SysV and LSB init scripts. systemd provides aggressive parallelization
110 capabilities, uses socket and D-Bus activation for starting services,
111 offers on-demand starting of daemons, keeps track of processes using
112 Linux cgroups, supports snapshotting and restoring of the system
113 state, maintains mount and automount points and implements an
114 elaborate transactional dependency-based service control logic. It can
115 work as a drop-in replacement for sysvinit.
116
117 %description -l pl.UTF-8
118 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
119 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
120 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
121 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
122 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
123 (restore) stanu systemu, zarządza (auto)mount pointami oraz
124 implementuje starannie opracowaną transakcjonalną, bazującą na
125 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
126 sysvinit.
127
128 %package init
129 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
130 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
131 Group:          Base
132 Requires:       systemd
133 Provides:       readahead = 1:1.5.7-3
134 Provides:       virtual(init-daemon)
135 Obsoletes:      SysVinit
136 Obsoletes:      readahead < 1:1.5.7-3
137 Obsoletes:      virtual(init-daemon)
138 Conflicts:      upstart
139
140 %description init
141 Install this package when you are ready to final switch to systemd.
142
143 %description init -l pl.UTF-8
144 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
145 przejścia na systemd.
146
147 %package units
148 Summary:        Configuration files, directories and installation tool for systemd
149 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
150 Group:          Base
151 Requires(post): coreutils
152 Requires(post): /bin/awk
153
154 %description units
155 Basic configuration files, directories and installation tool for the
156 systemd system and service manager.
157
158 This is common config, use %{_sysconfdir}/systemd/system to override.
159
160 %description units -l pl.UTF-8
161 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
162 zarządcy systemu i usług systemd.
163
164 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
165 poprzez katalog %{_sysconfdir}/systemd/system.
166
167 %package plymouth
168 Summary:        Plymouth support units for systemd
169 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
170 Group:          Base
171 Requires:       %{name}-units = %{version}-%{release}
172
173 %description plymouth
174 Plymouth (graphical boot) support units for systemd.
175
176 %description plymouth -l pl.UTF-8
177 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
178
179 %package gtk
180 Summary:        Graphical frontend for systemd
181 Summary(pl.UTF-8):      Graficzny interfejs do systemd
182 Group:          Base
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       polkit
185
186 %description gtk
187 Graphical front-end for systemd.
188
189 %description gtk -l pl.UTF-8
190 Graficzny interfejs do systemd.
191
192 %package libs
193 Summary:        Shared systemd libraries
194 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
195 Group:          Libraries
196
197 %description libs
198 Shared systemd libraries.
199
200 %description libs -l pl.UTF-8
201 Biblioteki współdzielone systemd.
202
203 %package devel
204 Summary:        Header files for systemd libraries
205 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
206 Group:          Development/Libraries
207 Requires:       %{name}-libs = %{version}-%{release}
208
209 %description devel
210 Header files for systemd libraries.
211
212 %description devel -l pl.UTF-8
213 Pliki nagłówkowe bibliotek systemd.
214
215 %package -n bash-completion-systemd
216 Summary:        bash-completion for systemd
217 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
218 Group:          Applications/Shells
219 Requires:       %{name}
220 Requires:       bash-completion
221
222 %description -n bash-completion-systemd
223 bash-completion for systemd.
224
225 %description -n bash-completion-systemd -l pl.UTF-8
226 Bashowe dopełnianie składni dla systemd
227
228 %package no-compat-tmpfiles
229 Summary:        Force update of packages that provide tmpfiles.d configuration
230 Group:          Base
231 Requires(post): sed > 4.0
232 Conflicts:      ConsoleKit-dirs < 0.4.5-7
233 Conflicts:      NetworkManager < 2:0.9.2.0-3
234 Conflicts:      Zope < 2.11.8-2
235 Conflicts:      amavisd-new < 1:2.7.0-1
236 Conflicts:      apache-base < 2.2.21-4
237 Conflicts:      apache-mod_bw < 0.92-3
238 Conflicts:      apache-mod_fastcgi < 2.4.6-6
239 Conflicts:      apache1-base < 1.3.42-5
240 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
241 Conflicts:      asterisk < 10.0.1-2
242 Conflicts:      autossh-init < 1.4b-3
243 Conflicts:      balance < 3.54-2
244 Conflicts:      bind < 7:9.8.1.P1-4
245 Conflicts:      bopm < 3.1.3-4
246 Conflicts:      callweaver < 1.2.1-9
247 Conflicts:      cassandra-bin < 0.8.9-2
248 Conflicts:      clamav < 0.97.3-3
249 Conflicts:      cups < 1:1.5.0-10
250 Conflicts:      dbus < 1.4.16-4
251 Conflicts:      dovecot < 1:2.0.16-3
252 Conflicts:      dspam < 3.9.0-6
253 Conflicts:      fail2ban < 0.8.4-4
254 Conflicts:      filesystem < 4.0-3
255 Conflicts:      gammu-smsd < 1:1.31.0-3
256 # Break gdm2.20 installs
257 #Conflicts:     gdm < 2:3.2.1.1-9
258 Conflicts:      greylistd < 0.8.8-2
259 Conflicts:      inn < 2.4.6-7
260 Conflicts:      ipsec-tools < 0.8.0-3
261 Conflicts:      jabber-common < 0-9
262 Conflicts:      laptop-mode-tools < 1.58-2
263 Conflicts:      libgpod < 0.8.0-6
264 Conflicts:      libvirt-utils < 0.9.9-4
265 Conflicts:      lighttpd < 1.4.30-5
266 Conflicts:      lirc < 0.9.0-20
267 Conflicts:      mailman < 5:2.1.14-4
268 Conflicts:      memcached < 1.4.11-2
269 Conflicts:      mpd < 0.16.5-4
270 Conflicts:      mrtg < 2.17.0-3
271 Conflicts:      munin-common < 1.4.5-5
272 Conflicts:      nagios-nrpe < 2.13-2
273 Conflicts:      ndisc6-rdnssd < 1.0.1-3
274 Conflicts:      nscd < 6:2.14.1-5
275 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
276 Conflicts:      openct < 0.6.20-3
277 Conflicts:      openl2tp < 1.8-3
278 Conflicts:      openldap-overlay-nssov < 2.4.28-4
279 Conflicts:      openldap-servers < 2.4.28-4
280 Conflicts:      openvpn < 2.2.2-2
281 Conflicts:      pam-pam_mount < 2.12-3
282 Conflicts:      pam-pam_ssh < 1.97-2
283 Conflicts:      pcsc-lite < 1.8.1-2
284 Conflicts:      php-dirs < 1.2-3
285 Conflicts:      policyd < 2.0.10-3
286 Conflicts:      pound < 2.6-2
287 Conflicts:      pptp < 1.7.2-3
288 Conflicts:      proftpd-common < 2:1.3.4a-2
289 Conflicts:      pulseaudio-server < 1.1-2
290 Conflicts:      quagga < 0.99.20-3
291 Conflicts:      radvd < 1.8.5-2
292 Conflicts:      rc-scripts < 0.4.5.2-3
293 Conflicts:      red5 < 0.9.0-2
294 Conflicts:      redis-server < 2.4.2-4
295 Conflicts:      smokeping < 2.4.2-10
296 Conflicts:      smtp-gated < 1.4.17-2
297 Conflicts:      socat < 1.7.2.0-2
298 Conflicts:      speech-dispatcher < 0.7.1-2
299 Conflicts:      sphinx < 2.0.3-4
300 Conflicts:      splashutils < 1.5.4.3-3
301 Conflicts:      stunnel < 4.50-2
302 Conflicts:      tenshi < 0.12-2
303 Conflicts:      tor < 0.2.2.35-2
304 Conflicts:      ucarp < 1.5.2-3
305 Conflicts:      udisks < 1.0.4-3
306 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
307 Conflicts:      vpnc < 0.5.3-2
308 Conflicts:      web2ldap < 1.1.0rc1-2
309 Conflicts:      wesnoth-server < 1:1.10-2
310 Conflicts:      wpa_supplicant < 0.7.3-10
311 Conflicts:      xl2tpd < 1.3.0-2
312
313 %description no-compat-tmpfiles
314 Force update of packages that provide tmpfiles.d configuration
315
316 %prep
317 %setup -q
318 %patch0 -p1
319 %patch1 -p1
320 %patch2 -p1
321 %patch3 -p1
322 %patch4 -p1
323 %patch5 -p1
324 cp -p %{SOURCE2} src/systemd_booted.c
325
326 %build
327 %{__aclocal} -I m4
328 %{__autoconf}
329 %{__autoheader}
330 %{__automake}
331 %configure \
332         %{__enable_disable audit} \
333         %{__enable_disable cryptsetup libcryptsetup} \
334         %{__enable_disable gtk} \
335         %{__enable_disable pam} \
336         %{__enable_disable plymouth} \
337         %{__enable_disable selinux} \
338         %{__enable_disable tcpd tcpwrap} \
339         --disable-silent-rules \
340         --disable-static \
341         --with-distro=pld \
342         --with-rootprefix= \
343         --with-rootlibdir=/%{_lib} \
344         --enable-split-usr
345
346 %{__make}
347 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
348
349 %install
350 rm -rf $RPM_BUILD_ROOT
351 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
352
353 %{__make} install \
354         DESTDIR=$RPM_BUILD_ROOT
355
356 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
357
358 # Main binary has been moved, but we don't want to break existing installs
359 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
360
361 # Create SysV compatibility symlinks. systemctl/systemd are smart
362 # enough to detect the way they were called
363 install -d $RPM_BUILD_ROOT/sbin
364 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
365 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
366 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
367 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
368 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
369 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
370 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
371
372 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
373
374 # disable redundant SYSV services
375 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
376 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
377 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
378 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
379 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
380 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
381
382 # add static (non-NetworkManager) networking
383 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
384
385 # install compatibility tmpfiles configs
386 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
387 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
388
389 # Install and enable storage subsystems support services (RAID, LVM, etc.)
390 install %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
391 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
392 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
393 install %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
394
395 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
396 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
397
398 # Make sure these directories are properly owned:
399 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
400 #       - syslog _might_ be used by some syslog implementation (none for now),
401 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
402 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
403
404 # Create new-style configuration files so that we can ghost-own them
405 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
406
407 # Install SysV conversion tool for systemd
408 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
409
410 install -d $RPM_BUILD_ROOT/var/log
411 :> $RPM_BUILD_ROOT/var/log/btmp
412 :> $RPM_BUILD_ROOT/var/log/wtmp
413
414 %if %{without gtk}
415 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
416 %endif
417
418 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
419 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
420 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
421
422 %clean
423 rm -rf $RPM_BUILD_ROOT
424
425 %post
426 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
427 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
428
429 %postun
430 if [ $1 -ge 1 ]; then
431         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
432 fi
433
434 %post   libs -p /sbin/ldconfig
435 %postun libs -p /sbin/ldconfig
436
437 %post units
438 if [ $1 -eq 1 ]; then
439         # Try to read default runlevel from the old inittab if it exists
440         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
441         if [ -z "$runlevel" ] ; then
442                 target="%{systemdunitdir}/graphical.target"
443         else
444                 target="%{systemdunitdir}/runlevel$runlevel.target"
445         fi
446
447         # And symlink what we found to the new-style default.target
448         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
449
450         # Setup hostname
451         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
452         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
453                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
454                 echo $HOSTNAME > /etc/hostname
455                 chmod 644 /etc/hostname
456         fi
457
458         # Enable the services we install by default.
459         /bin/systemctl enable \
460                 getty@.service \
461                 network.service \
462                 remote-fs.target \
463                 systemd-readahead-replay.service \
464                 systemd-readahead-collect.service >/dev/null 2>&1 || :
465 fi
466
467 %preun units
468 if [ $1 -eq 0 ] ; then
469         /bin/systemctl disable \
470                 getty@.service \
471                 network.service \
472                 remote-fs.target \
473                 systemd-readahead-replay.service \
474                 systemd-readahead-collect.service >/dev/null 2>&1 || :
475
476         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
477 fi
478
479 %postun units
480 if [ $1 -ge 1 ]; then
481         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
482 fi
483
484 %triggerpostun units -- %{name}-units < 43-7
485 # Remove design fialures
486 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
487 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
488 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
489 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
490
491 %post no-compat-tmpfiles
492 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
493
494 %files
495 %defattr(644,root,root,755)
496 %doc DISTRO_PORTING README TODO
497 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
498 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
499 /etc/dbus-1/system.d/org.freedesktop.login1.conf
500 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
501 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
502 %ghost %config(noreplace) %{_sysconfdir}/machine-id
503 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
504 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
505 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
506 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
507 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
508 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
509 %dir %{_sysconfdir}/systemd/user
510 %dir %{_sysconfdir}/systemd/system/*.target.wants
511 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
512 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
513 /etc/xdg/systemd
514 %attr(755,root,root) /bin/systemd
515 %attr(755,root,root) /bin/systemd-ask-password
516 %attr(755,root,root) /bin/systemd-journalctl
517 %attr(755,root,root) /bin/systemd-loginctl
518 %attr(755,root,root) /bin/systemd-machine-id-setup
519 %attr(755,root,root) /bin/systemd-notify
520 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
521 %attr(755,root,root) %{_bindir}/systemd-analyze
522 %attr(755,root,root) %{_bindir}/systemd-cat
523 %attr(755,root,root) %{_bindir}/systemd-cgtop
524 %attr(755,root,root) %{_bindir}/systemd-cgls
525 %attr(755,root,root) %{_bindir}/systemd-nspawn
526 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
527 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
528 %attr(755,root,root) /lib/systemd/pld-storage-init
529 %attr(755,root,root) /lib/systemd/systemd-*
530 %dir /lib/systemd/system-generators
531 %attr(755,root,root) /lib/systemd/systemd
532 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
533 %dir /lib/systemd/system-shutdown
534 /lib/udev/rules.d/99-systemd.rules
535 /lib/udev/rules.d/70-uaccess.rules
536 /lib/udev/rules.d/71-seat.rules
537 /lib/udev/rules.d/73-seat-late.rules
538 %dir %{_libexecdir}/systemd
539 %{_libexecdir}/systemd/user
540 %dir %{_libexecdir}/systemd/user-generators
541 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
542 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
543 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
544 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
545 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
546 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
547 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
548 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
549 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
550 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
551 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
552 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
553 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
554 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
555 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
556 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
557 %dir %{_datadir}/systemd
558 %{_datadir}/systemd/kbd-model-map
559 %{_mandir}/man1/systemd.1*
560 %{_mandir}/man1/systemd-*.1*
561 %{_mandir}/man5/binfmt.d.5*
562 %{_mandir}/man5/hostname.5*
563 %{_mandir}/man5/locale.conf.5*
564 %{_mandir}/man5/machine-id.5*
565 %{_mandir}/man5/machine-info.5*
566 %{_mandir}/man5/modules-load.d.5*
567 %{_mandir}/man5/os-release.5*
568 %{_mandir}/man5/sysctl.d.5*
569 %{_mandir}/man5/systemd.*.5*
570 %{_mandir}/man5/systemd-journald.conf.5*
571 %{_mandir}/man5/systemd-logind.conf.5*
572 %{_mandir}/man5/timezone.5*
573 %{_mandir}/man5/vconsole.conf.5*
574 %{_mandir}/man7/daemon.7*
575 %{_mandir}/man7/sd-daemon.7*
576 %{_mandir}/man7/sd-login.7*
577 %{_mandir}/man7/sd-readahead.7*
578 %{_mandir}/man7/systemd.special.7*
579 %dir /var/lib/%{name}
580 %dir /var/lib/%{name}/coredump
581 %attr(640,root,root) %ghost /var/log/btmp
582 %attr(664,root,utmp) %ghost /var/log/wtmp
583
584 %if %{with pam}
585 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
586 %{_mandir}/man8/pam_systemd.8*
587 %endif
588
589 %files init
590 %defattr(644,root,root,755)
591 %attr(755,root,root) /sbin/halt
592 %attr(755,root,root) /sbin/init
593 %attr(755,root,root) /sbin/poweroff
594 %attr(755,root,root) /sbin/reboot
595 %attr(755,root,root) /sbin/runlevel
596 %attr(755,root,root) /sbin/shutdown
597 %attr(755,root,root) /sbin/telinit
598 %{_mandir}/man1/init.1
599 %{_mandir}/man8/halt.8*
600 %{_mandir}/man8/poweroff.8
601 %{_mandir}/man8/reboot.8
602 %{_mandir}/man8/runlevel.8*
603 %{_mandir}/man8/shutdown.8*
604 %{_mandir}/man8/telinit.8*
605
606 %files units
607 %defattr(644,root,root,755)
608 %dir %{_sysconfdir}/binfmt.d
609 %dir %{_sysconfdir}/modules-load.d
610 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
611 %dir %{_sysconfdir}/sysctl.d
612 %dir %{_sysconfdir}/systemd
613 %dir %{_sysconfdir}/systemd/system
614 %dir %{_sysconfdir}/tmpfiles.d
615 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
616 %dir %{_libexecdir}/binfmt.d
617 %dir %{_libexecdir}/modules-load.d
618 %dir %{_libexecdir}/sysctl.d
619 %{_libexecdir}/sysctl.d/coredump.conf
620 %attr(755,root,root) /bin/systemctl
621 %attr(755,root,root) /bin/systemd-tmpfiles
622 %attr(755,root,root) /bin/systemd_booted
623 %{_mandir}/man1/systemctl.1*
624 %{_mandir}/man5/tmpfiles.d.5*
625 %{_mandir}/man8/systemd-tmpfiles.8*
626 %{_npkgconfigdir}/systemd.pc
627
628 %{systemdunitdir}/*.automount
629 %{systemdunitdir}/*.mount
630 %{systemdunitdir}/*.path
631 %{systemdunitdir}/*.service
632 %{systemdunitdir}/*.socket
633 %{systemdunitdir}/*.target
634 %{systemdunitdir}/*.timer
635 %if %{with plymouth}
636 %exclude %{systemdunitdir}/plymouth*.service
637 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
638 %endif
639 %dir %{systemdunitdir}/basic.target.wants
640 %dir %{systemdunitdir}/dbus.target.wants
641 %dir %{systemdunitdir}/final.target.wants
642 %dir %{systemdunitdir}/graphical.target.wants
643 %dir %{systemdunitdir}/halt.target.wants
644 %dir %{systemdunitdir}/kexec.target.wants
645 %dir %{systemdunitdir}/local-fs.target.wants
646 %dir %{systemdunitdir}/multi-user.target.wants
647 %dir %{systemdunitdir}/poweroff.target.wants
648 %dir %{systemdunitdir}/reboot.target.wants
649 %dir %{systemdunitdir}/runlevel[12345].target.wants
650 %dir %{systemdunitdir}/shutdown.target.wants
651 %dir %{systemdunitdir}/sockets.target.wants
652 %dir %{systemdunitdir}/sysinit.target.wants
653 %dir %{systemdunitdir}/syslog.target.wants
654 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
655 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
656 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
657 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
658 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
659 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
660 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
661 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
662 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
663 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
664 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
665 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
666 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
667 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
668 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
669 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
670 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
671 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
672
673 %if %{with plymouth}
674 %files plymouth
675 %defattr(644,root,root,755)
676 %{systemdunitdir}/plymouth-halt.service
677 %{systemdunitdir}/plymouth-kexec.service
678 %{systemdunitdir}/plymouth-poweroff.service
679 %{systemdunitdir}/plymouth-quit-wait.service
680 %{systemdunitdir}/plymouth-quit.service
681 %{systemdunitdir}/plymouth-read-write.service
682 %{systemdunitdir}/plymouth-reboot.service
683 %{systemdunitdir}/plymouth-start.service
684 %{systemdunitdir}/systemd-ask-password-plymouth.path
685 %{systemdunitdir}/systemd-ask-password-plymouth.service
686 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
687 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
688 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
689 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
690 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
691 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
692 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
693 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
694 %endif
695
696 %if %{with gtk}
697 %files gtk
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_bindir}/systemadm
700 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
701 %{_mandir}/man1/systemadm.1*
702 %endif
703
704 %files libs
705 %defattr(644,root,root,755)
706 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
707 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
708 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
709 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
710 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
711 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
712 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
713 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
714
715 %files devel
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
718 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
719 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
720 %attr(755,root,root) %{_libdir}/libsystemd-login.so
721 %{_includedir}/%{name}
722 %{_pkgconfigdir}/libsystemd-daemon.pc
723 %{_pkgconfigdir}/libsystemd-id128.pc
724 %{_pkgconfigdir}/libsystemd-journal.pc
725 %{_pkgconfigdir}/libsystemd-login.pc
726 %{_mandir}/man3/sd_booted.3*
727 %{_mandir}/man3/sd_get_seats.3*
728 %{_mandir}/man3/sd_get_sessions.3*
729 %{_mandir}/man3/sd_get_uids.3*
730 %{_mandir}/man3/sd_is_fifo.3*
731 %{_mandir}/man3/sd_is_mq.3*
732 %{_mandir}/man3/sd_is_socket.3
733 %{_mandir}/man3/sd_is_socket_inet.3
734 %{_mandir}/man3/sd_is_socket_unix.3
735 %{_mandir}/man3/sd_listen_fds.3*
736 %{_mandir}/man3/sd_login_monitor_flush.3*
737 %{_mandir}/man3/sd_login_monitor_get_fd.3*
738 %{_mandir}/man3/sd_login_monitor_new.3*
739 %{_mandir}/man3/sd_login_monitor_unref.3*
740 %{_mandir}/man3/sd_notify.3*
741 %{_mandir}/man3/sd_notifyf.3
742 %{_mandir}/man3/sd_pid_get_owner_uid.3*
743 %{_mandir}/man3/sd_pid_get_session.3*
744 %{_mandir}/man3/sd_pid_get_unit.3*
745 %{_mandir}/man3/sd_readahead.3*
746 %{_mandir}/man3/sd_seat_can_multi_session.3*
747 %{_mandir}/man3/sd_seat_get_active.3*
748 %{_mandir}/man3/sd_seat_get_sessions.3*
749 %{_mandir}/man3/sd_session_get_class.3*
750 %{_mandir}/man3/sd_session_get_display.3*
751 %{_mandir}/man3/sd_session_get_seat.3*
752 %{_mandir}/man3/sd_session_get_service.3*
753 %{_mandir}/man3/sd_session_get_type.3*
754 %{_mandir}/man3/sd_session_get_uid.3*
755 %{_mandir}/man3/sd_session_is_active.3*
756 %{_mandir}/man3/sd_uid_get_seats.3*
757 %{_mandir}/man3/sd_uid_get_sessions.3*
758 %{_mandir}/man3/sd_uid_get_state.3*
759 %{_mandir}/man3/sd_uid_is_on_seat.3*
760
761 %files -n bash-completion-systemd
762 %defattr(644,root,root,755)
763 /etc/bash_completion.d/systemd-bash-completion.sh
764
765 %files no-compat-tmpfiles
766 %defattr(644,root,root,755)
767 # empty package
This page took 0.091456 seconds and 3 git commands to generate.