]> git.pld-linux.org Git - packages/sysprof.git/blob - sysprof.spec
57d3ac65f0cef54c6b9613c9966336b7d1427826
[packages/sysprof.git] / sysprof.spec
1 #
2 # Conditional build:
3 %bcond_without  sysprofd        # daemon to run UI without root permissions
4 #
5 Summary:        Sampling CPU profiler for Linux
6 Summary(pl.UTF-8):      Próbkujący profiler procesora dla Linuksa
7 Name:           sysprof
8 Version:        3.42.0
9 Release:        1
10 License:        GPL v3+
11 Group:          Applications/System
12 Source0:        https://download.gnome.org/sources/sysprof/3.42/%{name}-%{version}.tar.xz
13 # Source0-md5:  061e2ea49672318370888311fe57ccef
14 URL:            http://www.sysprof.com/
15 BuildRequires:  cairo-devel
16 # -std=gnu11 + C11 atomics
17 BuildRequires:  gcc >= 6:4.9
18 BuildRequires:  gdk-pixbuf2-devel >= 2.0
19 BuildRequires:  gettext-tools >= 0.19.6
20 BuildRequires:  glib2-devel >= 1:2.67.4
21 BuildRequires:  gobject-introspection-devel >= 1.42.0
22 BuildRequires:  gtk+3-devel >= 3.22
23 BuildRequires:  json-glib-devel
24 BuildRequires:  libdazzle-devel >= 3.30.0
25 BuildRequires:  libstdc++-devel >= 6:4.7
26 BuildRequires:  libunwind-devel
27 BuildRequires:  meson >= 0.51.0
28 BuildRequires:  ninja >= 1.5
29 BuildRequires:  pango-devel
30 BuildRequires:  pkgconfig >= 1:0.22
31 %{?with_sysprofd:BuildRequires: polkit-devel >= 0.114}
32 BuildRequires:  rpmbuild(macros) >= 1.736
33 %{?with_sysprofd:BuildRequires: systemd-devel >= 1:222}
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  vala
36 BuildRequires:  xz
37 BuildRequires:  yelp-tools
38 Requires:       %{name}-libs = %{version}-%{release}
39 %{?with_sysprofd:Requires:      polkit >= 0.114}
40 %{?with_sysprofd:Requires:      systemd-units >= 1:222}
41 Requires:       uname(release) >= 2.6.31
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Sysprof is a sampling CPU profiler for Linux that uses a kernel module
46 to profile the entire system, not just a single application. Sysprof
47 handles shared libraries and applications do not need to be
48 recompiled. In fact they don't even have to be restarted.
49
50 Just insert the kernel module and start sysprof.
51
52 %description -l pl.UTF-8
53 Sysprof to próbkujący profiler procesora dla Linuksa wykorzystujący
54 moduł jądra do profilowania całego systemu, nie tylko pojedynczej
55 aplikacji. Sysprof obsługuje biblioteki współdzielone, a aplikacje nie
56 wymagają rekompilacji. Właściwie nawet nie trzeba ich restartować.
57
58 Wystarczy załadować moduł jądra i uruchomić sysprof.
59
60 %package libs
61 Summary:        The sysprof profiler library
62 Summary(pl.UTF-8):      Biblioteka profilera sysprof
63 Group:          Libraries
64 Requires:       glib2 >= 1:2.67.4
65
66 %description libs
67 The sysprof profiler library.
68
69 %description libs -l pl.UTF-8
70 Biblioteka profilera sysprof.
71
72 %package devel
73 Summary:        Header files for sysprof library
74 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof
75 Group:          Development/Libraries
76 Requires:       %{name}-libs = %{version}-%{release}
77 Requires:       glib2-devel >= 1:2.67.4
78 Obsoletes:      sysprof-static < 3.28.0
79
80 %description devel
81 Header files for sysprof library.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe biblioteki sysprof.
85
86 %package ui
87 Summary:        The sysprof graphical user interface
88 Summary(pl.UTF-8):      Graficzny interfejs użytkownika profilera sysprof
89 Group:          Applications/System
90 Requires(post,postun):  desktop-file-utils
91 Requires(post,postun):  glib2 >= 1:2.67.4
92 Requires(post,postun):  gtk-update-icon-cache
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       %{name}-ui-libs = %{version}-%{release}
95 Requires:       hicolor-icon-theme
96 Requires:       shared-mime-info
97
98 %description ui
99 The sysprof graphical user interface.
100
101 %description ui -l pl.UTF-8
102 Graficzny interfejs użytkownika profilera sysprof.
103
104 %package ui-libs
105 Summary:        The sysprof library containing reusable GTK+ widgets
106 Summary(pl.UTF-8):      Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku
107 Group:          X11/Libraries
108 Requires:       %{name}-libs = %{version}-%{release}
109 Requires:       gtk+3 >= 3.22
110 Requires:       libdazzle >= 3.30.0
111
112 %description ui-libs
113 The sysprof library containing reusable GTK+ widgets.
114
115 %description ui-libs -l pl.UTF-8
116 Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku.
117
118 %package ui-devel
119 Summary:        Header files for sysprof-ui library
120 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof-ui
121 Group:          X11/Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123 Requires:       %{name}-ui-libs = %{version}-%{release}
124 Requires:       gtk+3-devel >= 3.22
125 Obsoletes:      sysprof-ui-static < 3.28.0
126
127 %description ui-devel
128 Header files for sysprof-ui library.
129
130 %description ui-devel -l pl.UTF-8
131 Pliki nagłówkowe biblioteki sysprof-ui.
132
133 %prep
134 %setup -q
135
136 %build
137 %meson build \
138         %{!?with_sysprofd:-Dwith_sysprofd=host}
139
140 %ninja_build -C build
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %ninja_install -C build
146
147 %find_lang %{name} -o %{name}-ui.lang --with-gnome --without-mo
148 %find_lang %{name}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %if %{with sysprofd}
154 %post
155 %systemd_post sysprof2.service
156
157 %preun
158 %systemd_preun sysprof2.service
159
160 %postun
161 %systemd_reload
162 %endif
163
164 %post   libs -p /sbin/ldconfig
165 %postun libs -p /sbin/ldconfig
166
167 %post ui
168 %glib_compile_schemas
169 %update_icon_cache hicolor
170 %update_mime_database
171 %update_desktop_database
172
173 %postun ui
174 %glib_compile_schemas
175 %update_icon_cache hicolor
176 %update_mime_database
177 %update_desktop_database
178
179 %post   ui-libs -p /sbin/ldconfig
180 %postun ui-libs -p /sbin/ldconfig
181
182 %files -f %{name}.lang
183 %defattr(644,root,root,755)
184 %doc AUTHORS DESIGN.md NEWS README.md
185 %attr(755,root,root) %{_bindir}/sysprof-cli
186 %if %{with sysprofd}
187 %attr(755,root,root) %{_libexecdir}/sysprofd
188 %{systemdunitdir}/sysprof2.service
189 %{systemdunitdir}/sysprof3.service
190 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof2.service
191 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof3.service
192 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof2.conf
193 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof3.conf
194 %{_datadir}/polkit-1/actions/org.gnome.sysprof3.policy
195 %endif
196
197 %files libs
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/libsysprof-4.so
200 %attr(755,root,root) %{_libdir}/libsysprof-memory-4.so
201 %attr(755,root,root) %{_libdir}/libsysprof-speedtrack-4.so
202
203 %files devel
204 %defattr(644,root,root,755)
205 %{_libdir}/libsysprof-capture-4.a
206 %dir %{_includedir}/sysprof-4
207 %{_includedir}/sysprof-4/sysprof.h
208 %{_includedir}/sysprof-4/sysprof-address.h
209 %{_includedir}/sysprof-4/sysprof-battery-source.h
210 %{_includedir}/sysprof-4/sysprof-callgraph-profile.h
211 %{_includedir}/sysprof-4/sysprof-capture*.h
212 %{_includedir}/sysprof-4/sysprof-check.h
213 %{_includedir}/sysprof-4/sysprof-clock.h
214 %{_includedir}/sysprof-4/sysprof-collector.h
215 %{_includedir}/sysprof-4/sysprof-control-source.h
216 %{_includedir}/sysprof-4/sysprof-diskstat-source.h
217 %{_includedir}/sysprof-4/sysprof-elf-symbol-resolver.h
218 %{_includedir}/sysprof-4/sysprof-gjs-source.h
219 %{_includedir}/sysprof-4/sysprof-governor-source.h
220 %{_includedir}/sysprof-4/sysprof-hostinfo-source.h
221 %{_includedir}/sysprof-4/sysprof-jitmap-symbol-resolver.h
222 %{_includedir}/sysprof-4/sysprof-kernel-symbol.h
223 %{_includedir}/sysprof-4/sysprof-kernel-symbol-resolver.h
224 %{_includedir}/sysprof-4/sysprof-local-profiler.h
225 %{_includedir}/sysprof-4/sysprof-macros.h
226 %{_includedir}/sysprof-4/sysprof-memory-source.h
227 %{_includedir}/sysprof-4/sysprof-memprof-profile.h
228 %{_includedir}/sysprof-4/sysprof-memprof-source.h
229 %{_includedir}/sysprof-4/sysprof-model-filter.h
230 %{_includedir}/sysprof-4/sysprof-netdev-source.h
231 %{_includedir}/sysprof-4/sysprof-perf-counter.h
232 %{_includedir}/sysprof-4/sysprof-perf-source.h
233 %{_includedir}/sysprof-4/sysprof-platform.h
234 %{_includedir}/sysprof-4/sysprof-preload-source.h
235 %{_includedir}/sysprof-4/sysprof-proc-source.h
236 %{_includedir}/sysprof-4/sysprof-process-model.h
237 %{_includedir}/sysprof-4/sysprof-process-model-item.h
238 %{_includedir}/sysprof-4/sysprof-profile.h
239 %{_includedir}/sysprof-4/sysprof-profiler.h
240 %{_includedir}/sysprof-4/sysprof-proxy-source.h
241 %{_includedir}/sysprof-4/sysprof-selection.h
242 %{_includedir}/sysprof-4/sysprof-source.h
243 %{_includedir}/sysprof-4/sysprof-spawnable.h
244 %{_includedir}/sysprof-4/sysprof-symbol-resolver.h
245 %{_includedir}/sysprof-4/sysprof-symbols-source.h
246 %{_includedir}/sysprof-4/sysprof-tracefd-source.h
247 %{_includedir}/sysprof-4/sysprof-version.h
248 %{_includedir}/sysprof-4/sysprof-version-macros.h
249 %{_pkgconfigdir}/sysprof-4.pc
250 %{_pkgconfigdir}/sysprof-capture-4.pc
251 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof2.xml
252 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml
253 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml
254
255 %files ui -f %{name}-ui.lang
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_bindir}/sysprof
258 %{_datadir}/glib-2.0/schemas/org.gnome.sysprof3.gschema.xml
259 %{_datadir}/metainfo/org.gnome.Sysprof3.appdata.xml
260 %{_datadir}/mime/packages/sysprof-mime.xml
261 %{_desktopdir}/org.gnome.Sysprof3.desktop
262 %{_iconsdir}/hicolor/scalable/actions/sysprof-*.svg
263 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Sysprof.svg
264 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Sysprof-symbolic.svg
265
266 %files ui-libs
267 %defattr(644,root,root,755)
268 %attr(755,root,root) %{_libdir}/libsysprof-ui-4.so
269
270 %files ui-devel
271 %defattr(644,root,root,755)
272 %{_includedir}/sysprof-4/sysprof-display.h
273 %{_includedir}/sysprof-4/sysprof-notebook.h
274 %{_includedir}/sysprof-4/sysprof-page.h
275 %{_includedir}/sysprof-4/sysprof-process-model-row.h
276 %{_includedir}/sysprof-4/sysprof-ui.h
277 %{_includedir}/sysprof-4/sysprof-visualizer.h
278 %{_includedir}/sysprof-4/sysprof-visualizer-group.h
279 %{_includedir}/sysprof-4/sysprof-zoom-manager.h
280 %{_pkgconfigdir}/sysprof-ui-4.pc
This page took 0.068336 seconds and 2 git commands to generate.