]> git.pld-linux.org Git - packages/syslinux.git/blob - syslinux.spec
- updated to 6.02
[packages/syslinux.git] / syslinux.spec
1 #
2 # Conditional build:
3 %bcond_without  efi32   # EFI32 bootloader (requires x86_32 gnu-efi)
4 %bcond_without  efi64   # EFI64 bootloader (requires x86_64 gnu-efi)
5 #
6 %ifnarch %{ix86}
7 # %{x8664} also possible, but requires multilib gnu-efi
8 %undefine       with_efi32
9 %endif
10 %ifnarch %{x8664}
11 %undefine       with_efi64
12 %endif
13 Summary:        Simple bootloader
14 Summary(pl.UTF-8):      Prosty bootloader
15 Summary(pt_BR.UTF-8):   Carregador de boot simples
16 Summary(zh_CN.UTF-8):   Linux操作系统的启动管理器
17 Name:           syslinux
18 Version:        6.02
19 Release:        1
20 License:        GPL v2+
21 Group:          Applications/System
22 Source0:        https://www.kernel.org/pub/linux/utils/boot/syslinux/%{name}-%{version}.tar.xz
23 # Source0-md5:  6f275813a1b08cf852e55c0a3f8fbc78
24 URL:            http://syslinux.zytor.com/
25 BuildRequires:  gnu-efi
26 BuildRequires:  libuuid-devel
27 BuildRequires:  nasm
28 BuildRequires:  perl-base
29 BuildRequires:  perl-modules
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 Requires:       mtools
34 ExclusiveArch:  %{ix86} %{x8664}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _sbindir        /sbin
38
39 %description
40 SYSLINUX is a boot loader for the Linux operating system which
41 operates off MS-DOS floppies. It is intended to simplify first-time
42 installation of Linux, rescue disks, and other uses for boot floppies.
43 A SYSLINUX floppy can be manipulated using standard MS-DOS (or any
44 other OS that can access an MS-DOS filesystem) tools once it has been
45 created, and requires only a ~ 7K DOS program or ~ 13K Linux program
46 to create it in the first place. It also includes PXELINUX, a program
47 to boot off a network server using a boot PROM compatible with the
48 Intel PXE (Pre-Execution Environment) specification.
49
50 %description -l pl.UTF-8
51 SYSLINUX jest boot-loaderem dla Linuksa, który operuje na dyskietkach
52 z systemem plików MS-DOS. Jego przeznaczeniem jest uproszczenie
53 pierwszej instalacji Linuksa, dyskietki ratunkowe oraz inne rzeczy
54 związane z dyskietkami. Dyskietka syslinuksowa może być modyfikowana w
55 systemie MS-DOS (a także każdym innym systemie z dostępem do systemu
56 plików MS-DOS) gdy narzędzia są już stworzone, a także potrzebuje
57 tylko ~7K programu DOS-owego lub ~13K programu linuksowego do
58 stworzenia ich po raz pierwszy. Zawiera także program PXELINUX -
59 program służący do bootowania serwera sieciowego poprzez Boot-PROM
60 kompatybilny ze specyfikacją Intel PXE (Pre-Execution Environment).
61
62 %description -l pt_BR.UTF-8
63 SYSLINUX é um carregador de boot para o linux, operando em disquetes
64 com formatação DOS. Sua intenção é simplificar instalações do Linux,
65 discos de recuperação, e outros usos para disquetes de boot. Um
66 disquete SYSLINUX pode ser manipulado usando ferramentas padrão do DOS
67 (ou qualquer sistema que possa acessar um filesystem DOS) e requer
68 somente um programa DOS de aproximadamente 7K ou linux de 13K para
69 criá-lo na primeira vez.
70
71 Também inclui o PXELINUX, um programa para boot remoto a partir de um
72 servidor de rede usando um boot PROM compatível com a especificação
73 Intel PXE (Pre-Execution Environment).
74
75 %package devel
76 Summary:        Header files for syslinux libraries
77 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek syslinux
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description devel
82 This package includes the header files needed for compilation of
83 applications that are making use of the syslinux internals. Install
84 this package only if you plan to develop or will need to compile
85 customized syslinux clients.
86
87 %description devel -l pl.UTF-8
88 Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
89 aplikacji wykorzystujących kod syslinuksa. Należy go instalować tylko
90 jeśli chcemy tworzyć lub kompilować własnych klientów syslinuksa.
91
92 %prep
93 %setup -q
94
95 %{__sed} -i 's/-march=i386//' sample/Makefile
96
97 %build
98 for d in "bios installer" %{?with_efi32:efi32} %{?with_efi64:efi64} ; do
99 %{__make} -j1 $d \
100         CC="%{__cc}"
101 done
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name},%{_includedir}}
106 install bios/core/ldlinux.sys $RPM_BUILD_ROOT%{_datadir}/%{name}
107
108 %{__make} -j1 install \
109         firmware="bios %{?with_efi32:efi32} %{?with_efi64:efi64}" \
110         INSTALLROOT=$RPM_BUILD_ROOT \
111         LIBDIR=%{_libdir} \
112         MANDIR=%{_mandir}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc NEWS README* doc/*.txt
120 %attr(755,root,root) %{_sbindir}/extlinux
121 %attr(755,root,root) %{_bindir}/gethostip
122 %attr(755,root,root) %{_bindir}/isohybrid
123 %attr(755,root,root) %{_bindir}/isohybrid.pl
124 %attr(755,root,root) %{_bindir}/keytab-lilo
125 %attr(755,root,root) %{_bindir}/lss16toppm
126 %attr(755,root,root) %{_bindir}/md5pass
127 %attr(755,root,root) %{_bindir}/memdiskfind
128 %attr(755,root,root) %{_bindir}/mkdiskimage
129 %attr(755,root,root) %{_bindir}/ppmtolss16
130 %attr(755,root,root) %{_bindir}/pxelinux-options
131 %attr(755,root,root) %{_bindir}/sha1pass
132 %attr(755,root,root) %{_bindir}/syslinux
133 %attr(755,root,root) %{_bindir}/syslinux2ansi
134 %dir %{_datadir}/%{name}
135 %{_datadir}/%{name}/*.bin
136 %{_datadir}/%{name}/*.c32
137 %{_datadir}/%{name}/*.com
138 %{_datadir}/%{name}/dosutil
139 %{_datadir}/%{name}/gpxelinux.0
140 %{_datadir}/%{name}/gpxelinuxk.0
141 %{_datadir}/%{name}/ldlinux.sys
142 %{_datadir}/%{name}/lpxelinux.0
143 %{_datadir}/%{name}/memdisk
144 %{_datadir}/%{name}/pxelinux.0
145 %{_datadir}/%{name}/syslinux*.exe
146 %dir %{_datadir}/%{name}/diag
147 %{_datadir}/%{name}/diag/geodsp1s.img*
148 %{_datadir}/%{name}/diag/geodspms.img*
149 %{_datadir}/%{name}/diag/handoff.bin
150 %if %{with efi32}
151 %{_datadir}/%{name}/efi32
152 %endif
153 %if %{with efi64}
154 %{_datadir}/%{name}/efi64
155 %endif
156 %{_mandir}/man1/extlinux.1*
157 %{_mandir}/man1/gethostip.1*
158 %{_mandir}/man1/lss16toppm.1*
159 %{_mandir}/man1/ppmtolss16.1*
160 %{_mandir}/man1/syslinux.1*
161 %{_mandir}/man1/syslinux2ansi.1*
162
163 %files devel
164 %defattr(644,root,root,755)
165 %{_datadir}/%{name}/com32
This page took 0.071687 seconds and 3 git commands to generate.