]> git.pld-linux.org Git - packages/sysdig.git/blob - sysdig.spec
use system pkgs
[packages/sysdig.git] / sysdig.spec
1 Summary:        sysdig
2 Name:           sysdig
3 Version:        0.1.101
4 Release:        0.1
5 License:        GPL v2
6 Group:          Applications/System
7 Source0:        https://github.com/draios/sysdig/archive/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  5fe96a3a0fd98b2157a40cb29af41afc
9 URL:            http://www.sysdig.org/
10 BuildRequires:  cmake >= 2.8.2
11 BuildRequires:  gcc >= 6:4.4
12 BuildRequires:  jsoncpp-devel
13 BuildRequires:  luajit-devel
14 BuildRequires:  ncurses-devel
15 BuildRequires:  zlib-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Sysdig instruments your physical and virtual machines at the OS level
20 by installing into the Linux kernel and capturing system calls and
21 other OS events. Then, using sysdig's command line interface, you can
22 filter and decode these events in order to extract useful information.
23 Sysdig can be used to inspect systems live in real-time, or to
24 generate trace files that can be analyzed at a later stage.
25
26 %prep
27 %setup -q
28
29 %build
30 install -d build
31 cd build
32 %cmake \
33         -DBUILD_DRIVER=OFF \
34         -DUSE_BUNDLED_JSONCPP=OFF \
35         -DUSE_BUNDLED_LUAJIT=OFF \
36         -DUSE_BUNDLED_NCURSES=OFF \
37         -DUSE_BUNDLED_ZLIB=OFF \
38         ..
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 %{__make} -C build install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 mv $RPM_BUILD_ROOT%{_prefix}/src/sysdig* $RPM_BUILD_ROOT%{_prefix}/src/sysdig-%{version}
47 install -d $RPM_BUILD_ROOT%{_sysconfdir}
48 mv $RPM_BUILD_ROOT%{_prefix}/etc/bash_completion.d $RPM_BUILD_ROOT%{_sysconfdir}
49 rm -rf $RPM_BUILD_ROOT%{_datadir}/zsh
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %attr(755,root,root) %{_bindir}/csysdig
57 %attr(755,root,root) %{_bindir}/sysdig
58 %attr(755,root,root) %{_bindir}/sysdig-probe-loader
59 %{_mandir}/man8/csysdig.8*
60 %{_mandir}/man8/sysdig.8*
61 %{_datadir}/%{name}
62 %{_prefix}/src/sysdig-%{version}
63 /etc/bash_completion.d/sysdig
This page took 0.138943 seconds and 4 git commands to generate.