]> git.pld-linux.org Git - packages/synce-librapi2.git/blob - synce-librapi2.spec
- updated gettext BR
[packages/synce-librapi2.git] / synce-librapi2.spec
1 # TODO:
2 #       rm libstdc++-devel dependency - required only for tests programs
3 #
4 # Conditional build:
5 %bcond_without  dbus    # build without dbus support
6 %bcond_without  python  # build without python bindings
7 %bcond_with             hal     # build without HAL support
8 %bcond_without  udev    # build without UDEV support
9 %bcond_without  odccm   # build without odccm support
10
11 %if %{without dbus}
12 %undefine       with_odccm
13 %undefine       with_hal
14 %undefine       with_udev
15 %endif
16
17 Summary:        SynCE RAPI library
18 Summary(pl.UTF-8):      Biblioteka SynCE RAPI
19 Name:           synce-librapi2
20 Version:        0.15.2
21 Release:        4
22 License:        MIT
23 Group:          Libraries
24 Source0:        http://downloads.sourceforge.net/synce/librapi2-%{version}.tar.gz
25 # Source0-md5:  0a15bc22ee02794ca4714799611b4746
26 URL:            http://www.synce.org/
27 BuildRequires:  autoconf >= 2.50
28 BuildRequires:  automake >= 1.4
29 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.60}
30 BuildRequires:  gettext-tools
31 %{?with_hal:BuildRequires:      hal-devel}
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtool
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.559
36 %{?with_udev:BuildRequires:     udev-devel}
37 %if %{with python}
38 BuildRequires:  python-Pyrex
39 BuildRequires:  python-devel
40 BuildRequires:  rpm-pythonprov
41 # maybe temporaryliy, see https://bugs.launchpad.net/pld-linux/+bug/800148
42 BuildRequires:  python-modules
43 %endif
44 BuildRequires:  rpmbuild(macros) >= 1.213
45 BuildRequires:  synce-libsynce-devel >= 0.15
46 %requires_ge_to synce-libsynce synce-libsynce-devel
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 The RAPI library is an open source implementation that works like
51 RAPI.DLL, available on Microsoft operating systems. The library makes
52 it possible to make remote calls to a computer running Pocket PC.
53
54 %description -l pl.UTF-8
55 Biblioteka RAPI to otwarta implementacja działająca tak jak RAPI.DLL
56 dostępna w systemach operacyjnych Microsoftu. Biblioteka umożliwia
57 wykonywanie zdalnych odwołań do komputera Pocket PC.
58
59 %package devel
60 Summary:        Header files for RAPI library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki RAPI
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 %requires_eq    synce-libsynce-devel
65
66 %description devel
67 Header files for RAPI library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki RAPI.
71
72 %package static
73 Summary:        Static RAPI library
74 Summary(pl.UTF-8):      Statyczna biblioteka RAPI
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77
78 %description static
79 Static RAPI library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka RAPI.
83
84 %package -n python-pyrapi2
85 Summary:        Python bindinding for RAPI library
86 Summary(pl.UTF-8):      Wiązanie Pythona do biblioteki RAPI
87 Group:          Libraries/Python
88 Requires:       %{name} = %{version}-%{release}
89 %pyrequires_eq  python-libs
90
91 %description -n python-pyrapi2
92 Python bindinding for RAPI library.
93
94 %description -n python-pyrapi2 -l pl.UTF-8
95 Wiązanie Pythona do biblioteki RAPI.
96
97 %prep
98 %setup -q -n librapi2-%{version}
99
100 %build
101 %{__libtoolize}
102 %{__aclocal} -I m4
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         %{!?with_hal:--disable-hal-support}%{?with_hal:--enable-hal-support} \
108         %{!?with_odccm:--disable-odccm-support}%{?with_odccm:--enable-odccm-support} \
109         %{!?with_udev:--disable-udev-support}%{?with_udev:--enable-udev-support} \
110         %{!?with_python:--disable-python-bindings}%{?with_python:--enable-python-bindings}
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 rm -f $RPM_BUILD_ROOT%{py_sitedir}/pyrapi2.{la,a}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc BUGS ChangeLog README* TODO
131 %attr(755,root,root) %{_bindir}/pcp
132 %attr(755,root,root) %{_bindir}/pkillall
133 %attr(755,root,root) %{_bindir}/pls
134 %attr(755,root,root) %{_bindir}/pmkdir
135 %attr(755,root,root) %{_bindir}/pmv
136 %attr(755,root,root) %{_bindir}/prm
137 %attr(755,root,root) %{_bindir}/prmdir
138 %attr(755,root,root) %{_bindir}/prun
139 %attr(755,root,root) %{_bindir}/psettime
140 %attr(755,root,root) %{_bindir}/pshortcut
141 %attr(755,root,root) %{_bindir}/pstatus
142 %attr(755,root,root) %{_bindir}/rapiconfig
143 %attr(755,root,root) %{_bindir}/synce-database
144 %attr(755,root,root) %{_bindir}/synce-install-cab
145 %attr(755,root,root) %{_bindir}/synce-list-programs
146 %attr(755,root,root) %{_bindir}/synce-registry
147 %attr(755,root,root) %{_bindir}/synce-remove-program
148 %attr(755,root,root) %{_libdir}/librapi.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/librapi.so.2
150 %{_mandir}/man1/*.1*
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/librapi.so
155 %{_libdir}/librapi.la
156 %{_includedir}/irapistream.h
157 %{_includedir}/rapi.h
158 %{_includedir}/rapi2.h
159 %{_includedir}/rapitypes.h
160 %{_includedir}/rapitypes2.h
161 %{_pkgconfigdir}/librapi2.pc
162 %{_mandir}/man3/*
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/librapi.a
167
168 %if %{with python}
169 %files -n python-pyrapi2
170 %defattr(644,root,root,755)
171 %{py_sitedir}/pyrapi2.so
172 %endif
This page took 0.077153 seconds and 3 git commands to generate.