]> git.pld-linux.org Git - packages/swish-e.git/blob - swish-e.spec
e12b64329dff56645aa08ef6db02e360987731e7
[packages/swish-e.git] / swish-e.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do not perform "make test"
4
5 %define         rel     9
6 %define         snap    2014-09-14
7 %define         snapver %(echo %{snap} | tr -d '-')
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Simple Web Indexing System for Humans - Enhanced
10 Summary(pl.UTF-8):      Prosty system indeksowania stron WWW - wersja rozszerzona
11 Name:           swish-e
12 Version:        2.7.0
13 Release:        0.%{snapver}.%{rel}
14 License:        GPL/LGPL
15 Group:          Applications/Text
16 #Source0:       http://swish-e.org/distribution/%{name}-%{version}.tar.gz
17 Source0:        http://swish-e.org/swish-daily/%{name}-%{version}-%{snap}.tar.gz
18 # Source0-md5:  c6b918413382ff61eb5e224c8b4c6f7d
19 Patch0:         format-security.patch
20 Patch1:         namespace.patch
21 Patch2:         zlib-clash.patch
22 URL:            http://swish-e.org/
23 BuildRequires:  libxml2-devel
24 BuildRequires:  pcre-devel
25 BuildRequires:  rpm-perlprov
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Swish-e is Simple Web Indexing System for Humans - Enhanced.
31
32 Swish-e can quickly and easily index directories of files or remote
33 web sites and search the generated indexes.
34
35 Swish-e is extremely fast in both indexing and searching, highly
36 configurable, and can be seamlessly integrated with existing web sites
37 to maintain a consistent design. Swish-e can index web pages, but can
38 just as easily index text files, mailing list archives, or data stored
39 in a relational database.
40
41 Swish-e key features are:
42 - Emacs/Gnus mail index in cooordination with nnir.el
43 - Fast - many factors that affect speed, but a search on this server
44   that returns a thousand documents takes only a few seconds.
45 - Flexible - a number of configuration options provide you a high
46   degree of control over what is indexed and how.
47 - Powerful - the AND, OR and NOT operators are supported, words can be
48   truncated (using *), and searches can be limited to particular fields
49   (META tag fields, TITLEs, etc.)
50 - Free - nothing, zip, zero.
51 - It's made for Web sites - In indexing HTML files, SWISH-E can ignore
52   data in most tags while giving higher relevance to information in
53   header and title tags. Titles are extracted from HTML files and appear
54   in the search results. SWISH can automatically search your whole Web
55   site for you in one pass, if it's under one directory. You can also
56   limit your search to words in HTML titles, comments, emphasized tags,
57   and META tags. In addition, 8-bit HTML characters can be indexed,
58   converted, and searched.
59 - It creates portable indexes - Index files consist of only one file,
60   so they can be transported around and easily maintained.
61 - You can fix the source - We encourage people to send in patches and
62   suggestions on how to make SWISH-E better. You may want to join the
63   SWISH-E Discussion.
64
65 %description -l pl.UTF-8
66 Swish-e jest prostym systemem indeksującym WWW dla ludzi - w wersji
67 rozszerzonej.
68
69 Swish-e może zgrabnie i łatwo indeksować katalogi plików lub zdalne
70 strony WWW i przeszukiwać wygenerowane indeksy.
71
72 Swish-e jest ekstremalnie szybki zarówno w indeksowaniu i
73 wyszukiwaniu, mocno konfigurowalny, i może być łatwo zintegrowany z
74 istniejącymi stronami WWW w celu konfiguracji jego wyglądu. Swish-e
75 może indeksować nie tylko strony WWW, ale także pliki tekstowe,
76 archiwa list pocztowych lub dane przechowywane w relacyjnych bazach
77 danych.
78
79 Kluczowymi właściwościami swish-a są:
80 - Zgodne z Emacs/Gnus indeksowanie poczty w połączeniu z nnir.el
81 - Szybki - wiele współczynników ma wpływ na prędkość, ale wyszukiwanie
82   na serwerze zwracające tysiące dokumentów zabiera tylko kilka sekund.
83 - Elastyczny - duża liczba opcji konfiguracyjnych udostępnia wysoki
84   stopień możliwości określenia co i jak ma być indeksowane.
85 - Potężny - operatory AND, OR i NOT są obsługiwane, słowa mogą być
86   obcinane(korzystając z *), i wyszukiwanie ograniczane do konkretnych
87   pól (znaczniki META, tytuły itp.)
88 - Wolny - bezpłatny, darmowy, za friko.
89 - Stworzony dla stron WWW - indeksuje pliki HTML, może ignorować dane
90   w większości znaczników, przyznając większą wagę informacją w
91   nagłówkach i tytułach. Tytuły mogą być wyodrębniane z plików HTML i
92   pojawiać się w rezultatach wyszukiwania. SWISH może automatycznie
93   przeszukać całą stronę WWW w jednym przejściu, jeżeli jest w jednym
94   katalogu. Można także ograniczyć wyszukiwanie do słów w tytułach HTML,
95   komentarzach i znacznikach META. Dodatkowo - 8-bitowe znaki HTML mogą
96   być indeksowane, przekształcane i przeszukiwane.
97 - Tworzy przenośne indeksy - są zawarte w tylko jednym pliku, więc
98   mogą być łatwo transportowane i zarządzane.
99 - Można poprawić źródła - wszyscy są proszeni o wysyłanie łat i uwag
100   jak ulepszyć SWISH-E. Można się też przyłączyć do dyskusji na temat
101   SWISH-E.
102
103 %package doc
104 Summary:        Documentation for swish-e
105 Summary(pl.UTF-8):      Dokumentacja dla swish-e
106 Group:          Documentation
107
108 %description doc
109 SWISH-E documentation and examples
110
111 %description doc -l pl.UTF-8
112 Dokumentacja i przykłady dla SWISH-E
113
114 %package perl
115 Summary:        SWISH-E - Perl Scripts and Modules
116 Summary(pl.UTF-8):      SWISH-E - Skrypty i moduły dla Perla
117 Group:          Applications/Text
118 Requires:       %{name} = %{version}-%{release}
119
120 %description perl
121 Perl SWISH-E language bindings and scripts.
122
123 %description perl -l pl.UTF-8
124 Skrypty i moduły perlowe dla SWISH-E.
125
126 %package devel
127 Summary:        Header files for swish-e
128 Summary(pl.UTF-8):      Pliki nagłówkowe dla swish-e
129 Group:          Development/Libraries
130 Requires:       %{name} = %{version}-%{release}
131
132 %description devel
133 Header files for swish-e.
134
135 %description devel -l pl.UTF-8
136 Pliki nagłówkowe dla swish-e.
137
138 %package static
139 Summary:        Static library for swish-e
140 Summary(pl.UTF-8):      Biblioteka statyczna dla swish-e
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description static
145 Static library for swish-e.
146
147 %description static -l pl.UTF-8
148 Biblioteka statyczna dla swish-e.
149
150 %prep
151 %setup -q -n %{name}-%{version}-%{snap}
152 %patch0 -p1
153 %patch1 -p1
154 %patch2 -p1
155
156 %build
157 %configure \
158         --with-pcre
159 %{__make}
160 %{?with_tests:%{__make} test}
161
162 cd perl
163 echo skip | \
164 %{__perl} Makefile.PL \
165         INSTALLDIRS=vendor \
166         CCFLAGS="%{rpmcflags} -I../src" \
167         LIBS="%{rpmldflags} -L../src/.libs -lswish-e" \
168         SWISHINC=../src \
169         SWISHLIBS=-L../src/.libs \
170         SWISHVERSION=%{version} \
171         SWISHBINDIR=../src
172
173 %{__make}
174 %{?with_tests:%{__make} test}
175 cd ..
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179
180 %{__make} install \
181         DESTDIR=$RPM_BUILD_ROOT
182
183 mv $RPM_BUILD_ROOT%{_docdir}/%{name} %{name}-doc
184
185 %{__make} -C perl install \
186         DESTDIR=$RPM_BUILD_ROOT \
187         PREFIX=%{_prefix}
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %post   -p /sbin/ldconfig
193 %postun -p /sbin/ldconfig
194
195 %files
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/%{name}
198 %attr(755,root,root) %{_libdir}/libswish-e.so.*.*.*
199 %attr(755,root,root) %ghost %{_libdir}/libswish-e.so.2
200 %dir %{_prefix}/lib/swish-e
201 %{_mandir}/man?/*
202
203 %files doc
204 %defattr(644,root,root,755)
205 %doc %{name}-doc/*
206
207 %files perl
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_bindir}/swish-filter-test
210 %{_prefix}/lib/%{name}/perl
211 %attr(755,root,root) %{_prefix}/lib/%{name}/*.pl
212 %attr(755,root,root) %{_prefix}/lib/%{name}/*.cgi
213 %{_datadir}/swish-e
214 %dir %{perl_vendorarch}/SWISH
215 %{perl_vendorarch}/SWISH/*.pm
216 %dir %{perl_vendorarch}/auto/SWISH
217 %dir %{perl_vendorarch}/auto/SWISH/API
218 %attr(755,root,root) %{perl_vendorarch}/auto/SWISH/API/*.so
219
220 %files devel
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_bindir}/swish-config
223 %attr(755,root,root) %{_libdir}/libswish-e.so
224 %{_libdir}/libswish-e.la
225 %{_includedir}/*.h
226 %{_pkgconfigdir}/*.pc
227
228 %files static
229 %defattr(644,root,root,755)
230 %{_libdir}/libswish-e.a
This page took 0.034637 seconds and 2 git commands to generate.