]> git.pld-linux.org Git - packages/swish-e.git/blob - swish-e.spec
rebuild with perl 5.32
[packages/swish-e.git] / swish-e.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do not perform "make test"
4
5 %define         rel     12
6 %define         snap    2014-09-14
7 %define         snapver %(echo %{snap} | tr -d '-')
8 Summary:        Simple Web Indexing System for Humans - Enhanced
9 Summary(pl.UTF-8):      Prosty system indeksowania stron WWW - wersja rozszerzona
10 Name:           swish-e
11 Version:        2.7.0
12 Release:        0.%{snapver}.%{rel}
13 License:        GPL/LGPL
14 Group:          Applications/Text
15 #Source0:       http://swish-e.org/distribution/%{name}-%{version}.tar.gz
16 Source0:        http://swish-e.org/swish-daily/%{name}-%{version}-%{snap}.tar.gz
17 # Source0-md5:  c6b918413382ff61eb5e224c8b4c6f7d
18 Patch0:         format-security.patch
19 Patch1:         namespace.patch
20 Patch2:         zlib-clash.patch
21 URL:            http://swish-e.org/
22 BuildRequires:  libxml2-devel
23 BuildRequires:  pcre-devel
24 BuildRequires:  rpm-perlprov
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Swish-e is Simple Web Indexing System for Humans - Enhanced.
30
31 Swish-e can quickly and easily index directories of files or remote
32 web sites and search the generated indexes.
33
34 Swish-e is extremely fast in both indexing and searching, highly
35 configurable, and can be seamlessly integrated with existing web sites
36 to maintain a consistent design. Swish-e can index web pages, but can
37 just as easily index text files, mailing list archives, or data stored
38 in a relational database.
39
40 Swish-e key features are:
41 - Emacs/Gnus mail index in cooordination with nnir.el
42 - Fast - many factors that affect speed, but a search on this server
43   that returns a thousand documents takes only a few seconds.
44 - Flexible - a number of configuration options provide you a high
45   degree of control over what is indexed and how.
46 - Powerful - the AND, OR and NOT operators are supported, words can be
47   truncated (using *), and searches can be limited to particular fields
48   (META tag fields, TITLEs, etc.)
49 - Free - nothing, zip, zero.
50 - It's made for Web sites - In indexing HTML files, SWISH-E can ignore
51   data in most tags while giving higher relevance to information in
52   header and title tags. Titles are extracted from HTML files and appear
53   in the search results. SWISH can automatically search your whole Web
54   site for you in one pass, if it's under one directory. You can also
55   limit your search to words in HTML titles, comments, emphasized tags,
56   and META tags. In addition, 8-bit HTML characters can be indexed,
57   converted, and searched.
58 - It creates portable indexes - Index files consist of only one file,
59   so they can be transported around and easily maintained.
60 - You can fix the source - We encourage people to send in patches and
61   suggestions on how to make SWISH-E better. You may want to join the
62   SWISH-E Discussion.
63
64 %description -l pl.UTF-8
65 Swish-e jest prostym systemem indeksującym WWW dla ludzi - w wersji
66 rozszerzonej.
67
68 Swish-e może zgrabnie i łatwo indeksować katalogi plików lub zdalne
69 strony WWW i przeszukiwać wygenerowane indeksy.
70
71 Swish-e jest ekstremalnie szybki zarówno w indeksowaniu i
72 wyszukiwaniu, mocno konfigurowalny, i może być łatwo zintegrowany z
73 istniejącymi stronami WWW w celu konfiguracji jego wyglądu. Swish-e
74 może indeksować nie tylko strony WWW, ale także pliki tekstowe,
75 archiwa list pocztowych lub dane przechowywane w relacyjnych bazach
76 danych.
77
78 Kluczowymi właściwościami swish-a są:
79 - Zgodne z Emacs/Gnus indeksowanie poczty w połączeniu z nnir.el
80 - Szybki - wiele współczynników ma wpływ na prędkość, ale wyszukiwanie
81   na serwerze zwracające tysiące dokumentów zabiera tylko kilka sekund.
82 - Elastyczny - duża liczba opcji konfiguracyjnych udostępnia wysoki
83   stopień możliwości określenia co i jak ma być indeksowane.
84 - Potężny - operatory AND, OR i NOT są obsługiwane, słowa mogą być
85   obcinane(korzystając z *), i wyszukiwanie ograniczane do konkretnych
86   pól (znaczniki META, tytuły itp.)
87 - Wolny - bezpłatny, darmowy, za friko.
88 - Stworzony dla stron WWW - indeksuje pliki HTML, może ignorować dane
89   w większości znaczników, przyznając większą wagę informacją w
90   nagłówkach i tytułach. Tytuły mogą być wyodrębniane z plików HTML i
91   pojawiać się w rezultatach wyszukiwania. SWISH może automatycznie
92   przeszukać całą stronę WWW w jednym przejściu, jeżeli jest w jednym
93   katalogu. Można także ograniczyć wyszukiwanie do słów w tytułach HTML,
94   komentarzach i znacznikach META. Dodatkowo - 8-bitowe znaki HTML mogą
95   być indeksowane, przekształcane i przeszukiwane.
96 - Tworzy przenośne indeksy - są zawarte w tylko jednym pliku, więc
97   mogą być łatwo transportowane i zarządzane.
98 - Można poprawić źródła - wszyscy są proszeni o wysyłanie łat i uwag
99   jak ulepszyć SWISH-E. Można się też przyłączyć do dyskusji na temat
100   SWISH-E.
101
102 %package doc
103 Summary:        Documentation for swish-e
104 Summary(pl.UTF-8):      Dokumentacja dla swish-e
105 Group:          Documentation
106
107 %description doc
108 SWISH-E documentation and examples
109
110 %description doc -l pl.UTF-8
111 Dokumentacja i przykłady dla SWISH-E
112
113 %package perl
114 Summary:        SWISH-E - Perl Scripts and Modules
115 Summary(pl.UTF-8):      SWISH-E - Skrypty i moduły dla Perla
116 Group:          Applications/Text
117 Requires:       %{name} = %{version}-%{release}
118
119 %description perl
120 Perl SWISH-E language bindings and scripts.
121
122 %description perl -l pl.UTF-8
123 Skrypty i moduły perlowe dla SWISH-E.
124
125 %package devel
126 Summary:        Header files for swish-e
127 Summary(pl.UTF-8):      Pliki nagłówkowe dla swish-e
128 Group:          Development/Libraries
129 Requires:       %{name} = %{version}-%{release}
130
131 %description devel
132 Header files for swish-e.
133
134 %description devel -l pl.UTF-8
135 Pliki nagłówkowe dla swish-e.
136
137 %package static
138 Summary:        Static library for swish-e
139 Summary(pl.UTF-8):      Biblioteka statyczna dla swish-e
140 Group:          Development/Libraries
141 Requires:       %{name}-devel = %{version}-%{release}
142
143 %description static
144 Static library for swish-e.
145
146 %description static -l pl.UTF-8
147 Biblioteka statyczna dla swish-e.
148
149 %prep
150 %setup -q -n %{name}-%{version}-%{snap}
151 %patch0 -p1
152 %patch1 -p1
153 %patch2 -p1
154
155 %build
156 %configure \
157         --with-pcre
158 %{__make}
159 %{?with_tests:%{__make} test}
160
161 cd perl
162 echo skip | \
163 %{__perl} Makefile.PL \
164         INSTALLDIRS=vendor \
165         CCFLAGS="%{rpmcflags} -I../src" \
166         LIBS="%{rpmldflags} -L../src/.libs -lswish-e" \
167         SWISHINC=../src \
168         SWISHLIBS=-L../src/.libs \
169         SWISHVERSION=%{version} \
170         SWISHBINDIR=../src
171
172 %{__make}
173 %{?with_tests:%{__make} test}
174 cd ..
175
176 %install
177 rm -rf $RPM_BUILD_ROOT
178
179 %{__make} install \
180         DESTDIR=$RPM_BUILD_ROOT
181
182 mv $RPM_BUILD_ROOT%{_docdir}/%{name} %{name}-doc
183
184 %{__make} -C perl install \
185         DESTDIR=$RPM_BUILD_ROOT \
186         PREFIX=%{_prefix}
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %post   -p /sbin/ldconfig
192 %postun -p /sbin/ldconfig
193
194 %files
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_bindir}/%{name}
197 %attr(755,root,root) %{_libdir}/libswish-e.so.*.*.*
198 %attr(755,root,root) %ghost %{_libdir}/libswish-e.so.2
199 %dir %{_prefix}/lib/swish-e
200 %{_mandir}/man?/*
201
202 %files doc
203 %defattr(644,root,root,755)
204 %doc %{name}-doc/*
205
206 %files perl
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_bindir}/swish-filter-test
209 %{_prefix}/lib/%{name}/perl
210 %attr(755,root,root) %{_prefix}/lib/%{name}/*.pl
211 %attr(755,root,root) %{_prefix}/lib/%{name}/*.cgi
212 %{_datadir}/swish-e
213 %dir %{perl_vendorarch}/SWISH
214 %{perl_vendorarch}/SWISH/*.pm
215 %dir %{perl_vendorarch}/auto/SWISH
216 %dir %{perl_vendorarch}/auto/SWISH/API
217 %attr(755,root,root) %{perl_vendorarch}/auto/SWISH/API/*.so
218
219 %files devel
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_bindir}/swish-config
222 %attr(755,root,root) %{_libdir}/libswish-e.so
223 %{_libdir}/libswish-e.la
224 %{_includedir}/*.h
225 %{_pkgconfigdir}/*.pc
226
227 %files static
228 %defattr(644,root,root,755)
229 %{_libdir}/libswish-e.a
This page took 0.14348 seconds and 3 git commands to generate.