]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- updated to 1.3.20, updated php and php-vdecl patches
[packages/swig.git] / swig.spec
1 Summary:        Interface generator for Perl, Tcl, Guile and Python
2 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
3 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
4 Name:           swig
5 Version:        1.3.20
6 Release:        0.1
7 License:        distributable
8 Group:          Development/Languages
9 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
10 # Source0-md5:  aac11adef9f9709a75b9b0f676808d5f
11 Patch0:         %{name}-format.patch
12 Patch1:         %{name}-php.patch
13 Patch2:         %{name}-php-tsrm.patch
14 Patch3:         %{name}-php-freearg.patch
15 Patch4:         %{name}-php-vdecl.patch
16 URL:            http://www.swig.org/
17 Icon:           swig.gif
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  guile-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool
23 BuildRequires:  ocaml
24 BuildRequires:  perl-devel >= 5.6.1
25 BuildRequires:  php-devel >= 4.1.0
26 BuildRequires:  php-cgi
27 BuildRequires:  python-devel >= 2.3.2
28 BuildRequires:  ruby >= 1.6.3
29 BuildRequires:  tcl-devel >= 8.3.3
30 Obsoletes:      swig-ocaml
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 SWIG is a compiler that attempts to make it easy to integrate C, C++,
35 or Objective-C code with scripting languages including Perl, Tcl, and
36 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
37 and it generates an interface between C and your favorite scripting
38 language. However, this is only scratching the surface of what SWIG
39 can do--some of its more advanced features include automatic
40 documentation generation, module and library management, extensive
41 customization options, and more.
42
43 SWIG is entirely the product of users who have used the system and
44 suggested new idea. There are far too many people to thank
45 individually, but without this support, SWIG would be not be nearly as
46 powerful or fun to use as it is now. Many thanks!
47
48 %description -l pl
49 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
50 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
51 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
52 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
53 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
54 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
55 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
56 modu³ami i wiele innych.
57
58 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
59 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
60 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
61 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
62
63 %description -l pt_BR
64 O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo
65 com uma interface de descrição que consiste de uma combinação de C/C++
66 e diretivas especiais. Permite que linguagens tipo script usem C/C++
67 com um mínimo de esforço.
68
69 %package guile
70 Summary:        SWIG library: guile
71 Summary(pl):    Biblioteka SWIG: guile
72 Group:          Libraries
73
74 %description guile
75 SWIG library: guile.
76
77 %description guile -l pl
78 Biblioteka SWIG: guile.
79
80 %package perl
81 Summary:        SWIG library: Perl
82 Summary(pl):    Biblioteka SWIG: Perl
83 Group:          Libraries
84
85 %description perl
86 SWIG library: perl.
87
88 %description perl -l pl
89 Biblioteka SWIG: perl.
90
91 %package php
92 Summary:        SWIG library: php
93 Summary(pl):    Biblioteka SWIG: php
94 Group:          Libraries
95
96 %description php
97 SWIG library: php.
98
99 %description php -l pl
100 Biblioteka SWIG: php.
101
102 %package python
103 Summary:        SWIG library: python
104 Summary(pl):    Biblioteka SWIG: python
105 Group:          Libraries
106
107 %description python
108 SWIG library: python.
109
110 %description python -l pl
111 Biblioteka SWIG: python.
112
113 %package ruby
114 Summary:        SWIG library: ruby
115 Summary(pl):    Biblioteka SWIG: ruby
116 Group:          Libraries
117
118 %description ruby
119 SWIG library: ruby.
120
121 %description ruby -l pl
122 Biblioteka SWIG: ruby.
123
124 %package tcl
125 Summary:        SWIG library: tcl
126 Summary(pl):    Biblioteka SWIG: tcl
127 Group:          Libraries
128
129 %description tcl
130 SWIG library: tcl.
131
132 %description tcl -l pl
133 Biblioteka SWIG: tcl.
134
135 %prep
136 %setup -q -n SWIG-%{version}
137 %patch0 -p1
138 %patch1 -p1
139 %patch2 -p1
140 %patch3 -p1
141 %patch4 -p1
142
143 %build
144 %{__libtoolize}
145 %{__aclocal} -I Tools/config
146 %{__autoconf}
147 %configure
148
149 %{__make} source runtime \
150         OPT="%{rpmcflags}"
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
155
156 %{__make} install install-runtime \
157         DESTDIR=$RPM_BUILD_ROOT \
158         M4_INSTALL_DIR=$RPM_BUILD_ROOT%{_aclocaldir}
159
160 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %post   -p /sbin/ldconfig
166 %postun -p /sbin/ldconfig
167
168 %post   guile -p /sbin/ldconfig
169 %postun guile -p /sbin/ldconfig
170
171 %post   perl -p /sbin/ldconfig
172 %postun perl -p /sbin/ldconfig
173
174 %post   php -p /sbin/ldconfig
175 %postun php -p /sbin/ldconfig
176
177 %post   python -p /sbin/ldconfig
178 %postun python -p /sbin/ldconfig
179
180 %post   ruby -p /sbin/ldconfig
181 %postun ruby -p /sbin/ldconfig
182
183 %post   tcl -p /sbin/ldconfig
184 %postun tcl -p /sbin/ldconfig
185
186 %files
187 %defattr(644,root,root,755)
188 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
189 %{_libdir}/%{name}*
190 %attr(755,root,root) %{_bindir}/swig
191 %{_aclocaldir}/swig.m4
192 %{_examplesdir}/%{name}-%{version}
193
194 %files guile
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libswigguile*.so.*.*.*
197 %attr(755,root,root) %{_libdir}/libswigguile*.so
198 %{_libdir}/libswigguile*.la
199
200 %files perl
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libswigpl.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libswigpl.so
204 %{_libdir}/libswigpl.la
205
206 %files php
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/libswigphp4.so.*.*.*
209 %attr(755,root,root) %{_libdir}/libswigphp4.so
210 %{_libdir}/libswigphp4.la
211
212 %files python
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_libdir}/libswigpy.so.*.*.*
215 %attr(755,root,root) %{_libdir}/libswigpy.so
216 %{_libdir}/libswigpy.la
217
218 %files ruby
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/libswigrb.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libswigrb.so
222 %{_libdir}/libswigrb.la
223
224 %files tcl
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/libswigtcl*.so.*.*.*
227 %attr(755,root,root) %{_libdir}/libswigtcl*.so
228 %{_libdir}/libswigtcl*.la
This page took 0.073253 seconds and 4 git commands to generate.