]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- dropping lib64 patch (solved upstream)
[packages/swig.git] / swig.spec
1 #
2 # Conditional build:
3 %bcond_without  guile   # disable guile support
4 %bcond_without  ocaml   # disable ocaml support
5 %bcond_without  perl    # disable perl support
6 %bcond_without  php     # disable php support
7 %bcond_without  ruby    # disable ruby support
8 %bcond_without  tcl     # disable tcl support
9 #
10 Summary:        Interface generator for Perl, Tcl, Guile and Python
11 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
12 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
13 Name:           swig
14 Version:        1.3.25
15 Release:        2
16 License:        distributable
17 Group:          Development/Languages
18 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
19 # Source0-md5:  0a338d9de65e266338cbe7e2bea7a4a9
20 Patch0:         %{name}-format.patch
21 Patch1:         %{name}-php.patch
22 Patch2:         %{name}-php-freearg.patch
23 Patch3:         %{name}-php-vdecl.patch
24 URL:            http://www.swig.org/
25 Icon:           swig.gif
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 %{?with_guile:BuildRequires:    guile-devel}
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool
31 %{?with_ocaml:BuildRequires:    ocaml}
32 %{?with_perl:BuildRequires:     perl-devel >= 1:5.6.1}
33 %{?with_php:BuildRequires:      php-devel >= 4.1.0}
34 %{?with_php:BuildRequires:      php-cli}
35 BuildRequires:  python-devel >= 1:2.3.2
36 %{?with_ruby:BuildRequires:     ruby-devel >= 1:1.6.3}
37 %{?with_tcl:BuildRequires:      tcl-devel >= 8.3.3}
38 Obsoletes:      swig-ocaml
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 SWIG is a compiler that attempts to make it easy to integrate C, C++,
43 or Objective-C code with scripting languages including Perl, Tcl, and
44 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
45 and it generates an interface between C and your favorite scripting
46 language. However, this is only scratching the surface of what SWIG
47 can do--some of its more advanced features include automatic
48 documentation generation, module and library management, extensive
49 customization options, and more.
50
51 SWIG is entirely the product of users who have used the system and
52 suggested new idea. There are far too many people to thank
53 individually, but without this support, SWIG would be not be nearly as
54 powerful or fun to use as it is now. Many thanks!
55
56 %description -l pl
57 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
58 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
59 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
60 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
61 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
62 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
63 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
64 modu³ami i wiele innych.
65
66 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
67 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
68 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
69 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
70
71 %description -l pt_BR
72 O SWIG gera interfaces para perl, python e Tcl a partir de uma arquivo
73 com uma interface de descrição que consiste de uma combinação de C/C++
74 e diretivas especiais. Permite que linguagens tipo script usem C/C++
75 com um mínimo de esforço.
76
77 %package guile
78 Summary:        SWIG library: guile
79 Summary(pl):    Biblioteka SWIG: guile
80 Group:          Libraries
81 Requires:       %{name} = %{version}-%{release}
82
83 %description guile
84 SWIG library: guile.
85
86 %description guile -l pl
87 Biblioteka SWIG: guile.
88
89 %package perl
90 Summary:        SWIG library: Perl
91 Summary(pl):    Biblioteka SWIG: Perl
92 Group:          Libraries
93 Requires:       %{name} = %{version}-%{release}
94
95 %description perl
96 SWIG library: perl.
97
98 %description perl -l pl
99 Biblioteka SWIG: perl.
100
101 %package php
102 Summary:        SWIG library: php
103 Summary(pl):    Biblioteka SWIG: php
104 Group:          Libraries
105 Requires:       %{name} = %{version}-%{release}
106
107 %description php
108 SWIG library: php.
109
110 %description php -l pl
111 Biblioteka SWIG: php.
112
113 %package python
114 Summary:        SWIG library: python
115 Summary(pl):    Biblioteka SWIG: python
116 Group:          Libraries
117 Requires:       %{name} = %{version}-%{release}
118
119 %description python
120 SWIG library: python.
121
122 %description python -l pl
123 Biblioteka SWIG: python.
124
125 %package ruby
126 Summary:        SWIG library: ruby
127 Summary(pl):    Biblioteka SWIG: ruby
128 Group:          Libraries
129 Requires:       %{name} = %{version}-%{release}
130
131 %description ruby
132 SWIG library: ruby.
133
134 %description ruby -l pl
135 Biblioteka SWIG: ruby.
136
137 %package tcl
138 Summary:        SWIG library: tcl
139 Summary(pl):    Biblioteka SWIG: tcl
140 Group:          Libraries
141 Requires:       %{name} = %{version}-%{release}
142
143 %description tcl
144 SWIG library: tcl.
145
146 %description tcl -l pl
147 Biblioteka SWIG: tcl.
148
149 %prep
150 %setup -q
151 %patch0 -p1
152 %patch1 -p1
153 %patch2 -p1
154 %patch3 -p1
155
156 %build
157 %{__libtoolize}
158 %{__aclocal} -I Tools/config
159 %{__autoconf}
160 %{__automake}
161 %configure
162
163 %{__make} source \
164         OPT="%{rpmcflags}"
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
169
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT \
172         M4_INSTALL_DIR=$RPM_BUILD_ROOT%{_aclocaldir}
173
174 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %post   guile -p /sbin/ldconfig
183 %postun guile -p /sbin/ldconfig
184
185 %post   perl -p /sbin/ldconfig
186 %postun perl -p /sbin/ldconfig
187
188 %post   php -p /sbin/ldconfig
189 %postun php -p /sbin/ldconfig
190
191 %post   python -p /sbin/ldconfig
192 %postun python -p /sbin/ldconfig
193
194 %post   ruby -p /sbin/ldconfig
195 %postun ruby -p /sbin/ldconfig
196
197 %post   tcl -p /sbin/ldconfig
198 %postun tcl -p /sbin/ldconfig
199
200 %files
201 %defattr(644,root,root,755)
202 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
203 %attr(755,root,root) %{_bindir}/swig
204 %{_datadir}/%{name}
205 %{?with_guile:%exclude %{_datadir}/%{name}/%{version}/guile}
206 %{?with_perl:%exclude %{_datadir}/%{name}/%{version}/perl5}
207 %{?with_php:%exclude %{_datadir}/%{name}/%{version}/php4}
208 %exclude %{_datadir}/%{name}/%{version}/python
209 %{?with_ruby:%exclude %{_datadir}/%{name}/%{version}/ruby}
210 %{?with_tcl:%exclude %{_datadir}/%{name}/%{version}/tcl}
211 %{_examplesdir}/%{name}-%{version}
212
213 %if %{with guile}
214 %files guile
215 %defattr(644,root,root,755)
216 %{_datadir}/%{name}/%{version}/guile
217 %endif
218
219 %if %{with perl}
220 %files perl
221 %defattr(644,root,root,755)
222 %{_datadir}/%{name}/%{version}/perl5
223 %endif
224
225 %if %{with php}
226 %files php
227 %defattr(644,root,root,755)
228 %{_datadir}/%{name}/%{version}/php4
229 %endif
230
231 %files python
232 %defattr(644,root,root,755)
233 %{_datadir}/%{name}/%{version}/python
234
235 %if %{with ruby}
236 %files ruby
237 %defattr(644,root,root,755)
238 %{_datadir}/%{name}/%{version}/ruby
239 %endif
240
241 %if %{with tcl}
242 %files tcl
243 %defattr(644,root,root,755)
244 %{_datadir}/%{name}/%{version}/tcl
245 %endif
This page took 0.054484 seconds and 4 git commands to generate.