]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- freearg typemap fixed when using c++ default arguments
[packages/swig.git] / swig.spec
1
2 Summary:        Interface generator for Perl, Tcl, Guile and Python
3 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
4 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
5 Name:           swig
6 Version:        1.3.19
7 Release:        5
8 License:        distributable
9 Group:          Development/Languages
10 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
11 # Source0-md5:  a733455544426b31868dd87fc162e750
12 Patch0:         %{name}-format.patch
13 Patch1:         %{name}-php.patch
14 Patch2:         %{name}-php-tsrm.patch
15 Patch3:         %{name}-php-freearg.patch
16 URL:            http://www.swig.org/
17 Icon:           swig.gif
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  guile-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool
23 BuildRequires:  perl-devel >= 5.6.1
24 BuildRequires:  php-devel >= 4.1.0
25 BuildRequires:  php-cgi
26 BuildRequires:  python >= 2.2
27 BuildRequires:  ruby >= 1.6.3
28 BuildRequires:  tcl-devel >= 8.3.3
29 BuildRequires:  ocaml
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 SWIG is a compiler that attempts to make it easy to integrate C, C++,
34 or Objective-C code with scripting languages including Perl, Tcl, and
35 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
36 and it generates an interface between C and your favorite scripting
37 language. However, this is only scratching the surface of what SWIG
38 can do--some of its more advanced features include automatic
39 documentation generation, module and library management, extensive
40 customization options, and more.
41
42 SWIG is entirely the product of users who have used the system and
43 suggested new idea. There are far too many people to thank
44 individually, but without this support, SWIG would be not be nearly as
45 powerful or fun to use as it is now. Many thanks!
46
47 %description -l pl
48 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
49 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
50 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
51 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
52 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
53 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
54 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
55 modu³ami i wiele innych.
56
57 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
58 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
59 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
60 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
61
62 %description -l pt_BR
63 O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo
64 com uma interface de descrição que consiste de uma combinação de C/C++
65 e diretivas especiais. Permite que linguagens tipo script usem C/C++
66 com um mínimo de esforço.
67
68 %package guile
69 Summary:        SWIG library: guile
70 Summary(pl):    Biblioteka SWIG: guile
71 Group:          Libraries
72
73 %description guile
74 SWIG library: guile.
75
76 %description guile -l pl
77 Biblioteka SWIG: guile.
78
79 %package perl
80 Summary:        SWIG library: Perl
81 Summary(pl):    Biblioteka SWIG: Perl
82 Group:          Libraries
83
84 %description perl
85 SWIG library: perl.
86
87 %description perl -l pl
88 Biblioteka SWIG: perl.
89
90 %package php
91 Summary:        SWIG library: php
92 Summary(pl):    Biblioteka SWIG: php
93 Group:          Libraries
94
95 %description php
96 SWIG library: php.
97
98 %description php -l pl
99 Biblioteka SWIG: php.
100
101 %package python
102 Summary:        SWIG library: python
103 Summary(pl):    Biblioteka SWIG: python
104 Group:          Libraries
105
106 %description python
107 SWIG library: python.
108
109 %description python -l pl
110 Biblioteka SWIG: python.
111
112 %package ruby
113 Summary:        SWIG library: ruby
114 Summary(pl):    Biblioteka SWIG: ruby
115 Group:          Libraries
116
117 %description ruby
118 SWIG library: ruby.
119
120 %description ruby -l pl
121 Biblioteka SWIG: ruby.
122
123 %package tcl
124 Summary:        SWIG library: tcl
125 Summary(pl):    Biblioteka SWIG: tcl
126 Group:          Libraries
127
128 %description tcl
129 SWIG library: tcl.
130
131 %description tcl -l pl
132 Biblioteka SWIG: tcl.
133
134 %package ocaml
135 Summary:        SWIG library: ocaml
136 Summary(pl):    Biblioteka SWIG: ocaml
137 Group:          Libraries
138
139 %description ocaml
140 SWIG library: ocaml.
141
142 %description ocaml -l pl
143 Biblioteka SWIG: ocaml.
144
145 %prep
146 %setup -q -n SWIG-%{version}
147 %patch0 -p1
148 %patch1 -p1
149 %patch2 -p1
150 %patch3 -p1
151
152 %build
153 oldpwd=$PWD
154 for i in . Tools; do
155   cd $i
156   %{__libtoolize}
157   %{__aclocal}
158   %{__autoconf}
159   cd $oldpwd
160 done
161 %configure
162
163 %{__make} OPT="%{rpmcflags}"
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
168
169 %{__make} install \
170         DESTDIR=$RPM_BUILD_ROOT
171
172 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   -p /sbin/ldconfig
178 %postun -p /sbin/ldconfig
179
180 %files
181 %defattr(644,root,root,755)
182 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
183 %{_libdir}/%{name}*
184 %attr(755,root,root) %{_bindir}/swig
185 %{_examplesdir}/%{name}-%{version}
186
187 %files guile
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/lib*guile.so
190 %{_libdir}/lib*guile.la
191
192 %files perl
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/lib*pl.so
195 %{_libdir}/lib*pl.la
196
197 %files php
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/lib*php4.so
200 %{_libdir}/lib*php4.la
201
202 %files python
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/lib*py.so
205 %{_libdir}/lib*py.la
206
207 %files ruby
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/lib*rb.so
210 %{_libdir}/lib*rb.la
211
212 %files tcl
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_libdir}/lib*tcl*.so
215 %{_libdir}/lib*tcl*.la
216
217 %files ocaml
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/lib*ocaml*.so*
220 %{_libdir}/lib*ocaml*.la
This page took 0.039585 seconds and 4 git commands to generate.