]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- adapterized.
[packages/swig.git] / swig.spec
1 Summary:        Interface generator for Perl, Tcl, Guile and Python
2 Summary(pl):    Generator interfejsu do Perl'a, Tcl'a, Guile'a i Python'a
3 Name:           swig
4 Version:        1.3a5
5 Release:        0.2
6 License:        distributable
7 Group:          Development/Languages
8 Source0:        http://prdownloads.sourceforge.net/swig/%{name}%{version}.tar.gz
9 Patch0:         %{name}1.1p2-fixed-paths.patch
10 Patch1:         %{name}-python.patch
11 Patch2:         %{name}-configure.patch
12 URL:            http://www.swig.org
13 BuildRequires:  python >= 2.1
14 BuildRequires:  ruby >= 1.6.3
15 BuildRequires:  perl-devel >= 5.6.1
16 BuildRequires:  tcl >= 8.3.3
17 Icon:           swig.gif
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 SWIG is a compiler that attempts to make it easy to integrate C, C++,
22 or Objective-C code with scripting languages including Perl, Tcl, and
23 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
24 and it generates an interface between C and your favorite scripting
25 language. However, this is only scratching the surface of what SWIG
26 can do--some of its more advanced features include automatic
27 documentation generation, module and library management, extensive
28 customization options, and more.
29
30 SWIG is entirely the product of users who have used the system and
31 suggested new idea. There are far too many people to thank
32 individually, but without this support, SWIG would be not be nearly as
33 powerful or fun to use as it is now. Many thanks!
34
35 %description -l pl
36 SWIG jesk kompilatorem, który próbuje ulatwic integrowanie kodu
37 napisanego w C, C++ lub Objective-C z jêzykami skryptowymitakimi jak
38 Perl, Tcl i Python. Mówi±c najpro¶ciej, jesli dostarczysz mu zestaw
39 zdeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
40 pomiedzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
41 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
42 to automatyczne generowanie dokumentacji, zarzadzanie bibliotekami i
43 modu³ami i wiele innych.
44
45 SWIG jest w ca³o¶ci dzi³em ludzi, którzy go u¿ywali i wprowadzali nowe
46 pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich osobno, ale
47 bez ich wsparcia, SWIG nie by³by anie tak pote¿nym na¿edziem, ani tak
48 fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
49
50 %prep
51 %setup -q -n SWIG%{version}
52 find Examples/ -type l -exec rm -v {} \;
53 perl -pi -e 's|^\s*BIN_DIR\s*=\s*\@bindir\@|BIN_DIR = $(prefix)/@bindir@/|' Makefile.in
54 %patch1 -p1
55 %patch2 -p1
56
57 %build
58 autoconf
59 (cd Source/DOH && autoconf)
60 (cd Tools && autoconf)
61 %configure
62 %{__make} OPT="%{rpmcflags}"
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT/{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
67
68 %{__make} install \
69         prefix=$RPM_BUILD_ROOT/%{_prefix} \
70         BIN_DIR=$RPM_BUILD_ROOT/%{_bindir}
71
72 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74 gzip -9nf CHANGES NEW README ANNOUNCE TODO LICENSE
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc Doc *.gz
82 %{_libdir}/%{name}*
83 %attr(755,root,root) %{_bindir}/swig
84 %{_examplesdir}/%{name}-%{version}
This page took 0.070708 seconds and 4 git commands to generate.