]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- tsrm.patch that fix building php subpackage
[packages/swig.git] / swig.spec
1
2 Summary:        Interface generator for Perl, Tcl, Guile and Python
3 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
4 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
5 Name:           swig
6 Version:        1.3.19
7 Release:        4
8 License:        distributable
9 Group:          Development/Languages
10 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
11 # Source0-md5:  a733455544426b31868dd87fc162e750
12 Patch0:         %{name}-format.patch
13 Patch1:         %{name}-php.patch
14 Patch2:         %{name}-php-tsrm.patch
15 URL:            http://www.swig.org/
16 Icon:           swig.gif
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  guile-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool
22 BuildRequires:  perl-devel >= 5.6.1
23 BuildRequires:  php-devel >= 4.1.0
24 BuildRequires:  php-cgi
25 BuildRequires:  python >= 2.2
26 BuildRequires:  ruby >= 1.6.3
27 BuildRequires:  tcl-devel >= 8.3.3
28 BuildRequires:  ocaml
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 SWIG is a compiler that attempts to make it easy to integrate C, C++,
33 or Objective-C code with scripting languages including Perl, Tcl, and
34 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
35 and it generates an interface between C and your favorite scripting
36 language. However, this is only scratching the surface of what SWIG
37 can do--some of its more advanced features include automatic
38 documentation generation, module and library management, extensive
39 customization options, and more.
40
41 SWIG is entirely the product of users who have used the system and
42 suggested new idea. There are far too many people to thank
43 individually, but without this support, SWIG would be not be nearly as
44 powerful or fun to use as it is now. Many thanks!
45
46 %description -l pl
47 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
48 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
49 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
50 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
51 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
52 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
53 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
54 modu³ami i wiele innych.
55
56 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
57 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
58 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
59 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
60
61 %description -l pt_BR
62 O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo
63 com uma interface de descrição que consiste de uma combinação de C/C++
64 e diretivas especiais. Permite que linguagens tipo script usem C/C++
65 com um mínimo de esforço.
66
67 %package guile
68 Summary:        SWIG library: guile
69 Summary(pl):    Biblioteka SWIG: guile
70 Group:          Libraries
71
72 %description guile
73 SWIG library: guile.
74
75 %description guile -l pl
76 Biblioteka SWIG: guile.
77
78 %package perl
79 Summary:        SWIG library: Perl
80 Summary(pl):    Biblioteka SWIG: Perl
81 Group:          Libraries
82
83 %description perl
84 SWIG library: perl.
85
86 %description perl -l pl
87 Biblioteka SWIG: perl.
88
89 %package php
90 Summary:        SWIG library: php
91 Summary(pl):    Biblioteka SWIG: php
92 Group:          Libraries
93
94 %description php
95 SWIG library: php.
96
97 %description php -l pl
98 Biblioteka SWIG: php.
99
100 %package python
101 Summary:        SWIG library: python
102 Summary(pl):    Biblioteka SWIG: python
103 Group:          Libraries
104
105 %description python
106 SWIG library: python.
107
108 %description python -l pl
109 Biblioteka SWIG: python.
110
111 %package ruby
112 Summary:        SWIG library: ruby
113 Summary(pl):    Biblioteka SWIG: ruby
114 Group:          Libraries
115
116 %description ruby
117 SWIG library: ruby.
118
119 %description ruby -l pl
120 Biblioteka SWIG: ruby.
121
122 %package tcl
123 Summary:        SWIG library: tcl
124 Summary(pl):    Biblioteka SWIG: tcl
125 Group:          Libraries
126
127 %description tcl
128 SWIG library: tcl.
129
130 %description tcl -l pl
131 Biblioteka SWIG: tcl.
132
133 %package ocaml
134 Summary:        SWIG library: ocaml
135 Summary(pl):    Biblioteka SWIG: ocaml
136 Group:          Libraries
137
138 %description ocaml
139 SWIG library: ocaml.
140
141 %description ocaml -l pl
142 Biblioteka SWIG: ocaml.
143
144 %prep
145 %setup -q -n SWIG-%{version}
146 %patch0 -p1
147 %patch1 -p1
148 %patch2 -p1
149
150 %build
151 oldpwd=$PWD
152 for i in . Tools; do
153   cd $i
154   %{__libtoolize}
155   %{__aclocal}
156   %{__autoconf}
157   cd $oldpwd
158 done
159 %configure
160
161 %{__make} OPT="%{rpmcflags}"
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
166
167 %{__make} install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post   -p /sbin/ldconfig
176 %postun -p /sbin/ldconfig
177
178 %files
179 %defattr(644,root,root,755)
180 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
181 %{_libdir}/%{name}*
182 %attr(755,root,root) %{_bindir}/swig
183 %{_examplesdir}/%{name}-%{version}
184
185 %files guile
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/lib*guile.so
188 %{_libdir}/lib*guile.la
189
190 %files perl
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/lib*pl.so
193 %{_libdir}/lib*pl.la
194
195 %files php
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/lib*php4.so
198 %{_libdir}/lib*php4.la
199
200 %files python
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/lib*py.so
203 %{_libdir}/lib*py.la
204
205 %files ruby
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_libdir}/lib*rb.so
208 %{_libdir}/lib*rb.la
209
210 %files tcl
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/lib*tcl*.so
213 %{_libdir}/lib*tcl*.la
214
215 %files ocaml
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/lib*ocaml*.so*
218 %{_libdir}/lib*ocaml*.la
This page took 0.075351 seconds and 4 git commands to generate.