]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- updated Source0 URL
[packages/swig.git] / swig.spec
1 Summary:        Interface generator for Perl, Tcl, Guile and Python
2 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
3 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
4 Name:           swig
5 Version:        1.3.17
6 Release:        1
7 License:        distributable
8 Group:          Development/Languages
9 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
10 URL:            http://www.swig.org/
11 Icon:           swig.gif
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  guile-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool
17 BuildRequires:  perl-devel >= 5.6.1
18 BuildRequires:  php-devel >= 4.1.0
19 BuildRequires:  python >= 2.2
20 BuildRequires:  ruby >= 1.6.3
21 BuildRequires:  tcl >= 8.3.3
22 BuildRequires:  ocaml
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 SWIG is a compiler that attempts to make it easy to integrate C, C++,
27 or Objective-C code with scripting languages including Perl, Tcl, and
28 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
29 and it generates an interface between C and your favorite scripting
30 language. However, this is only scratching the surface of what SWIG
31 can do--some of its more advanced features include automatic
32 documentation generation, module and library management, extensive
33 customization options, and more.
34
35 SWIG is entirely the product of users who have used the system and
36 suggested new idea. There are far too many people to thank
37 individually, but without this support, SWIG would be not be nearly as
38 powerful or fun to use as it is now. Many thanks!
39
40 %description -l pl
41 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
42 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
43 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
44 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
45 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
46 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
47 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
48 modu³ami i wiele innych.
49
50 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
51 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
52 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
53 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
54
55 %description -l pt_BR
56 O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo
57 com uma interface de descrição que consiste de uma combinação de C/C++
58 e diretivas especiais. Permite que linguagens tipo script usem C/C++
59 com um mínimo de esforço.
60
61 %package guile
62 Summary:        SWIG library: guile
63 Summary(pl):    Biblioteka SWIG: guile
64 Group:          Libraries
65
66 %description guile
67 SWIG library: guile.
68
69 %description guile -l pl
70 Biblioteka SWIG: guile.
71
72 %package perl
73 Summary:        SWIG library: Perl
74 Summary(pl):    Biblioteka SWIG: Perl
75 Group:          Libraries
76
77 %description perl
78 SWIG library: perl.
79
80 %description perl -l pl
81 Biblioteka SWIG: perl.
82
83 %package python
84 Summary:        SWIG library: python
85 Summary(pl):    Biblioteka SWIG: python
86 Group:          Libraries
87
88 %description python
89 SWIG library: python.
90
91 %description python -l pl
92 Biblioteka SWIG: python.
93
94 %package ruby
95 Summary:        SWIG library: ruby
96 Summary(pl):    Biblioteka SWIG: ruby
97 Group:          Libraries
98
99 %description ruby
100 SWIG library: ruby.
101
102 %description ruby -l pl
103 Biblioteka SWIG: ruby.
104
105 %package tcl
106 Summary:        SWIG library: tcl
107 Summary(pl):    Biblioteka SWIG: tcl
108 Group:          Libraries
109
110 %description tcl
111 SWIG library: tcl.
112
113 %description tcl -l pl
114 Biblioteka SWIG: tcl.
115
116 %package ocaml
117 Summary:        SWIG library: ocaml
118 Summary(pl):    Biblioteka SWIG: ocaml
119 Group:          Libraries
120
121 %description ocaml
122 SWIG library: ocaml.
123
124 %description ocaml -l pl
125 Biblioteka SWIG: ocaml.
126
127 %prep
128 %setup -q -n SWIG-%{version}
129
130 %build
131 oldpwd=$PWD
132 for i in . Source/DOH Tools Examples/GIFPlot; do
133   cd $i
134   %{__libtoolize}
135   %{__aclocal}
136   %{__autoconf}
137   cd $oldpwd
138 done
139 %configure
140
141 %{__make} OPT="%{rpmcflags}"
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
161 %{_libdir}/%{name}*
162 %attr(755,root,root) %{_bindir}/swig
163 %{_examplesdir}/%{name}-%{version}
164
165 %files guile
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/lib*guile.so
168 %{_libdir}/lib*guile.la
169
170 %files perl
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/lib*pl.so
173 %{_libdir}/lib*pl.la
174
175 %files python
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/lib*py.so
178 %{_libdir}/lib*py.la
179
180 %files ruby
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/lib*rb.so
183 %{_libdir}/lib*rb.la
184
185 %files tcl
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/lib*tcl*.so
188 %{_libdir}/lib*tcl*.la
189
190 %files ocaml
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/lib*ocaml*.so*
193 %{_libdir}/lib*ocaml*.la
This page took 0.092138 seconds and 4 git commands to generate.