]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
noarch bash completions
[packages/subversion.git] / subversion.spec
1 # Conditional build:
2 %bcond_with     net_client_only         # build only net client
3 %bcond_without  swig                    # disable bindings generation with Swig
4 %bcond_without  python                  # build without Python bindings (broken)
5 %bcond_without  csvn                    # build Python csvn bindings
6 %bcond_without  perl                    # build without Perl bindings
7 %bcond_without  ruby                    # build without Ruby bindings
8 %bcond_without  apache                  # build without Apache support (webdav, etc)
9 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
10 %bcond_without  tests                   # don't perform "make check"
11 %bcond_without  kwallet                 # build without kde4 wallet support
12 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
13 %bcond_without  gnome                   # build without gnome keyring support
14 %bcond_without  db                      # disable Subversion Berkeley DB based filesystem library
15 %bcond_with     db6                     # allow BDB6 (not tested by upstream, released on AGPL)
16
17 # for AC: --without csvn,gnome,javahl,kde,ruby
18
19 %if %{with net_client_only}
20 %undefine       with_apache
21 %undefine       with_db
22 %undefine       with_swig
23 %undefine       with_javahl
24 %endif
25
26 %if %{without swig}
27 %undefine       with_perl
28 %undefine       with_python
29 %undefine       with_ruby
30 %endif
31
32 %if %{without kde}
33 %undefine       with_kwallet
34 %endif
35
36 %if %{without python} && %{without perl} && %{without ruby}
37 %undefine       with_swig
38 %endif
39
40 %define apxs    /usr/sbin/apxs
41 %define pdir    SVN
42 %define pnam    _Core
43
44 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
45 Summary:        A Concurrent Versioning system similar to but better than CVS
46 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
47 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
48 Name:           subversion
49 Version:        1.8.8
50 Release:        1
51 License:        Apache v2.0
52 Group:          Development/Version Control
53 Source0:        http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
54 # Source0-md5:  db04a587c68e38da6d0e342e6508f514
55 Source1:        %{name}-dav_svn.conf
56 Source2:        %{name}-authz_svn.conf
57 Source3:        %{name}-svnserve.init
58 Source4:        %{name}-svnserve.sysconfig
59 # current subversion tarball has correct *.swg files
60 # but after regeneration these are broken again, so
61 # we still need this script
62 Source5:        %{name}-convert-typemaps-to-ifdef.py
63 Patch0:         %{name}-home_etc.patch
64 Patch1:         %{name}-DESTDIR.patch
65 Patch2:         %{name}-ruby-datadir-path.patch
66 Patch3:         %{name}-tests.patch
67 URL:            http://subversion.apache.org/
68 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
69 BuildRequires:  apr-devel >= 1:1.0.0
70 BuildRequires:  apr-util-devel >= 1:1.2.8-3
71 BuildRequires:  autoconf >= 2.59
72 BuildRequires:  automake
73 BuildRequires:  bison
74 BuildRequires:  cyrus-sasl-devel
75 %if %{with kwallet} || %{with gnome}
76 BuildRequires:  dbus-devel
77 %endif
78 BuildRequires:  db-devel >= 4.1.25
79 BuildRequires:  expat-devel
80 BuildRequires:  gettext-devel
81 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
82 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
83 BuildRequires:  libmagic-devel
84 BuildRequires:  libtool >= 1.4-9
85 BuildRequires:  pkgconfig
86 %{?with_csvn:BuildRequires:     python-ctypesgen}
87 BuildRequires:  rpm-pythonprov
88 BuildRequires:  rpmbuild(macros) >= 1.656
89 BuildRequires:  sed >= 4.0
90 BuildRequires:  serf-devel >= 1.2.1
91 BuildRequires:  sqlite3-devel >= 3.6.18
92 BuildRequires:  texinfo
93 BuildRequires:  which
94 %if %{with javahl}
95 BuildRequires:  jdk >= 1.5
96 BuildRequires:  libstdc++-devel
97 %endif
98 %if %{with perl}
99 BuildRequires:  perl-devel >= 1:5.8.0
100 BuildRequires:  rpm-perlprov >= 4.1-13
101 BuildRequires:  swig-perl >= 1.3.24
102 %endif
103 %if %{with python}
104 BuildRequires:  python-devel >= 1:2.4
105 BuildRequires:  swig-python >= 1.3.24
106 %endif
107 %if %{with ruby}
108 BuildRequires:  rpm-rubyprov
109 BuildRequires:  ruby-devel >= 1:1.8.2
110 BuildRequires:  ruby-irb
111 BuildRequires:  ruby-rubygems
112 BuildRequires:  swig-ruby >= 1.3.24
113 %endif
114 Requires:       %{name}-libs = %{version}-%{release}
115 %requires_ge    sqlite3
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %define         _libexecdir             %{_libdir}/svn
119 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
120 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
121
122 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
123
124 %description
125 The goal of the Subversion project is to build a version control
126 system that is a compelling replacement for CVS in the open source
127 community.
128
129 Our goals are:
130 - All current CVS features.
131 - Directories, renames, and file meta-data are versioned.
132 - Symbolic links, etc, are supported
133 - Commits are truly atomic.
134 - Branching and tagging are cheap (constant time) operations
135 - Repeated merges are handled gracefully
136 - Support for plug-in client side diff programs
137 - Natively client/server
138 - Client/server protocol sends diffs in both directions
139 - Costs are proportional to change size, not project size
140 - Internationalization
141 - Progressive multi-lingual support
142
143 %description -l pl.UTF-8
144 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
145 zamiennika dla CVS.
146
147 Cele projektu to:
148 - Wszystkie aktualne możliwości CVS.
149 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
150 - Obsługa dowiązań symbolicznych itp.
151 - Commity są w pełni atomowe.
152 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
153 - Dobra obsługa powtarzanego łączenia (merge).
154 - Obsługa wtyczek diff po stronie klienta.
155 - Natywny klient/serwer.
156 - Klient/Serwer przesyłają diffy w obu kierunkach.
157 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
158 - Internacjonalizacja.
159 - Postępujące wsparcie dla wielu języków.
160
161 %description -l pt_BR.UTF-8
162 O objetivo do projeto Subversion é construir um sistema de controle de
163 versões que seja um substituto para o CVS (Concurrent Versioning
164 System) na comunidade opensource, fornecendo grandes melhorias.
165
166 %package libs
167 Summary:        Subversion libraries and modules
168 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
169 Group:          Libraries
170 Requires:       serf >= 1.2.1
171 Obsoletes:      libsubversion0
172
173 %description libs
174 Subversion libraries and modules.
175
176 %description libs -l pl.UTF-8
177 Biblioteka subversion oraz ładowalne moduły.
178
179 %package devel
180 Summary:        Header files and develpment documentation for subversion
181 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
182 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
183 Group:          Development/Libraries
184 Requires:       %{name}-libs = %{version}-%{release}
185 Requires:       apr-util-devel >= 1:1.0.0
186 Requires:       serf-devel >= 1.2.1
187 Obsoletes:      libsubversion0-devel
188
189 %description devel
190 Header files and develpment documentation for subversion.
191
192 %description devel -l pl.UTF-8
193 Pliki nagłówkowe i dokumetacja do subversion.
194
195 %description devel -l pt_BR.UTF-8
196 Este pacote provê os arquivos necessários para desenvolvedores
197 interagirem com o Subversion.
198
199 %package static
200 Summary:        Static subversion library
201 Summary(pl.UTF-8):      Biblioteka statyczna subversion
202 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
203 Group:          Development/Libraries
204 Requires:       %{name}-devel = %{version}
205 Obsoletes:      libsubversion0-static-devel
206
207 %description static
208 Static subversion library.
209
210 %description static -l pl.UTF-8
211 Biblioteka statyczna subversion.
212
213 %description static -l pt_BR.UTF-8
214 Este pacote provê um cliente estático do subversion.
215
216 %package svnserve
217 Summary:        Subversion svnserve
218 Summary(pl.UTF-8):      Subversion svnserve
219 Group:          Networking/Daemons
220 Requires(post,preun):   /sbin/chkconfig
221 Requires(postun):       /usr/sbin/groupdel
222 Requires(postun):       /usr/sbin/userdel
223 Requires(pre):  /bin/id
224 Requires(pre):  /usr/bin/getgid
225 Requires(pre):  /usr/lib/rpm/user_group.sh
226 Requires(pre):  /usr/sbin/groupadd
227 Requires(pre):  /usr/sbin/useradd
228 Requires(pre):  /usr/sbin/usermod
229 Requires:       %{name} = %{version}-%{release}
230 Requires:       rc-scripts
231 Provides:       group(svn)
232 Provides:       user(svn)
233
234 %description svnserve
235 Subversion svnserve server.
236
237 %description svnserve -l pl.UTF-8
238 Serwer subversion svnserve.
239
240 %package tools
241 Summary:        Subversion tools and scripts
242 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
243 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
244 Group:          Applications
245 Requires:       %{name} = %{version}-%{release}
246 Requires:       python
247 Requires:       python-subversion = %{version}
248
249 %description tools
250 Subversion tools and scripts.
251
252 %description tools -l pl.UTF-8
253 Narzędzia oraz skrypty dla subversion.
254
255 %package -n bash-completion-subversion
256 Summary:        bash completion for subversion
257 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
258 Group:          Applications/Shells
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       bash-completion
261 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
262 %if "%{_rpmversion}" >= "5"
263 BuildArch:      noarch
264 %endif
265
266 %description -n bash-completion-subversion
267 Bash completion for subversion.
268
269 %description -n bash-completion-subversion -l pl.UTF-8
270 Dopełnienia basha dla subversion.
271
272 %package -n java-subversion
273 Summary:        Subversion Java bindings
274 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
275 Group:          Development/Languages/Java
276 Requires:       %{name}-libs = %{version}-%{release}
277
278 %description -n java-subversion
279 This is a set of Java classes which provide the functionality of
280 subversion-libs, the Subversion libraries. It is useful if you want
281 to, for example, write a Java class that manipulates a Subversion
282 repository or working copy. See the 'subversion' package for more
283 information.
284
285 %description -n java-subversion -l pl.UTF-8
286 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
287 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
288 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
289 roboczą. Więcej informacji w pakiecie subversion.
290
291 %package -n python-subversion
292 Summary:        Subversion Python bindings
293 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
294 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
295 Group:          Development/Languages/Python
296 Requires:       %{name}-libs = %{version}-%{release}
297 Requires:       python
298 Obsoletes:      subversion-python
299
300 %description -n python-subversion
301 Subversion Python bindings.
302
303 %description -n python-subversion -l pl.UTF-8
304 Dowiązania do Subversion dla Pythona.
305
306 %description -n python-subversion -l pt_BR.UTF-8
307 Módulos Python para acessar os recursos do Subversion.
308
309 %package -n python-csvn
310 Summary:        CTypes Subversion Python bindings
311 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
312 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
313 Group:          Development/Languages/Python
314 Requires:       %{name}-libs = %{version}-%{release}
315 Requires:       python
316
317 %description -n python-csvn
318 Subversion CTypes Python bindings.
319
320 %description -n python-csvn -l pl.UTF-8
321 Dowiązania do Subversion dla Pythona używające CTypes.
322
323 %description -n python-csvn -l pt_BR.UTF-8
324 Módulos Python para acessar os recursos do Subversion.
325
326 %package -n perl-subversion
327 Summary:        Subversion Perl bindings
328 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
329 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
330 Group:          Development/Languages/Perl
331 Requires:       %{name}-libs = %{version}-%{release}
332 Obsoletes:      subversion-perl
333
334 %description -n perl-subversion
335 Subversion Perl bindings.
336
337 %description -n perl-subversion -l pl.UTF-8
338 Dowiązania do Subversion dla Perla.
339
340 %description -n perl-subversion -l pt_BR.UTF-8
341 Módulos Perl para acessar os recursos do Subversion.
342
343 %package -n ruby-subversion
344 Summary:        Subversion Ruby bindings
345 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
346 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
347 Group:          Development/Languages
348 Requires:       %{name}-libs = %{version}-%{release}
349 Obsoletes:      subversion-ruby
350
351 %description -n ruby-subversion
352 Subversion Ruby bindings.
353
354 %description -n ruby-subversion -l pl.UTF-8
355 Dowiązania do Subversion dla języka Ruby.
356
357 %description -n ruby-subversion -l pt_BR.UTF-8
358 Módulos Ruby para acessar os recursos do Subversion.
359
360 %package -n apache-mod_dav_svn
361 Summary:        Apache module: Subversion Server
362 Summary(pl.UTF-8):      Moduł Apache'a: serwer Subversion
363 Group:          Networking/Daemons
364 Requires:       %{name} = %{version}-%{release}
365 Requires:       apache(modules-api) = %apache_modules_api
366 Requires:       apache-mod_dav
367
368 %description -n apache-mod_dav_svn
369 Apache module: Subversion Server.
370
371 %description -n apache-mod_dav_svn -l pl.UTF-8
372 Moduł Apache'a: serwer Subversion.
373
374 %package -n apache-mod_authz_svn
375 Summary:        Apache module: Subversion Server - path-based authorization
376 Summary(pl.UTF-8):      Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera Subversion
377 Group:          Networking/Daemons
378 Requires:       %{name}-libs = %{version}-%{release}
379 Requires:       apache(modules-api) = %apache_modules_api
380 Requires:       apache-mod_dav_svn = %{version}-%{release}
381
382 %description -n apache-mod_authz_svn
383 Apache module: Subversion Server - path-based authorization.
384
385 %description -n apache-mod_authz_svn -l pl.UTF-8
386 Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera
387 Subversion.
388
389 %package -n apache-mod_dontdothat_svn
390 Summary:        Apache module: Allows you to block specific svn requests
391 Summary(pl.UTF-8):      Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn
392 Group:          Networking/Daemons
393 Requires:       %{name}-libs = %{version}-%{release}
394 Requires:       apache(modules-api) = %apache_modules_api
395 Requires:       apache-mod_dav_svn = %{version}-%{release}
396
397 %description -n apache-mod_dontdothat_svn
398 Apache module: Allows you to block specific svn requests.
399
400 %description -n apache-mod_dontdothat_svn -l pl.UTF-8
401 Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn.
402
403 %package -n gnome-keyring-subversion
404 Summary:        GNOME Keyring authentication provider for Subversion
405 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
406 Group:          X11/Applications
407 Requires:       %{name}-libs = %{version}-%{release}
408
409 %description -n gnome-keyring-subversion
410 Authentication provider module for Subversion which allows SVN client
411 to authenticate using GNOME Keyring.
412
413 %description -n gnome-keyring-subversion -l pl.UTF-8
414 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
415 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
416
417 %package -n kde4-kwallet-subversion
418 Summary:        KDE Wallet authentication provider for Subversion
419 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
420 Group:          X11/Applications
421 Requires:       %{name}-libs = %{version}-%{release}
422
423 %description -n kde4-kwallet-subversion
424 Authentication provider module for Subversion which allows SVN client
425 to authenticate using KDE Wallet.
426
427 %description -n kde4-kwallet-subversion -l pl.UTF-8
428 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
429 uwierzytelniać się przy użyciu Portfela KDE.
430
431 %prep
432 %setup -q
433 %patch0 -p0
434 %patch1 -p1
435 %patch2 -p0
436 %patch3 -p1
437
438 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
439
440 %build
441 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
442 #%{__rm} subversion/bindings/swig/proxy/*.swg
443 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
444 chmod +x ./autogen.sh && ./autogen.sh
445 %{__libtoolize}
446 %configure \
447         --with-editor=vi \
448         --with-zlib=%{_libdir} \
449         --disable-runtime-module-search \
450         --disable-mod-activation \
451 %if %{with db}
452         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
453         %{?with_db6:--enable-bdb6} \
454 %else
455         --without-berkeley-db \
456 %endif
457 %if %{with apache}
458         --with-apache-libexecdir="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
459         --with-apxs=%{_sbindir}/apxs \
460 %else
461         --without-apxs \
462 %endif
463 %if %{without swig}
464         --without-swig \
465 %endif
466 %if %{with ruby}
467         svn_cv_ruby_sitedir_libsuffix="" \
468         svn_cv_ruby_sitedir_archsuffix="" \
469         --with-ruby-sitedir=%{ruby_vendorarchdir} \
470 %else
471         ac_cv_path_RUBY=none \
472 %endif
473 %if %{with csvn}
474         --with-ctypesgen=%{_bindir}/ctypesgen.py \
475 %endif
476 %if %{with javahl}
477         --enable-javahl \
478         --with-jdk="%{java_home}" \
479         --without-jikes \
480 %else
481         --disable-javahl \
482 %endif
483         --with-serf=%{_prefix} \
484         --with-apr=%{_bindir}/apr-1-config \
485         --with-apr-util=%{_bindir}/apu-1-config \
486 %if %{with kwallet}
487         --with-kwallet \
488 %endif
489 %if %{with gnome}
490         --with-gnome-keyring
491 %endif
492
493 %{__make} -j1
494
495 %{__make} tools
496
497 %if %{with csvn}
498 # Python ctypes bindings
499 %{__make} ctypes-python
500 %endif
501 %if %{with python}
502 # Python swig bindings
503 %{__make} swig-py \
504         swig_pydir=%{py_sitedir}/libsvn \
505         swig_pydir_extra=%{py_sitedir}/svn
506 %endif
507 %if %{with perl}
508 # Perl swig bindings
509 %{__make} -j1 swig-pl-lib
510 cd subversion/bindings/swig/perl/native
511 %{__perl} Makefile.PL INSTALLDIRS=vendor
512 %{__make} -j1
513 cd -
514 %endif
515 %if %{with javahl}
516 %{__make} -j1 javahl \
517         javahl_javadir="%{_javadir}"
518 %endif
519 # ruby
520 %if %{with ruby}
521 %{__make} swig-rb
522 %endif
523
524 %if %{with tests}
525 %{__make} -j1 check
526 %if %{with csvn}
527 %{__make} -j1 check-ctypes-python
528 %endif
529 %if %{with python}
530 %{__make} -j1 check-swig-py
531 %endif
532 %if %{with perl}
533 %{__make} -j1 check-swig-pl
534 %endif
535 %if %{with ruby}
536 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
537 #%{__make} check-swig-rb
538 %endif
539 %endif
540
541 %install
542 rm -rf $RPM_BUILD_ROOT
543 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
544         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
545         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
546         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
547         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
548
549 %{__make} install -j1 \
550         toolsdir=%{_bindir} \
551         DESTDIR=$RPM_BUILD_ROOT \
552         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
553 %if %{with javahl}
554         install-javahl \
555         javahl_javadir="%{_javadir}" \
556 %endif
557 %if %{with python}
558         install-swig-py \
559         swig_pydir=%{py_sitedir}/libsvn \
560         swig_pydir_extra=%{py_sitedir}/svn \
561 %endif
562 %if %{with csvn}
563         install-ctypes-python \
564 %endif
565         install-tools
566
567 %if %{with ruby}
568 %{__make} install -j1 \
569         DESTDIR=$RPM_BUILD_ROOT \
570         install-swig-rb install-swig-rb-doc \
571
572 # not our package
573 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
574 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
575 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
576 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
577 %endif
578
579 %if %{with perl}
580 %{__make} install-swig-pl-lib \
581         DESTDIR=$RPM_BUILD_ROOT
582 %{__make} -C subversion/bindings/swig/perl/native install \
583         DESTDIR=$RPM_BUILD_ROOT \
584         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
585         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
586 %endif
587
588 %if %{with apache}
589 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
590 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
591 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
592 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
593 %endif
594
595 %if %{without net_client_only}
596 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
597 %endif
598
599 # rename not to conflict with standard packages. (are these needed at all?)
600 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
601 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
602 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
603
604 %if %{with python} || %{with csvn}
605 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
606 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
607 %py_postclean
608 %endif
609 %if %{with python}
610 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
611 # .a created on ac only
612 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
613 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
614 %endif
615
616 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
617 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
618
619 %if %{with javahl}
620 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
621 %endif
622 %if %{with swig}
623 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
624 %if %{with ruby}
625 %{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/svn/ext/*.la
626 %endif
627 %endif
628 %if %{with gnome} || %{with kwallet}
629 # dlopened by soname (libsvn_auth_*-1.so.0)
630 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
631 %endif
632
633 %find_lang %{name}
634
635 %clean
636 rm -rf $RPM_BUILD_ROOT
637
638 %pre svnserve
639 %groupadd -g 86 svn
640 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
641
642 %post   libs -p /sbin/ldconfig
643 %postun libs -p /sbin/ldconfig
644
645 %post   devel -p /sbin/postshell
646 -/usr/sbin/fix-info-dir -c %{_infodir}
647
648 %postun devel -p /sbin/postshell
649 -/usr/sbin/fix-info-dir -c %{_infodir}
650
651 %post   -n java-subversion -p /sbin/ldconfig
652 %postun -n java-subversion -p /sbin/ldconfig
653
654 %post   -n perl-subversion -p /sbin/ldconfig
655 %postun -n perl-subversion -p /sbin/ldconfig
656
657 %post   -n python-subversion -p /sbin/ldconfig
658 %postun -n python-subversion -p /sbin/ldconfig
659
660 %post   -n ruby-subversion -p /sbin/ldconfig
661 %postun -n ruby-subversion -p /sbin/ldconfig
662
663 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
664 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
665
666 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
667 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
668
669 %post svnserve
670 /sbin/chkconfig --add svnserve
671 %service svnserve restart "svnserve daemon"
672
673 %preun svnserve
674 if [ "$1" = "0" ]; then
675         %service svnserve stop
676         /sbin/chkconfig --del svnserve
677 fi
678
679 %postun svnserve
680 if [ "$1" = "0" ]; then
681         %userremove svn
682         %groupremove svn
683 fi
684
685 %post -n apache-mod_dav_svn
686 %service -q httpd restart
687
688 %postun -n apache-mod_dav_svn
689 if [ "$1" = "0" ]; then
690         %service -q httpd restart
691 fi
692
693 %post -n apache-mod_authz_svn
694 %service -q httpd restart
695
696 %postun -n apache-mod_authz_svn
697 if [ "$1" = "0" ]; then
698         %service -q httpd restart
699 fi
700
701 %post -n apache-mod_dontdothat_svn
702 %service -q httpd restart
703
704 %postun -n apache-mod_dontdothat_svn
705 if [ "$1" = "0" ]; then
706         %service -q httpd restart
707 fi
708
709 %files
710 %defattr(644,root,root,755)
711 %doc BUGS CHANGES INSTALL README
712 %doc doc/*/*.html
713 %doc tools/hook-scripts/*.{pl,py,example}
714 %doc tools/hook-scripts/mailer/*.{py,example}
715 %doc tools/xslt/*
716 %attr(755,root,root) %{_bindir}/svn
717 %attr(755,root,root) %{_bindir}/svnadmin
718 %attr(755,root,root) %{_bindir}/svndumpfilter
719 %attr(755,root,root) %{_bindir}/svnlook
720 %attr(755,root,root) %{_bindir}/svnmucc
721 %attr(755,root,root) %{_bindir}/svnrdump
722 %attr(755,root,root) %{_bindir}/svnsync
723 %attr(755,root,root) %{_bindir}/svnversion
724 %{_mandir}/man1/svn.1*
725 %{_mandir}/man1/svnadmin.1*
726 %{_mandir}/man1/svndumpfilter.1*
727 %{_mandir}/man1/svnrdump.1*
728 %{_mandir}/man1/svnlook.1*
729 %{_mandir}/man1/svnmucc.1*
730 %{_mandir}/man1/svnsync.1*
731 %{_mandir}/man1/svnversion.1*
732
733 %files libs -f %{name}.lang
734 %defattr(644,root,root,755)
735 %dir %{_sysconfdir}/%{name}
736 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
737 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
738 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
740 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
741 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
742 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
743 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
744 %if %{without net_client_only}
745 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
746 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
747 %endif
748 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
749 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
750 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
751 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
752 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
753 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
754 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
755 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
756 %attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so.*.*.*
757 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_serf-1.so.0
758 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
759 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
760 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
761 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
762 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
763 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
764 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
765 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
766
767 %files devel
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
770 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
771 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
772 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
773 %if %{without net_client_only}
774 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
775 %endif
776 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
777 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
778 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
779 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
780 %attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so
781 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
782 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
783 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
784 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
785 %{_libdir}/libsvn_client-1.la
786 %{_libdir}/libsvn_delta-1.la
787 %{_libdir}/libsvn_diff-1.la
788 %{_libdir}/libsvn_fs-1.la
789 %if %{without net_client_only}
790 %{_libdir}/libsvn_fs_base-1.la
791 %endif
792 %{_libdir}/libsvn_fs_fs-1.la
793 %{_libdir}/libsvn_fs_util-1.la
794 %{_libdir}/libsvn_ra-1.la
795 %{_libdir}/libsvn_ra_local-1.la
796 %{_libdir}/libsvn_ra_serf-1.la
797 %{_libdir}/libsvn_ra_svn-1.la
798 %{_libdir}/libsvn_repos-1.la
799 %{_libdir}/libsvn_subr-1.la
800 %{_libdir}/libsvn_wc-1.la
801 %{_includedir}/%{name}-1
802 %{_examplesdir}/%{name}-%{version}
803
804 %files static
805 %defattr(644,root,root,755)
806 %{_libdir}/libsvn_client-1.a
807 %{_libdir}/libsvn_delta-1.a
808 %{_libdir}/libsvn_diff-1.a
809 %{_libdir}/libsvn_fs-1.a
810 %if %{without net_client_only}
811 %{_libdir}/libsvn_fs_base-1.a
812 %endif
813 %{_libdir}/libsvn_fs_fs-1.a
814 %{_libdir}/libsvn_fs_util-1.a
815 %{_libdir}/libsvn_ra-1.a
816 %{_libdir}/libsvn_ra_local-1.a
817 %{_libdir}/libsvn_ra_serf-1.a
818 %{_libdir}/libsvn_ra_svn-1.a
819 %{_libdir}/libsvn_repos-1.a
820 %{_libdir}/libsvn_subr-1.a
821 %{_libdir}/libsvn_wc-1.a
822
823 %if %{with gnome}
824 %files -n gnome-keyring-subversion
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
827 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
828 %endif
829
830 %if %{with kwallet}
831 %files -n kde4-kwallet-subversion
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
834 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
835 %endif
836
837 %if %{without net_client_only}
838 %files svnserve
839 %defattr(644,root,root,755)
840 %attr(755,root,root) %{_bindir}/svnserve
841 %{_mandir}/man5/svnserve.conf.5*
842 %{_mandir}/man8/svnserve.8*
843 %dir %attr(750,svn,svn) /home/services/subversion
844 %dir %attr(750,svn,svn) /home/services/subversion/repos
845 %if %{with apache}
846 %attr(754,root,root) /etc/rc.d/init.d/svnserve
847 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
848 %endif
849
850 %files tools
851 %defattr(644,root,root,755)
852 # tools/backup/hot-backup.py
853 %attr(755,root,root) %{_bindir}/svn-hot-backup
854
855 # tools/diff
856 %attr(755,root,root) %{_bindir}/svndiff
857 %attr(755,root,root) %{_bindir}/svndiff3
858 %attr(755,root,root) %{_bindir}/svndiff4
859
860 # tools/server-side
861 %attr(755,root,root) %{_bindir}/fsfs-stats
862 %attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
863 %attr(755,root,root) %{_bindir}/svn-rep-sharing-stats
864 %attr(755,root,root) %{_bindir}/svnauthz
865 %attr(755,root,root) %{_bindir}/svnauthz-validate
866
867 # tools/client-side
868 %attr(755,root,root) %{_bindir}/svn-bench
869
870 # tools/dev/svnraisetreeconflict
871 %attr(755,root,root) %{_bindir}/svnraisetreeconflict
872
873 # tools/dev/
874 %attr(755,root,root) %{_bindir}/fsfs-access-map
875 %attr(755,root,root) %{_bindir}/fsfs-reorg
876
877 %files -n bash-completion-subversion
878 %defattr(644,root,root,755)
879 /etc/bash_completion.d/%{name}
880
881 %endif # net_client_only
882
883 %if %{with javahl}
884 %files -n java-subversion
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
887 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
888 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
889 %{_javadir}/svn-javahl.jar
890 %endif
891
892 %if %{with python}
893 %files -n python-subversion
894 %defattr(644,root,root,755)
895 %doc tools/backup/*.py
896 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
897 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
898 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
899 %dir %{py_sitedir}/libsvn
900 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
901 %{py_sitedir}/libsvn/*.py[co]
902 %dir %{py_sitedir}/svn
903 %{py_sitedir}/svn/*.py[co]
904 %{_examplesdir}/python-%{name}-%{version}
905 %endif
906
907 %if %{with csvn}
908 %files -n python-csvn
909 %defattr(644,root,root,755)
910 %doc subversion/bindings/ctypes-python/{README,TODO}
911 %doc subversion/bindings/ctypes-python/examples/*.py
912 %dir %{py_sitescriptdir}/csvn
913 %{py_sitescriptdir}/csvn/*.py[co]
914 %dir %{py_sitescriptdir}/csvn/core
915 %{py_sitescriptdir}/csvn/core/*.py[co]
916 %dir %{py_sitescriptdir}/csvn/ext
917 %{py_sitescriptdir}/csvn/ext/*.py[co]
918 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
919 %endif
920
921 %if %{with perl}
922 %files -n perl-subversion
923 %defattr(644,root,root,755)
924 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
925 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
926 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
927 %{perl_vendorarch}/SVN
928 %dir %{perl_vendorarch}/auto/SVN
929 %dir %{perl_vendorarch}/auto/SVN/*
930 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
931 %{perl_vendorarch}/auto/SVN/*/*.bs
932 %{_mandir}/man3/*.3pm*
933 %endif
934
935 %if %{with ruby}
936 %files -n ruby-subversion
937 %defattr(644,root,root,755)
938 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
939 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
940 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
941 %dir %{ruby_vendorarchdir}/svn
942 %{ruby_vendorarchdir}/svn/*.rb
943 %dir %{ruby_vendorarchdir}/svn/ext
944 %attr(755,root,root) %{ruby_vendorarchdir}/svn/ext/*.so
945 %{ruby_ridir}/Svn
946 %endif
947
948 %if %{with apache}
949 %files -n apache-mod_dav_svn
950 %defattr(644,root,root,755)
951 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
952 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
953
954 %files -n apache-mod_authz_svn
955 %defattr(644,root,root,755)
956 %doc subversion/mod_authz_svn/INSTALL
957 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
958 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
959
960 %files -n apache-mod_dontdothat_svn
961 %defattr(644,root,root,755)
962 %doc tools/server-side/mod_dontdothat/README
963 %attr(755,root,root) %{apachelibdir}/mod_dontdothat.so
964 %endif
This page took 0.108514 seconds and 4 git commands to generate.