]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- strict deps (at least) on -libs package to avoid errors like:
[packages/subversion.git] / subversion.spec
1 #
2 # Conditional build:
3 %bcond_with     net_client_only         # build only net client
4 %bcond_without  neon                    # use serf instead of neon
5 %bcond_without  swig                    # disable bindings generation with Swig
6 %bcond_without  python                  # build without Python bindings (broken)
7 %bcond_without  csvn                    # build Python csvn bindings
8 %bcond_without  perl                    # build without Perl bindings
9 %bcond_with     ruby                    # build with Ruby bindings (only 1.8.x is supported)
10 %bcond_without  apache                  # build without Apache support (webdav, etc)
11 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
12 %bcond_without  tests                   # don't perform "make check"
13 %bcond_without  kwallet                 # build without kde4 wallet support
14 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
15 %bcond_without  gnome                   # build without gnome keyring support
16 %bcond_without  db                      # disable Subversion Berkeley DB based filesystem library
17
18 %if %{with net_client_only}
19 %undefine       with_apache
20 %undefine       with_db
21 %undefine       with_swig
22 %undefine       with_javahl
23 %endif
24
25 %if %{without swig}
26 %undefine       with_perl
27 %undefine       with_python
28 %undefine       with_ruby
29 %endif
30
31 %if %{without kde}
32 %undefine       with_kwallet
33 %endif
34
35 %if %{without python} && %{without perl} && %{without ruby}
36 %undefine       with_swig
37 %endif
38
39 %define apxs    /usr/sbin/apxs
40 %define pdir    SVN
41 %define pnam    _Core
42
43 %if %{with neon}
44 %define webdavlib       neon
45 %else
46 %define webdavlib       serf
47 %endif
48 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
49 Summary:        A Concurrent Versioning system similar to but better than CVS
50 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
51 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
52 Name:           subversion
53 Version:        1.7.1
54 Release:        2
55 License:        Apache/BSD-like
56 Group:          Development/Version Control
57 Source0:        http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
58 # Source0-md5:  8a4fa74385df85a9702141b6b68b8307
59 Source1:        %{name}-dav_svn.conf
60 Source2:        %{name}-authz_svn.conf
61 Source3:        %{name}-svnserve.init
62 Source4:        %{name}-svnserve.sysconfig
63 # current subversion tarball has correct *.swg files
64 # but after regeneration these are broken again, so
65 # we still need this script
66 Source5:        %{name}-convert-typemaps-to-ifdef.py
67 Patch0:         %{name}-home_etc.patch
68 Patch1:         %{name}-DESTDIR.patch
69 Patch2:         %{name}-ruby-datadir-path.patch
70 Patch3:         %{name}-tests.patch
71 # running this hook for every post breaks mod_rails
72 Patch4:         %{name}-mod_dav_svn-fix-hook.patch
73 URL:            http://subversion.apache.org/
74 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
75 BuildRequires:  apr-devel >= 1:1.0.0
76 BuildRequires:  apr-util-devel >= 1:1.2.8-3
77 BuildRequires:  autoconf >= 2.59
78 BuildRequires:  automake
79 BuildRequires:  bison
80 BuildRequires:  cyrus-sasl-devel
81 %if %{with kwallet} || %{with gnome}
82 BuildRequires:  dbus-devel
83 %endif
84 BuildRequires:  db-devel >= 4.1.25
85 BuildRequires:  expat-devel
86 BuildRequires:  gettext-devel
87 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
88 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
89 BuildRequires:  libmagic-devel
90 BuildRequires:  libtool >= 1.4-9
91 BuildRequires:  pkgconfig
92 %{?with_csvn:BuildRequires:     python-ctypesgen}
93 BuildRequires:  rpm-pythonprov
94 BuildRequires:  rpmbuild(macros) >= 1.583
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  sqlite3-devel >= 3.6.18
97 BuildRequires:  texinfo
98 BuildRequires:  which
99 %if %{with neon}
100 BuildRequires:  neon-devel >= 0.26.0
101 %else
102 BuildRequires:  serf-devel >= 0.7.1
103 %endif
104 %if %{with javahl}
105 BuildRequires:  jdk >= 1.5
106 BuildRequires:  libstdc++-devel
107 %endif
108 %if %{with perl}
109 BuildRequires:  perl-devel >= 1:5.8.0
110 BuildRequires:  rpm-perlprov >= 4.1-13
111 BuildRequires:  swig-perl >= 1.3.24
112 %endif
113 %if %{with python}
114 BuildRequires:  python-devel >= 1:2.4
115 BuildRequires:  swig-python >= 1.3.24
116 %endif
117 %if %{with ruby}
118 BuildRequires:  ruby-devel < 1:1.9
119 BuildRequires:  ruby-devel >= 1:1.8.2
120 BuildRequires:  ruby-rubygems
121 BuildRequires:  swig-ruby >= 1.3.24
122 %endif
123 Requires:       %{name}-libs = %{version}-%{release}
124 %requires_ge    sqlite3
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %define         _libexecdir             %{_libdir}/svn
128 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
129 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
130
131 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
132
133 %description
134 The goal of the Subversion project is to build a version control
135 system that is a compelling replacement for CVS in the open source
136 community.
137
138 Our goals are:
139 - All current CVS features.
140 - Directories, renames, and file meta-data are versioned.
141 - Symbolic links, etc, are supported
142 - Commits are truly atomic.
143 - Branching and tagging are cheap (constant time) operations
144 - Repeated merges are handled gracefully
145 - Support for plug-in client side diff programs
146 - Natively client/server
147 - Client/server protocol sends diffs in both directions
148 - Costs are proportional to change size, not project size
149 - Internationalization
150 - Progressive multi-lingual support
151
152 %description -l pl.UTF-8
153 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
154 zamiennika dla CVS.
155
156 Cele projektu to:
157 - Wszystkie aktualne możliwości CVS.
158 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
159 - Obsługa dowiązań symbolicznych itp.
160 - Commity są w pełni atomowe.
161 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
162 - Dobra obsługa powtarzanego łączenia (merge).
163 - Obsługa wtyczek diff po stronie klienta.
164 - Natywny klient/serwer.
165 - Klient/Serwer przesyłają diffy w obu kierunkach.
166 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
167 - Internacjonalizacja.
168 - Postępujące wsparcie dla wielu języków.
169
170 %description -l pt_BR.UTF-8
171 O objetivo do projeto Subversion é construir um sistema de controle de
172 versões que seja um substituto para o CVS (Concurrent Versioning
173 System) na comunidade opensource, fornecendo grandes melhorias.
174
175 %package libs
176 Summary:        Subversion libraries and modules
177 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
178 Group:          Libraries
179 %if %{with neon}
180 Requires:       neon >= 0.26.0
181 %else
182 Requires:       serf >= 0.7.1
183 %endif
184 Obsoletes:      libsubversion0
185
186 %description libs
187 Subversion libraries and modules.
188
189 %description libs -l pl.UTF-8
190 Biblioteka subversion oraz ładowalne moduły.
191
192 %package devel
193 Summary:        Header files and develpment documentation for subversion
194 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
195 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
196 Group:          Development/Libraries
197 Requires:       %{name}-libs = %{version}-%{release}
198 Requires:       apr-util-devel >= 1:1.0.0
199 %{?with_neon:Requires:  neon-devel >= 0.26.0}
200 Obsoletes:      libsubversion0-devel
201
202 %description devel
203 Header files and develpment documentation for subversion.
204
205 %description devel -l pl.UTF-8
206 Pliki nagłówkowe i dokumetacja do subversion.
207
208 %description devel -l pt_BR.UTF-8
209 Este pacote provê os arquivos necessários para desenvolvedores
210 interagirem com o Subversion.
211
212 %package static
213 Summary:        Static subversion library
214 Summary(pl.UTF-8):      Biblioteka statyczna subversion
215 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
216 Group:          Development/Libraries
217 Requires:       %{name}-devel = %{version}
218 Obsoletes:      libsubversion0-static-devel
219
220 %description static
221 Static subversion library.
222
223 %description static -l pl.UTF-8
224 Biblioteka statyczna subversion.
225
226 %description static -l pt_BR.UTF-8
227 Este pacote provê um cliente estático do subversion.
228
229 %package svnserve
230 Summary:        Subversion svnserve
231 Summary(pl.UTF-8):      Subversion svnserve
232 Group:          Networking/Daemons
233 Requires(post,preun):   /sbin/chkconfig
234 Requires(postun):       /usr/sbin/groupdel
235 Requires(postun):       /usr/sbin/userdel
236 Requires(pre):  /bin/id
237 Requires(pre):  /usr/bin/getgid
238 Requires(pre):  /usr/lib/rpm/user_group.sh
239 Requires(pre):  /usr/sbin/groupadd
240 Requires(pre):  /usr/sbin/useradd
241 Requires(pre):  /usr/sbin/usermod
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       rc-scripts
244 Provides:       group(svn)
245 Provides:       user(svn)
246
247 %description svnserve
248 Subversion svnserve server.
249
250 %description svnserve -l pl.UTF-8
251 Serwer subversion svnserve.
252
253 %package tools
254 Summary:        Subversion tools and scripts
255 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
256 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
257 Group:          Applications
258 %pyrequires_eq  python
259 Requires:       %{name} = %{version}-%{release}
260 Requires:       python-subversion = %{version}
261
262 %description tools
263 Subversion tools and scripts.
264
265 %description tools -l pl.UTF-8
266 Narzędzia oraz skrypty dla subversion.
267
268 %package -n bash-completion-subversion
269 Summary:        bash completion for subversion
270 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
271 Group:          Applications/Shells
272 Requires:       %{name} = %{version}-%{release}
273 Requires:       bash-completion
274 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
275
276 %description -n bash-completion-subversion
277 Bash completion for subversion.
278
279 %description -n bash-completion-subversion -l pl.UTF-8
280 Dopełnienia basha dla subversion.
281
282 %package -n java-subversion
283 Summary:        Subversion Java bindings
284 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
285 Group:          Development/Languages/Java
286 Requires:       %{name}-libs = %{version}-%{release}
287
288 %description -n java-subversion
289 This is a set of Java classes which provide the functionality of
290 subversion-libs, the Subversion libraries. It is useful if you want
291 to, for example, write a Java class that manipulates a Subversion
292 repository or working copy. See the 'subversion' package for more
293 information.
294
295 %description -n java-subversion -l pl.UTF-8
296 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
297 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
298 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
299 roboczą. Więcej informacji w pakiecie subversion.
300
301 %package -n python-subversion
302 Summary:        Subversion Python bindings
303 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
304 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
305 Group:          Development/Languages/Python
306 %pyrequires_eq  python
307 Requires:       %{name}-libs = %{version}-%{release}
308 Obsoletes:      subversion-python
309
310 %description -n python-subversion
311 Subversion Python bindings.
312
313 %description -n python-subversion -l pl.UTF-8
314 Dowiązania do Subversion dla Pythona.
315
316 %description -n python-subversion -l pt_BR.UTF-8
317 Módulos Python para acessar os recursos do Subversion.
318
319 %package -n python-csvn
320 Summary:        CTypes Subversion Python bindings
321 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
322 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
323 Group:          Development/Languages/Python
324 %pyrequires_eq  python
325 Requires:       %{name}-libs = %{version}-%{release}
326
327 %description -n python-csvn
328 Subversion CTypes Python bindings.
329
330 %description -n python-csvn -l pl.UTF-8
331 Dowiązania do Subversion dla Pythona używające CTypes.
332
333 %description -n python-csvn -l pt_BR.UTF-8
334 Módulos Python para acessar os recursos do Subversion.
335
336 %package -n perl-subversion
337 Summary:        Subversion Perl bindings
338 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
339 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
340 Group:          Development/Languages/Perl
341 Requires:       %{name}-libs = %{version}-%{release}
342 Obsoletes:      subversion-perl
343
344 %description -n perl-subversion
345 Subversion Perl bindings.
346
347 %description -n perl-subversion -l pl.UTF-8
348 Dowiązania do Subversion dla Perla.
349
350 %description -n perl-subversion -l pt_BR.UTF-8
351 Módulos Perl para acessar os recursos do Subversion.
352
353 %package -n ruby-subversion
354 Summary:        Subversion Ruby bindings
355 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
356 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
357 Group:          Development/Languages
358 Requires:       %{name}-libs = %{version}-%{release}
359 Obsoletes:      subversion-ruby
360
361 %description -n ruby-subversion
362 Subversion Ruby bindings.
363
364 %description -n ruby-subversion -l pl.UTF-8
365 Dowiązania do Subversion dla języka Ruby.
366
367 %description -n ruby-subversion -l pt_BR.UTF-8
368 Módulos Ruby para acessar os recursos do Subversion.
369
370 %package -n apache-mod_dav_svn
371 Summary:        Apache module: Subversion Server
372 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
373 Group:          Networking/Daemons
374 Requires:       %{name} = %{version}-%{release}
375 Requires:       apache(modules-api) = %apache_modules_api
376 Requires:       apache-mod_dav
377
378 %description -n apache-mod_dav_svn
379 Apache module: Subversion Server.
380
381 %description -n apache-mod_dav_svn -l pl.UTF-8
382 Moduł apache: Serwer Subversion.
383
384 %package -n apache-mod_authz_svn
385 Summary:        Apache module: Subversion Server - path-based authorization
386 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
387 Group:          Networking/Daemons
388 Requires:       %{name}-libs = %{version}-%{release}
389 Requires:       apache(modules-api) = %apache_modules_api
390 Requires:       apache-mod_dav_svn = %{version}-%{release}
391
392 %description -n apache-mod_authz_svn
393 Apache module: Subversion Server - path-based authorization.
394
395 %description -n apache-mod_authz_svn -l pl.UTF-8
396 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
397
398 %package -n gnome-keyring-subversion
399 Summary:        GNOME Keyring authentication provider for Subversion
400 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
401 Group:          X11/Applications
402 Requires:       %{name}-libs = %{version}-%{release}
403
404 %description -n gnome-keyring-subversion
405 Authentication provider module for Subversion which allows SVN client
406 to authenticate using GNOME Keyring.
407
408 %description -n gnome-keyring-subversion -l pl.UTF-8
409 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
410 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
411
412 %package -n kde4-kwallet-subversion
413 Summary:        KDE Wallet authentication provider for Subversion
414 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
415 Group:          X11/Applications
416 Requires:       %{name}-libs = %{version}-%{release}
417
418 %description -n kde4-kwallet-subversion
419 Authentication provider module for Subversion which allows SVN client
420 to authenticate using KDE Wallet.
421
422 %description -n kde4-kwallet-subversion -l pl.UTF-8
423 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
424 uwierzytelniać się przy użyciu Portfela KDE.
425
426 %prep
427 %setup -q
428 %patch0 -p0
429 %patch1 -p1
430 %patch2 -p0
431 %patch3 -p1
432 %patch4 -p1
433
434 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
435
436 # serf.m4 macro is broken and ignores --without serf
437 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
438
439 %build
440 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
441 #%{__rm} subversion/bindings/swig/proxy/*.swg
442 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
443 chmod +x ./autogen.sh && ./autogen.sh
444 %{__libtoolize}
445 %configure \
446         --with-editor=vi \
447         --with-zlib=%{_libdir} \
448         --disable-runtime-module-search \
449         --disable-mod-activation \
450 %if %{with db}
451         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
452 %else
453         --without-berkeley-db \
454 %endif
455 %if %{with apache}
456         --with-apxs=%{_sbindir}/apxs \
457 %else
458         --without-apxs \
459 %endif
460 %if %{without swig}
461         --without-swig \
462 %endif
463 %if %{without ruby}
464         ac_cv_path_RUBY=none \
465 %endif
466 %if %{with csvn}
467         --with-ctypesgen=%{_bindir}/ctypesgen.py \
468 %endif
469 %if %{with javahl}
470         --enable-javahl \
471         --with-jdk="%{java_home}" \
472         --without-jikes \
473 %else
474         --disable-javahl \
475 %endif
476 %if %{with neon}
477         --without-serf \
478         --with-neon=%{_prefix} \
479         --disable-neon-version-check \
480 %else
481         --with-serf=%{_prefix} \
482         --without-neon \
483 %endif
484         --with-apr=%{_bindir}/apr-1-config \
485         --with-apr-util=%{_bindir}/apu-1-config \
486 %if %{with kwallet}
487         --with-kwallet \
488 %endif
489 %if %{with gnome}
490         --with-gnome-keyring
491 %endif
492
493 %{__make} -j1
494
495 %if %{with csvn}
496 # Python ctypes bindings
497 %{__make} ctypes-python
498 %endif
499 %if %{with python}
500 # Python swig bindings
501 %{__make} swig-py \
502         swig_pydir=%{py_sitedir}/libsvn \
503         swig_pydir_extra=%{py_sitedir}/svn
504 %endif
505 %if %{with perl}
506 # Perl swig bindings
507 %{__make} -j1 swig-pl-lib
508 cd subversion/bindings/swig/perl/native
509 %{__perl} Makefile.PL INSTALLDIRS=vendor
510 %{__make} -j1
511 cd -
512 %endif
513 %if %{with javahl}
514 %{__make} -j1 javahl \
515         javahl_javadir="%{_javadir}"
516 %endif
517 # ruby
518 %if %{with ruby}
519 %{__make} swig-rb
520 %endif
521
522 %if %{with tests}
523 %{__make} -j1 check
524 %if %{with csvn}
525 %{__make} -j1 check-ctypes-python
526 %endif
527 %if %{with python}
528 %{__make} -j1 check-swig-py
529 %endif
530 %if %{with perl}
531 %{__make} -j1 check-swig-pl
532 %endif
533 %if %{with ruby}
534 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
535 #%{__make} check-swig-rb
536 %endif
537 %endif
538
539 %install
540 rm -rf $RPM_BUILD_ROOT
541 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
542         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
543         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
544         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
545         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
546
547 %{__make} install -j1 \
548         DESTDIR=$RPM_BUILD_ROOT \
549         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
550 %if %{with javahl}
551         install-javahl \
552         javahl_javadir="%{_javadir}" \
553 %endif
554 %if %{with python}
555         install-swig-py \
556         swig_pydir=%{py_sitedir}/libsvn \
557         swig_pydir_extra=%{py_sitedir}/svn \
558 %endif
559 %if %{with csvn}
560         install-ctypes-python \
561 %endif
562
563 %if %{with ruby}
564 %{__make} install -j1 \
565         DESTDIR=$RPM_BUILD_ROOT \
566         install-swig-rb install-swig-rb-doc \
567
568 # not our package
569 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Kernel
570 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
571 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
572 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Uconv
573 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
574 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
575 %endif
576
577 %if %{with perl}
578 %{__make} install-swig-pl-lib \
579         DESTDIR=$RPM_BUILD_ROOT
580 %{__make} -C subversion/bindings/swig/perl/native install \
581         DESTDIR=$RPM_BUILD_ROOT \
582         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
583         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
584 %endif
585
586 %if %{with apache}
587 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
588 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
589 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
590 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
591 %endif
592
593 %if %{without net_client_only}
594 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
595 %endif
596 %if %{with python} || %{with csvn}
597 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
598 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
599 %py_postclean
600 %endif
601 %if %{with python}
602 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
603 # .a created on ac only
604 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
605 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
606 %endif
607
608 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
609 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
610
611 %if %{with javahl}
612 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
613 %endif
614 %if %{with swig}
615 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
616 %if %{with ruby}
617 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
618 %endif
619 %endif
620 %if %{with gnome} || %{with kwallet}
621 # dlopened by soname (libsvn_auth_*-1.so.0)
622 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
623 %endif
624
625 %find_lang %{name}
626
627 %clean
628 rm -rf $RPM_BUILD_ROOT
629
630 %pre svnserve
631 %groupadd -g 86 svn
632 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
633
634 %post   libs -p /sbin/ldconfig
635 %postun libs -p /sbin/ldconfig
636
637 %post   devel -p /sbin/postshell
638 -/usr/sbin/fix-info-dir -c %{_infodir}
639
640 %postun devel -p /sbin/postshell
641 -/usr/sbin/fix-info-dir -c %{_infodir}
642
643 %post   -n java-subversion -p /sbin/ldconfig
644 %postun -n java-subversion -p /sbin/ldconfig
645
646 %post   -n perl-subversion -p /sbin/ldconfig
647 %postun -n perl-subversion -p /sbin/ldconfig
648
649 %post   -n python-subversion -p /sbin/ldconfig
650 %postun -n python-subversion -p /sbin/ldconfig
651
652 %post   -n ruby-subversion -p /sbin/ldconfig
653 %postun -n ruby-subversion -p /sbin/ldconfig
654
655 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
656 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
657
658 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
659 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
660
661 %post svnserve
662 /sbin/chkconfig --add svnserve
663 %service svnserve restart "svnserve daemon"
664
665 %preun svnserve
666 if [ "$1" = "0" ]; then
667         %service svnserve stop
668         /sbin/chkconfig --del svnserve
669 fi
670
671 %postun svnserve
672 if [ "$1" = "0" ]; then
673         %userremove svn
674         %groupremove svn
675 fi
676
677 %post -n apache-mod_dav_svn
678 %service -q httpd restart
679
680 %postun -n apache-mod_dav_svn
681 if [ "$1" = "0" ]; then
682         %service -q httpd restart
683 fi
684
685 %post -n apache-mod_authz_svn
686 %service -q httpd restart
687
688 %postun -n apache-mod_authz_svn
689 if [ "$1" = "0" ]; then
690         %service -q httpd restart
691 fi
692
693 %files
694 %defattr(644,root,root,755)
695 %doc BUGS CHANGES INSTALL README
696 %doc doc/*/*.html
697 %doc tools/hook-scripts/*.{pl,py,example}
698 %doc tools/hook-scripts/mailer/*.{py,example}
699 %doc tools/xslt/*
700 %attr(755,root,root) %{_bindir}/svn
701 %attr(755,root,root) %{_bindir}/svnadmin
702 %attr(755,root,root) %{_bindir}/svndumpfilter
703 %attr(755,root,root) %{_bindir}/svnrdump
704 %attr(755,root,root) %{_bindir}/svnlook
705 %attr(755,root,root) %{_bindir}/svnsync
706 %attr(755,root,root) %{_bindir}/svnversion
707 %{_mandir}/man1/svn.1*
708 %{_mandir}/man1/svnadmin.1*
709 %{_mandir}/man1/svndumpfilter.1*
710 %{_mandir}/man1/svnrdump.1*
711 %{_mandir}/man1/svnlook.1*
712 %{_mandir}/man1/svnsync.1*
713 %{_mandir}/man1/svnversion.1*
714
715 %files libs -f %{name}.lang
716 %defattr(644,root,root,755)
717 %dir %{_sysconfdir}/%{name}
718 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
719 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
720 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
721 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
722 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
723 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
724 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
725 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
726 %if %{without net_client_only}
727 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
728 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
729 %endif
730 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
731 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
732 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
733 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
734 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
735 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
736 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
737 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
738 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
740 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
741 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
742 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
743 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
744 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
745 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
746 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
747 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
748
749 %files devel
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
752 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
753 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
754 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
755 %if %{without net_client_only}
756 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
757 %endif
758 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
759 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
760 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
761 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
762 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
763 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
764 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
765 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
766 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
767 %{_libdir}/libsvn_client-1.la
768 %{_libdir}/libsvn_delta-1.la
769 %{_libdir}/libsvn_diff-1.la
770 %{_libdir}/libsvn_fs-1.la
771 %if %{without net_client_only}
772 %{_libdir}/libsvn_fs_base-1.la
773 %endif
774 %{_libdir}/libsvn_fs_fs-1.la
775 %{_libdir}/libsvn_fs_util-1.la
776 %{_libdir}/libsvn_ra-1.la
777 %{_libdir}/libsvn_ra_local-1.la
778 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
779 %{_libdir}/libsvn_ra_svn-1.la
780 %{_libdir}/libsvn_repos-1.la
781 %{_libdir}/libsvn_subr-1.la
782 %{_libdir}/libsvn_wc-1.la
783 %{_includedir}/%{name}-1
784 %{_examplesdir}/%{name}-%{version}
785
786 %files static
787 %defattr(644,root,root,755)
788 %{_libdir}/libsvn_client-1.a
789 %{_libdir}/libsvn_delta-1.a
790 %{_libdir}/libsvn_diff-1.a
791 %{_libdir}/libsvn_fs-1.a
792 %if %{without net_client_only}
793 %{_libdir}/libsvn_fs_base-1.a
794 %endif
795 %{_libdir}/libsvn_fs_fs-1.a
796 %{_libdir}/libsvn_fs_util-1.a
797 %{_libdir}/libsvn_ra-1.a
798 %{_libdir}/libsvn_ra_local-1.a
799 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
800 %{_libdir}/libsvn_ra_svn-1.a
801 %{_libdir}/libsvn_repos-1.a
802 %{_libdir}/libsvn_subr-1.a
803 %{_libdir}/libsvn_wc-1.a
804
805 %if %{with gnome}
806 %files -n gnome-keyring-subversion
807 %defattr(644,root,root,755)
808 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
809 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
810 %endif
811
812 %if %{with kwallet}
813 %files -n kde4-kwallet-subversion
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
816 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
817 %endif
818
819 %if %{without net_client_only}
820 %files svnserve
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_bindir}/svnserve
823 %{_mandir}/man5/svnserve.conf.5*
824 %{_mandir}/man8/svnserve.8*
825 %dir %attr(750,svn,svn) /home/services/subversion
826 %dir %attr(750,svn,svn) /home/services/subversion/repos
827 %if %{with apache}
828 %attr(754,root,root) /etc/rc.d/init.d/svnserve
829 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
830 %endif
831
832 %files tools
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_bindir}/svn-hot-backup
835
836 %files -n bash-completion-subversion
837 %defattr(644,root,root,755)
838 /etc/bash_completion.d/%{name}
839
840 %endif # net_client_only
841
842 %if %{with javahl}
843 %files -n java-subversion
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
846 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
847 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
848 %{_javadir}/svn-javahl.jar
849 %endif
850
851 %if %{with python}
852 %files -n python-subversion
853 %defattr(644,root,root,755)
854 %doc tools/backup/*.py
855 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
856 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
857 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
858 %dir %{py_sitedir}/libsvn
859 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
860 %{py_sitedir}/libsvn/*.py[co]
861 %dir %{py_sitedir}/svn
862 %{py_sitedir}/svn/*.py[co]
863 %{_examplesdir}/python-%{name}-%{version}
864 %endif
865
866 %if %{with csvn}
867 %files -n python-csvn
868 %defattr(644,root,root,755)
869 %doc subversion/bindings/ctypes-python/{README,TODO}
870 %doc subversion/bindings/ctypes-python/examples/*.py
871 %dir %{py_sitescriptdir}/csvn
872 %{py_sitescriptdir}/csvn/*.py[co]
873 %dir %{py_sitescriptdir}/csvn/core
874 %{py_sitescriptdir}/csvn/core/*.py[co]
875 %dir %{py_sitescriptdir}/csvn/ext
876 %{py_sitescriptdir}/csvn/ext/*.py[co]
877 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
878 %endif
879
880 %if %{with perl}
881 %files -n perl-subversion
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
884 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
885 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
886 %{perl_vendorarch}/SVN
887 %dir %{perl_vendorarch}/auto/SVN
888 %dir %{perl_vendorarch}/auto/SVN/*
889 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
890 %{perl_vendorarch}/auto/SVN/*/*.bs
891 %{_mandir}/man3/*.3pm*
892 %endif
893
894 %if %{with ruby}
895 %files -n ruby-subversion
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
898 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
899 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
900 %dir %{ruby_sitelibdir}/svn
901 %{ruby_sitelibdir}/svn/*.rb
902 %dir %{ruby_sitearchdir}/svn
903 %dir %{ruby_sitearchdir}/svn/ext
904 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
905 %{ruby_ridir}/Svn
906 %endif
907
908 %if %{with apache}
909 %files -n apache-mod_dav_svn
910 %defattr(644,root,root,755)
911 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
912 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
913
914 %files -n apache-mod_authz_svn
915 %defattr(644,root,root,755)
916 %doc subversion/mod_authz_svn/INSTALL
917 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
918 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
919 %endif
This page took 0.103116 seconds and 4 git commands to generate.