]> git.pld-linux.org Git - packages/subdownloader.git/blob - subdownloader.spec
rebuild with python 3.10
[packages/subdownloader.git] / subdownloader.spec
1 %define         module          subdownloader
2 Summary:        Fast and Easy Subtitle Downloader
3 Summary(pl.UTF-8):      Narzędzie do automatycznego ściągania/wysyłania podpisów do plików wideo
4 Name:           subdownloader
5 Version:        2.1.0
6 Release:        3
7 License:        GPL v3
8 Group:          X11/Applications/Multimedia
9 Source0:        https://github.com/subdownloader/subdownloader/archive/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  2ee94f8cb2fd1d8eb8742122273e0ae9
11 Source1:        %{name}.desktop
12 Source2:        %{name}.png
13 # Source2-md5:  de3d0cfa08b1572878cde6e3800205fa
14 Source3:        %{name}.sh
15 # site down, and was not in distfiles
16 URL:            http://www.subdownloader.net/
17 BuildRequires:  python3 >= 1:3.4
18 BuildRequires:  python3-PyQt5
19 #BuildRequires: python3-PyQt5-devel-tools
20 BuildRequires:  python3-PyQt5-uic
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.714
23 Requires:       desktop-file-utils
24 #Requires:      python-mmpython
25 Requires:       python3-PyQt5 >= 5.0.0
26 Requires:       python3-pymediainfo
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _appdir %{_datadir}/%{name}
31 %define         _localedir %{py3_sitescriptdir}/subdownloader/client/locale
32
33 %description
34 SubDownloader is a program for automatic download/upload subtitles for
35 videofiles (DivX, MPEG, AVI, VOB, etc) and DVDs using fast hashing.
36
37 Features:
38 - no spyware, no adware, source code is available
39 - it uses fast hashing algorithm (27 GB movies/7 seconds)
40 - recursively folders search
41 - autodetect language of the subtitles
42 - upload entire series seasons' subtitles in less than 1 minute
43 - and many more
44
45 %description -l pl.UTF-8
46 Subdownloader to napisane w Pythonie wolnodostępne narzędzie do
47 automatycznego ściągania/wysyłania podpisów do filmów (DivX, MPEG, AVI
48 itp.).
49
50 Cechy:
51 - brak spyware, adware; dostępny kod źródłowy
52 - wykorzystuje szybki algorytm haszujący (27 GB filmów/7 sekund)
53 - rekurencyjne wyszukiwanie napisów z folderów divx
54 - wysyłanie całych serii podpisów seriali w czasie poniżej minuty
55 - automatyczne wykrywanie języka podpisów
56 - i wiele więcej
57
58 %prep
59 %setup -q
60
61 %{__rm} scripts/gui/rc/images/icon32.ico
62
63 %build
64 %py3_build
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %py3_install
69
70 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
71 # manual was removed in https://github.com/subdownloader/subdownloader/commit/ccdc6552261060c
72 #cp -p subdownloader.1 $RPM_BUILD_ROOT%{_mandir}/man1
73 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
74 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
75
76 %{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/subdownloader/client/locale/subdownloader.pot
77 %{__rm} $RPM_BUILD_ROOT%{py3_sitescriptdir}/subdownloader/client/locale/*/subdownloader.po
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post
83 %update_desktop_database
84
85 %postun
86 %update_desktop_database
87
88 %files
89 %defattr(644,root,root,755)
90 %doc ChangeLog README.md
91 %attr(755,root,root) %{_bindir}/%{name}
92 %if 0
93 %{_mandir}/man1/*.1*
94 %endif
95 %{_desktopdir}/%{name}.desktop
96 %{_pixmapsdir}/%{name}.png
97
98 %dir %{py3_sitescriptdir}/%{module}
99 %{py3_sitescriptdir}/%{module}/*.py
100 %{py3_sitescriptdir}/%{module}/__pycache__
101 %dir %{py3_sitescriptdir}/%{module}/client
102 %{py3_sitescriptdir}/%{module}/client/*.py
103 %{py3_sitescriptdir}/%{module}/client/__pycache__
104 %{py3_sitescriptdir}/%{module}/client/cli
105 %{py3_sitescriptdir}/%{module}/client/gui
106 %{py3_sitescriptdir}/%{module}/client/locale
107 %{py3_sitescriptdir}/%{module}/client/modules
108 %{py3_sitescriptdir}/%{module}/languages
109 %{py3_sitescriptdir}/%{module}/provider
110 %{py3_sitescriptdir}/%{module}-%{version}*-py*.egg-info
This page took 0.066392 seconds and 3 git commands to generate.