]> git.pld-linux.org Git - packages/strigi.git/blob - strigi.spec
- up to 0.7.1
[packages/strigi.git] / strigi.spec
1 #
2 # Conditional build:
3 %bcond_without  dbus            # dbus support
4 #
5 %define         qtver   4.6.0
6 #%define                _svnver 850421
7
8 Summary:        Strigi desktop search
9 Summary(pl.UTF-8):      System wyszukiwania Strigi
10 Name:           strigi
11 Version:        0.7.1
12 Release:        1
13 License:        GPL
14 Group:          X11/Applications
15 Source0:        http://www.vandenoever.info/software/strigi/%{name}-%{version}.tar.bz2
16 # Source0-md5:  c60147f5acd53ac5102ed0c972b279fb
17 URL:            http://strigi.sourceforge.net/
18 BuildRequires:  QtDBus-devel >= %{qtver}
19 BuildRequires:  QtGui-devel >= %{qtver}
20 BuildRequires:  bzip2-devel
21 BuildRequires:  clucene-core-devel
22 BuildRequires:  cmake >= 2.6.2
23 BuildRequires:  cppunit-devel
24 %{?with_dbus:BuildRequires:     dbus-devel >= 1.0}
25 BuildRequires:  exiv2-devel >= 0.18.2
26 BuildRequires:  expat-devel
27 BuildRequires:  fam-devel
28 BuildRequires:  libxml2-devel
29 BuildRequires:  log4cxx-devel
30 %{?with_dbus:BuildRequires:     pkgconfig}
31 BuildRequires:  qt4-build >= %{qtver}
32 BuildRequires:  qt4-qmake >= %{qtver}
33 BuildRequires:  rpmbuild(macros) >= 1.293
34 BuildRequires:  zlib-devel
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Here are the main features of Strigi Desktop Search: very fast
39 crawling, very small memory footprint, no hammering of the system,
40 pluggable backend (currently clucene and hyperestraier, sqlite3 and
41 xapian are in the works), communication between daemon and search
42 program over an abstract interface with two implementations: DBus and
43 a simple Unix socket. Especially the DBus interface makes it very easy
44 to write client applications. There are a few sample scripts in the
45 code using Perl, Python, GTK+ and Qt. Writing clients is so easy that
46 any GNOME or KDE app could implement this. Additionally, there is a
47 simple interface for implementing plugins for extracting information.
48 We'll try to reuse the kat plugins, although native plugins will have
49 a large speed advantage. Strigi also has calculation of sha1 for every
50 file crawled which allows for fast finding of duplicate files.
51
52 %description -l pl.UTF-8
53 Główne cechy systemu wyszukiwania Strigi to: bardzo szybkie
54 przeglądanie, bardzo mały narzut pamięciowy, nieprzytykanie systemu,
55 backend z obsługą wtyczek (aktualnie clucene i hyperestraier, sqlite3
56 i xapian w trakcie rozwoju), komunikacja między demonem a programem
57 wyszukującym po abstrakcyjnym interfejsie z dwiema implementacjami:
58 DBus i prostym gdzieździe uniksowym. Zwłaszcza interfejs DBus znacznie
59 ułatwia pisanie aplikacji klienckich. Istnieje kilka przykładowych
60 skryptów napisanych z użyciem Perla, Pythona, GTK+ i Qt. Tworzenie
61 klientów jest tak proste, że każda aplikacja GNOME czy KDE może to
62 zaimplementować. Ponadto istnieje prosty interfejs do implementowania
63 wtyczek do wydobywania informacji. Autorzy będą próbowali
64 wykorzystywać wtyczki kata, ale natywne wtyczki będą miały większą
65 szybkość. Strigi ma także obliczanie sha1 dla każdego przeglądanego
66 pliku, co pozwala na szybkie znajdowanie duplikatów.
67
68 %package devel
69 Summary:        Header files for strigi
70 Summary(pl.UTF-8):      Pliki nagłówkowe dla strigi
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description devel
75 Header files for strigi.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe dla strigi.
79
80 %prep
81 %setup -q
82
83 %build
84 install -d build
85 cd build
86 # add this to get verbose output
87 #-DCMAKE_VERBOSE_MAKEFILE=1 \
88 %cmake \
89         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
90         -DCMAKE_AR=/usr/bin/ar \
91         -DENABLE_INOTIFY=1 \
92         -DENABLE_FAM=1 \
93         -DENABLE_LOG4CXX=1 \
94 %if "%{_lib}" == "lib64"
95         -DLIB_SUFFIX=64 \
96 %endif
97         ../
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} -C build install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_bindir}/*
116 %attr(755,root,root) %{_libdir}/libsearchclient.so.*.*.*
117 %attr(755,root,root) %{_libdir}/libstreamanalyzer.so.*.*.*
118 %attr(755,root,root) %{_libdir}/libstreams.so.*.*.*
119 %attr(755,root,root) %{_libdir}/libstrigihtmlgui.so.*.*.*
120 %attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libsearchclient.so.0
122 %attr(755,root,root) %ghost %{_libdir}/libstreamanalyzer.so.0
123 %attr(755,root,root) %ghost %{_libdir}/libstreams.so.0
124 %attr(755,root,root) %ghost %{_libdir}/libstrigihtmlgui.so.0
125 %attr(755,root,root) %ghost %{_libdir}/libstrigiqtdbusclient.so.0
126 %dir %{_libdir}/strigi
127 %attr(755,root,root) %{_libdir}/strigi/*.so
128 %{?with_dbus:%{_datadir}/dbus-1/services/*.service}
129 %dir %{_datadir}/strigi
130 %{_datadir}/strigi/fieldproperties
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libsearchclient.so
135 %attr(755,root,root) %{_libdir}/libstreamanalyzer.so
136 %attr(755,root,root) %{_libdir}/libstreams.so
137 %attr(755,root,root) %{_libdir}/libstrigihtmlgui.so
138 %attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so
139 %{_libdir}/strigi/*.cmake
140 %dir %{_includedir}/strigi
141 %{_includedir}/strigi/*.h
142 %{_includedir}/strigi/qtdbus
143 %{_pkgconfigdir}/libstreamanalyzer.pc
144 %{_pkgconfigdir}/libstreams.pc
This page took 0.047348 seconds and 4 git commands to generate.