]> git.pld-linux.org Git - packages/strigi.git/blob - strigi.spec
- pl
[packages/strigi.git] / strigi.spec
1 #
2 # TODO:
3 # - what about strigi daemon?
4 #
5 Summary:        Strigi desktop search
6 Summary(pl.UTF-8):      System wyszukiwania Strigi
7 Name:           strigi
8 Version:        0.5.1
9 Release:        2
10 License:        GPL
11 Group:          X11/Applications
12 Source0:        http://www.vandenoever.info/software/strigi/%{name}-%{version}.tar.bz2
13 # Source0-md5:  b976b4f3cf451fc53cd773c338d78994
14 URL:            http://www.vandenoever.info/software/strigi/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  cmake
18 BuildRequires:  rpmbuild(macros) >= 1.129
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Here are the main features of Strigi Desktop Search: very fast
23 crawling, very small memory footprint, no hammering of the system,
24 pluggable backend (currently clucene and hyperestraier, sqlite3 and
25 xapian are in the works), communication between daemon and search
26 program over an abstract interface with two implementations: DBus and
27 a simple unix socket. Especially the DBus interface makes it very easy
28 to write client applications. There are a few sample scripts in the
29 code using Perl, Python, GTK+ and Qt. Writing clients is so easy that
30 any GNOME or KDE app could implement this. Additionally, there is a
31 simple interface for implementing plugins for extracting information.
32 We'll try to reuse the kat plugins, although native plugins will have
33 a large speed advantage. Strigi also has calculation of sha1 for every
34 file crawled which allows for fast finding of duplicate files.
35
36 %description -l pl.UTF-8
37 Główne cechy systemu wyszukiwania Strigi to: bardzo szybkie
38 przeglądanie, bardzo mały narzut pamięciowy, nieprzytykanie systemu,
39 backend z obsługą wtyczek (aktualnie clucene i hyperestraier, sqlite3
40 i xapian w trakcie rozwoju), komunikacja między demonem a programem
41 wyszukującym po abstrakcyjnym interfejsie z dwiema implementacjami:
42 DBus i prostym gdzieździe uniksowym. Zwłaszcza interfejs DBus znacznie
43 ułatwia pisanie aplikacji klienckich. Istnieje kilka przykładowych
44 skryptów napisanych z użyciem Perla, Pythona, GTK+ i Qt. Tworzenie
45 klientów jest tak proste, że każda aplikacja GNOME czy KDE może to
46 zaimplementować. Ponadto istnieje prosty interfejs do implementowania
47 wtyczek do wydobywania informacji. Autorzy będą próbowali
48 wykorzystywać wtyczki kata, ale natywne wtyczki będą miały większą
49 szybkość. Strigi ma także obliczanie sha1 dla każdego przeglądanego
50 pliku, co pozwala na szybkie znajdowanie duplikatów.
51
52 %package devel
53 Summary:        Header files for strigi
54 Summary(pl.UTF-8):      Pliki nagłówkowe dla strigi
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description devel
59 Header files for strigi.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe dla strigi.
63
64 %prep
65 %setup -q
66
67 %build
68 install -d build
69 cd build
70 %cmake \
71         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
72 %if "%{_lib}" == "lib64"
73         -DLIB_SUFFIX=64 \
74 %endif
75         ../
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} -C build install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_bindir}/*
94 %attr(755,root,root) %{_libdir}/*.so*
95 %dir %{_libdir}/strigi
96 %attr(755,root,root) %{_libdir}/strigi/*.so
97
98 %files devel
99 %defattr(644,root,root,755)
100 %dir %{_includedir}/strigi
101 %{_includedir}/strigi/*.h
102 %{_pkgconfigdir}/*.pc
103 %dir %{_datadir}/strigi
104 %{_datadir}/strigi/fieldproperties
This page took 0.085202 seconds and 4 git commands to generate.