]> git.pld-linux.org Git - packages/strigi.git/blob - strigi.spec
- merged from DEVEL
[packages/strigi.git] / strigi.spec
1 #
2 # Conditional build:
3 %bcond_without  dbus            # dbus support
4 #
5 #
6 # TODO:
7 # - what about strigi daemon?
8 # - Could not find CLucene. Please install CLucene = 0.9.16a (http://clucene.sf.net)
9 # - Cannot find Exiv2 library!
10 #
11 %define         qtver   4.4.3
12 #%define                _svnver 850421
13
14 Summary:        Strigi desktop search
15 Summary(pl.UTF-8):      System wyszukiwania Strigi
16 Name:           strigi
17 Version:        0.6.4
18 Release:        1
19 License:        GPL
20 Group:          X11/Applications
21 Source0:        http://www.vandenoever.info/software/strigi/%{name}-%{version}.tar.bz2
22 # Source0-md5:  324fd9606ac77765501717ff92c04f9a
23 URL:            http://strigi.sourceforge.net/
24 BuildRequires:  QtDBus-devel >= %{qtver}
25 BuildRequires:  QtGui-devel >= %{qtver}
26 BuildRequires:  bzip2-devel
27 BuildRequires:  clucene-core-devel
28 BuildRequires:  cmake >= 2.6.2
29 BuildRequires:  cppunit-devel
30 %{?with_dbus:BuildRequires:     dbus-devel >= 1.0}
31 BuildRequires:  expat-devel
32 BuildRequires:  libxml2-devel
33 BuildRequires:  qt4-build >= %{qtver}
34 BuildRequires:  qt4-qmake >= %{qtver}
35 BuildRequires:  rpmbuild(macros) >= 1.293
36 BuildRequires:  zlib-devel
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Here are the main features of Strigi Desktop Search: very fast
41 crawling, very small memory footprint, no hammering of the system,
42 pluggable backend (currently clucene and hyperestraier, sqlite3 and
43 xapian are in the works), communication between daemon and search
44 program over an abstract interface with two implementations: DBus and
45 a simple Unix socket. Especially the DBus interface makes it very easy
46 to write client applications. There are a few sample scripts in the
47 code using Perl, Python, GTK+ and Qt. Writing clients is so easy that
48 any GNOME or KDE app could implement this. Additionally, there is a
49 simple interface for implementing plugins for extracting information.
50 We'll try to reuse the kat plugins, although native plugins will have
51 a large speed advantage. Strigi also has calculation of sha1 for every
52 file crawled which allows for fast finding of duplicate files.
53
54 %description -l pl.UTF-8
55 Główne cechy systemu wyszukiwania Strigi to: bardzo szybkie
56 przeglądanie, bardzo mały narzut pamięciowy, nieprzytykanie systemu,
57 backend z obsługą wtyczek (aktualnie clucene i hyperestraier, sqlite3
58 i xapian w trakcie rozwoju), komunikacja między demonem a programem
59 wyszukującym po abstrakcyjnym interfejsie z dwiema implementacjami:
60 DBus i prostym gdzieździe uniksowym. Zwłaszcza interfejs DBus znacznie
61 ułatwia pisanie aplikacji klienckich. Istnieje kilka przykładowych
62 skryptów napisanych z użyciem Perla, Pythona, GTK+ i Qt. Tworzenie
63 klientów jest tak proste, że każda aplikacja GNOME czy KDE może to
64 zaimplementować. Ponadto istnieje prosty interfejs do implementowania
65 wtyczek do wydobywania informacji. Autorzy będą próbowali
66 wykorzystywać wtyczki kata, ale natywne wtyczki będą miały większą
67 szybkość. Strigi ma także obliczanie sha1 dla każdego przeglądanego
68 pliku, co pozwala na szybkie znajdowanie duplikatów.
69
70 %package devel
71 Summary:        Header files for strigi
72 Summary(pl.UTF-8):      Pliki nagłówkowe dla strigi
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description devel
77 Header files for strigi.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe dla strigi.
81
82 %prep
83 %setup -q
84
85 %build
86 install -d build
87 cd build
88 # add this to get verbose output
89 #-DCMAKE_VERBOSE_MAKEFILE=1 \
90 %cmake \
91         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
92         -DCMAKE_AR=/usr/bin/ar \
93 %if "%{_lib}" == "lib64"
94         -DLIB_SUFFIX=64 \
95 %endif
96         ../
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} -C build install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_bindir}/*
115 %attr(755,root,root) %{_libdir}/libsearchclient.so.*.*.*
116 %attr(755,root,root) %{_libdir}/libstreamanalyzer.so.*.*.*
117 %attr(755,root,root) %{_libdir}/libstreams.so.*.*.*
118 %attr(755,root,root) %{_libdir}/libstrigihtmlgui.so.*.*.*
119 %attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libsearchclient.so.0
121 %attr(755,root,root) %ghost %{_libdir}/libstreamanalyzer.so.0
122 %attr(755,root,root) %ghost %{_libdir}/libstreams.so.0
123 %attr(755,root,root) %ghost %{_libdir}/libstrigihtmlgui.so.0
124 %attr(755,root,root) %ghost %{_libdir}/libstrigiqtdbusclient.so.0
125 %dir %{_libdir}/strigi
126 %attr(755,root,root) %{_libdir}/strigi/*.so
127 %{?with_dbus:%{_datadir}/dbus-1/services/*.service}
128 %dir %{_datadir}/strigi
129 %{_datadir}/strigi/fieldproperties
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libsearchclient.so
134 %attr(755,root,root) %{_libdir}/libstreamanalyzer.so
135 %attr(755,root,root) %{_libdir}/libstreams.so
136 %attr(755,root,root) %{_libdir}/libstrigihtmlgui.so
137 %attr(755,root,root) %{_libdir}/libstrigiqtdbusclient.so
138 %{_libdir}/strigi/*.cmake
139 %dir %{_includedir}/strigi
140 %{_includedir}/strigi/*.h
141 %{_includedir}/strigi/qtdbus
142 %{_pkgconfigdir}/libstreamanalyzer.pc
143 %{_pkgconfigdir}/libstreams.pc
This page took 0.072203 seconds and 4 git commands to generate.