]> git.pld-linux.org Git - packages/strigi.git/blob - strigi.spec
- build Qt4 client and strigi daemon (added BR's)
[packages/strigi.git] / strigi.spec
1 #
2 # TODO:
3 # - what about strigi daemon?
4 #
5 Summary:        Strigi desktop search
6 Summary(pl.UTF-8):      System wyszukiwania Strigi
7 Name:           strigi
8 Version:        0.5.5
9 Release:        3
10 License:        GPL
11 Group:          X11/Applications
12 Source0:        http://www.vandenoever.info/software/strigi/%{name}-%{version}.tar.bz2
13 # Source0-md5:  bf61ec453f5e0063ea70ace783df3a14
14 URL:            http://www.vandenoever.info/software/strigi/
15 BuildRequires:  QtDBus-devel >= 4.3.0
16 BuildRequires:  QtGui-devel >= 4.3.0
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  clucene-core
20 BuildRequires:  cmake
21 BuildRequires:  rpmbuild(macros) >= 1.129
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Here are the main features of Strigi Desktop Search: very fast
26 crawling, very small memory footprint, no hammering of the system,
27 pluggable backend (currently clucene and hyperestraier, sqlite3 and
28 xapian are in the works), communication between daemon and search
29 program over an abstract interface with two implementations: DBus and
30 a simple unix socket. Especially the DBus interface makes it very easy
31 to write client applications. There are a few sample scripts in the
32 code using Perl, Python, GTK+ and Qt. Writing clients is so easy that
33 any GNOME or KDE app could implement this. Additionally, there is a
34 simple interface for implementing plugins for extracting information.
35 We'll try to reuse the kat plugins, although native plugins will have
36 a large speed advantage. Strigi also has calculation of sha1 for every
37 file crawled which allows for fast finding of duplicate files.
38
39 %description -l pl.UTF-8
40 Główne cechy systemu wyszukiwania Strigi to: bardzo szybkie
41 przeglądanie, bardzo mały narzut pamięciowy, nieprzytykanie systemu,
42 backend z obsługą wtyczek (aktualnie clucene i hyperestraier, sqlite3
43 i xapian w trakcie rozwoju), komunikacja między demonem a programem
44 wyszukującym po abstrakcyjnym interfejsie z dwiema implementacjami:
45 DBus i prostym gdzieździe uniksowym. Zwłaszcza interfejs DBus znacznie
46 ułatwia pisanie aplikacji klienckich. Istnieje kilka przykładowych
47 skryptów napisanych z użyciem Perla, Pythona, GTK+ i Qt. Tworzenie
48 klientów jest tak proste, że każda aplikacja GNOME czy KDE może to
49 zaimplementować. Ponadto istnieje prosty interfejs do implementowania
50 wtyczek do wydobywania informacji. Autorzy będą próbowali
51 wykorzystywać wtyczki kata, ale natywne wtyczki będą miały większą
52 szybkość. Strigi ma także obliczanie sha1 dla każdego przeglądanego
53 pliku, co pozwala na szybkie znajdowanie duplikatów.
54
55 %package devel
56 Summary:        Header files for strigi
57 Summary(pl.UTF-8):      Pliki nagłówkowe dla strigi
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description devel
62 Header files for strigi.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe dla strigi.
66
67 %prep
68 %setup -q
69
70 %build
71 install -d build
72 cd build
73 %cmake \
74         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
75         -DCMAKE_VERBOSE_MAKEFILE=1 \
76 %if "%{_lib}" == "lib64"
77         -DLIB_SUFFIX=64 \
78 %endif
79         ..
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} -C build install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_bindir}/*
98 %attr(755,root,root) %{_libdir}/*.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libstreamanalyzer.so.0
100 %attr(755,root,root) %ghost %{_libdir}/libstreams.so.0
101 %{_datadir}/dbus-1/services/*.service
102 %dir %{_datadir}/strigi
103 %{_datadir}/strigi/fieldproperties
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libstreamanalyzer.so
108 %attr(755,root,root) %{_libdir}/libstreams.so
109 %{_libdir}/strigi/*.cmake
110 %dir %{_includedir}/strigi
111 %{_includedir}/strigi/*.h
112 %dir %{_includedir}/strigi/qtdbus
113 %{_includedir}/strigi/qtdbus/*.h
114 %{_pkgconfigdir}/libstreamanalyzer.pc
115 %{_pkgconfigdir}/libstreams.pc
This page took 0.09385 seconds and 3 git commands to generate.