]> git.pld-linux.org Git - packages/stfl.git/blob - stfl.spec
rebuild with perl 5.32
[packages/stfl.git] / stfl.spec
1 Summary:        STFL implements a curses-based widget set for text terminals
2 Summary(hu.UTF-8):      Az STFL egy curses-alapú widget-készletet biztosít szöveges terminálokhoz
3 Summary(pl.UTF-8):      Implementacja opartego na ncurses zestawu widgetów dla terminali tekstowych
4 Name:           stfl
5 Version:        0.24
6 Release:        6
7 License:        LGPL v3
8 Group:          Libraries
9 Source0:        http://www.clifford.at/stfl/%{name}-%{version}.tar.gz
10 # Source0-md5:  98c764ccc8f13ed05ea22559d7116b96
11 Patch0:         %{name}-example-dir.patch
12 Patch1:         %{name}-link.patch
13 Patch2:         python-install.patch
14 URL:            http://www.clifford.at/stfl/
15 BuildRequires:  ncurses-devel >= 5
16 BuildRequires:  perl-devel
17 BuildRequires:  python-devel
18 BuildRequires:  python-modules
19 BuildRequires:  rpm-perlprov
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  ruby-devel
22 BuildRequires:  swig-perl
23 BuildRequires:  swig-python
24 BuildRequires:  swig-ruby
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 STFL is a library which implements a curses-based widget set for text
29 terminals.
30
31 %description -l hu.UTF-8
32 Az STFL egy curses-alapú widget-készletet biztosít szöveges
33 terminálokhoz.
34
35 %description -l pl.UTF-8
36 STFL jest biblioteką udostępniającą implementacją opartego na ncurses
37 zestawu widgetów dla terminali tekstowych.
38
39 %package devel
40 Summary:        Header files for STFL library
41 Summary(hu.UTF-8):      Az STFL könyvtár fejlesztői fájljai
42 Summary(pl.UTF-8):      Pliki nagłówekowe biblioteki STFL
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for STFL library.
48
49 %description devel -l hu.UTF-8
50 Az STFL könyvtár fejlesztői fájljai.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki STFL.
54
55 %package static
56 Summary:        Static STFL library
57 Summary(hu.UTF-8):      Statikus STFL könyvtár
58 Summary(pl.UTF-8):      Statyczna biblioteka STFL
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static STFL library.
64
65 %description static -l hu.UTF-8
66 Statikus STFL könyvtár.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka STFL.
70
71 %package -n perl-%{name}
72 Summary:        Perl binding for STFL
73 Summary(hu.UTF-8):      Perl kapcsolódás STFL-hez
74 Summary(pl.UTF-8):      Wiązania Perla dla STFL-a
75 Group:          Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Obsoletes:      stfl-perl
78
79 %description -n perl-%{name}
80 Perl binding for STFL.
81
82 %description -n perl-%{name} -l hu.UTF-8
83 Perl kapcsolódás STFL-hez.
84
85 %description -n perl-%{name} -l pl.UTF-8
86 Wiązania Perla dla STFL-a.
87
88 %package -n python-%{name}
89 Summary:        Python binding for STFL
90 Summary(hu.UTF-8):      Python kapcsolódás STFL-hez
91 Summary(pl.UTF-8):      Wiązania Pythona dla STFL-a
92 Group:          Libraries
93 Requires:       %{name} = %{version}-%{release}
94 Obsoletes:      stfl-python
95
96 %description -n python-%{name}
97 Python binding for STFL.
98
99 %description -n python-%{name} -l hu.UTF-8
100 Python kapcsolódás STFL-hez.
101
102 %description -n python-%{name} -l pl.UTF-8
103 Wiązania Pythona dla STFL-a.
104
105 %package -n ruby-%{name}
106 Summary:        Ruby binding for STFL
107 Summary(hu.UTF-8):      Ruby kapcsolódás STFL-hez
108 Summary(pl.UTF-8):      Wiązania Ruby'ego dla STFL-a
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111 Obsoletes:      stfl-ruby
112
113 %description -n ruby-%{name}
114 Ruby binding for STFL.
115
116 %description -n ruby-%{name} -l hu.UTF-8
117 Ruby kapcsolódás STFL-hez.
118
119 %description -n ruby-%{name} -l pl.UTF-8
120 Wiązania Ruby'ego dla STFL-a.
121
122 %prep
123 %setup -q
124 %patch0 -p1
125 %patch1 -p1
126 %patch2 -p1
127 echo 'LDLIBS=-ltinfow' >> Makefile.cfg
128
129 %build
130 %{__make} -j1 \
131         prefix="" \
132         libdir=%{_libdir} \
133         CFLAGS="-Wall %{rpmcppflags} %{rpmcflags} -I. -D_GNU_SOURCE -fPIC" \
134         LDFLAGS="%{rpmldflags}" \
135         CC="%{__cc} -pthread"
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT%{py_libdir}/lib-dynload
140
141 %{__make} -j1 install \
142         prefix=%{_prefix} \
143         libdir=%{_lib} \
144         RUBYARCHDIR=$RPM_BUILD_ROOT%{ruby_vendorarchdir} \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 /sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}
148
149 %{__mv} $RPM_BUILD_ROOT%{py_sitedir}/lib-dynload/_stfl.so \
150         $RPM_BUILD_ROOT%{py_sitedir}
151 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
152 %py_postclean
153
154 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
155 install example{,.c,.stfl} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %doc README
166 %attr(755,root,root) %{_libdir}/libstfl.so.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libstfl.so.0
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/libstfl.so
172 %{_includedir}/stfl.h
173 %{_pkgconfigdir}/stfl.pc
174 %dir %{_examplesdir}/%{name}-%{version}
175 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/example
176 %{_examplesdir}/%{name}-%{version}/example.*
177
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/libstfl.a
181
182 %files -n perl-%{name}
183 %defattr(644,root,root,755)
184 %doc perl5/example.pl
185 %{perl_vendorarch}/stfl.pm
186 %dir %{perl_vendorarch}/auto/stfl
187 %attr(755,root,root) %{perl_vendorarch}/auto/stfl/stfl.so
188
189 %files -n python-%{name}
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{py_sitedir}/_stfl.so
192 %{py_sitedir}/stfl.py[co]
193
194 %files -n ruby-%{name}
195 %defattr(644,root,root,755)
196 %doc ruby/example.rb
197 %attr(755,root,root) %{ruby_vendorarchdir}/stfl.so
This page took 0.093756 seconds and 3 git commands to generate.