]> git.pld-linux.org Git - packages/stfl.git/blob - stfl.spec
8d64e364c2e86344e56a58ffb9a1c1b9411c7b36
[packages/stfl.git] / stfl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        STFL implements a curses-based widget set for text terminals
3 Summary(hu.UTF-8):      Az STFL egy curses-alapú widget-készletet biztosít szöveges terminálokhoz
4 Summary(pl.UTF-8):      Implementacja opartego na ncurses zestawu widgetów dla terminali tekstowych
5 Name:           stfl
6 Version:        0.22
7 Release:        4
8 License:        LGPL v3
9 Group:          Libraries
10 Source0:        http://www.clifford.at/stfl/%{name}-%{version}.tar.gz
11 # Source0-md5:  df4998f69fed15fabd702a25777f74ab
12 URL:            http://www.clifford.at/stfl/
13 Patch0:         %{name}-example-dir.patch
14 Patch1:         %{name}-link.patch
15 BuildRequires:  ncurses-devel
16 BuildRequires:  perl-devel
17 BuildRequires:  python-devel
18 BuildRequires:  python-modules
19 BuildRequires:  rpm-perlprov
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  ruby-devel
22 BuildRequires:  swig-perl
23 BuildRequires:  swig-python
24 BuildRequires:  swig-ruby
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 STFL is a library which implements a curses-based widget set for text
29 terminals.
30
31 %description -l hu.UTF-8
32 Az STFL egy curses-alapú widget-készletet biztosít szöveges
33 terminálokhoz.
34
35 %description -l pl.UTF-8
36 STFL jest biblioteką udostępniającą implementacją opartego na ncurses
37 zestawu widgetów dla terminali tekstowych.
38
39 %package devel
40 Summary:        Header files for STFL library
41 Summary(hu.UTF-8):      Az STFL könyvtár fejlesztői fájljai
42 Summary(pl.UTF-8):      Pliki nagłówekowe biblioteki STFL
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for STFL library.
48
49 %description devel -l hu.UTF-8
50 Az STFL könyvtár fejlesztői fájljai.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki STFL.
54
55 %package static
56 Summary:        Static STFL library
57 Summary(hu.UTF-8):      Statikus STFL könyvtár
58 Summary(pl.UTF-8):      Statyczna biblioteka STFL
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static STFL library.
64
65 %description static -l hu.UTF-8
66 Statikus STFL könyvtár.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka STFL.
70
71 %package -n perl-%{name}
72 Summary:        Perl binding for STFL
73 Summary(hu.UTF-8):      Perl kapcsolódás STFL-hez
74 Summary(pl.UTF-8):      Wiązania Perla dla STFLa
75 Group:          Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Obsoletes:      stfl-perl
78
79 %description -n perl-%{name}
80 Perl binding for STFL.
81
82 %description -n perl-%{name} -l hu.UTF-8
83 Perl kapcsolódás STFL-hez.
84
85 %description -n perl-%{name} -l pl.UTF-8
86 Wiązania Perla dla STFLa.
87
88 %package -n python-%{name}
89 Summary:        Python binding for STFL
90 Summary(hu.UTF-8):      Python kapcsolódás STFL-hez
91 Summary(pl.UTF-8):      Wiązania Pythona dla STFLa
92 Group:          Libraries
93 Requires:       %{name} = %{version}-%{release}
94 Obsoletes:      stfl-python
95
96 %description -n python-%{name}
97 Python binding for STFL.
98
99 %description -n python-%{name} -l hu.UTF-8
100 Python kapcsolódás STFL-hez.
101
102 %description -n python-%{name} -l pl.UTF-8
103 Wiązania Pythona dla STFLa.
104
105 %package -n ruby-%{name}
106 Summary:        Ruby binding for STFL
107 Summary(hu.UTF-8):      Ruby kapcsolódás STFL-hez
108 Summary(pl.UTF-8):      Wiązania Ruby'ego dla STFLa
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111 Obsoletes:      stfl-ruby
112
113 %description -n ruby-%{name}
114 Ruby binding for STFL.
115
116 %description -n ruby-%{name} -l hu.UTF-8
117 Ruby kapcsolódás STFL-hez.
118
119 %description -n ruby-%{name} -l pl.UTF-8
120 Wiązania Ruby'ego dla STFLa.
121
122 %prep
123 %setup -q
124 %patch0 -p1
125 %patch1 -p1
126 echo 'LDLIBS=-ltinfow' >> Makefile.cfg
127
128 %build
129 %{__make} -j1 \
130         prefix="" \
131         libdir=%{_libdir} \
132         CFLAGS="-Wall %{rpmcppflags} %{rpmcflags} -I. -D_GNU_SOURCE -fPIC" \
133         LDFLAGS="%{rpmldflags}" \
134         CC="%{__cc} -pthread"
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 install -d $RPM_BUILD_ROOT%{py_libdir}/lib-dynload
140
141 %{__make} -j1 install \
142         prefix=%{_prefix} \
143         libdir=%{_lib} \
144         RUBYARCHDIR=$RPM_BUILD_ROOT%{ruby_vendorarchdir} \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 mv  $RPM_BUILD_ROOT%{py_libdir}/site-packages/lib-dynload/_stfl.so \
148         $RPM_BUILD_ROOT%{py_libdir}/lib-dynload
149
150 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
151 install example{,.c,.stfl} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
152
153 ln -sf libstfl.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libstfl.so.0
154
155 %post -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %files
162 %defattr(644,root,root,755)
163 %doc README
164 %attr(755,root,root) %{_libdir}/libstfl.so.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libstfl.so.0
166
167 %files devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libstfl.so
170 %{_includedir}/stfl.h
171 %{_pkgconfigdir}/stfl.pc
172 %dir %{_examplesdir}/%{name}-%{version}
173 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/example
174 %{_examplesdir}/%{name}-%{version}/example.*
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/lib*.a
179
180 %files -n perl-%{name}
181 %defattr(644,root,root,755)
182 %doc perl5/example.pl
183 %{perl_vendorarch}/stfl.pm
184 %dir %{perl_vendorarch}/auto/stfl
185 %attr(755,root,root) %{perl_vendorarch}/auto/stfl/stfl.so
186
187 %files -n python-%{name}
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{py_libdir}/lib-dynload/_stfl.so
190 %{py_libdir}/site-packages/stfl.pyc
191
192 %files -n ruby-%{name}
193 %defattr(644,root,root,755)
194 %doc ruby/example.rb
195 %attr(755,root,root) %{ruby_vendorarchdir}/stfl.so
This page took 0.058812 seconds and 2 git commands to generate.