]> git.pld-linux.org Git - packages/srt.git/blob - srt.spec
don't override CMAKE_BUILD_TYPE; rel 2
[packages/srt.git] / srt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Secure Reliable Transport library
6 Summary(pl.UTF-8):      Biblioteka Secure Reliable Transport
7 Name:           srt
8 Version:        1.4.3
9 Release:        2
10 License:        MPL v2.0
11 Group:          Libraries
12 #Source0Download: https://github.com/Haivision/srt/releases
13 Source0:        https://github.com/Haivision/srt/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  3ed903e5a32b9ee9ec011028fb34f331
15 Patch0:         %{name}-build_type.patch
16 URL:            https://www.srtalliance.org/
17 BuildRequires:  cmake >= 2.8.12
18 BuildRequires:  libstdc++-devel >= 6:4.7
19 BuildRequires:  pkgconfig
20 BuildRequires:  openssl-devel
21 BuildRequires:  rpmbuild(macros) >= 1.605
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Secure Reliable Transport (SRT) is an open source transport technology
26 that optimizes streaming performance across unpredictable networks,
27 such as the Internet.
28
29 %description -l pl.UTF-8
30 Secure Reliable Transport (SRT) to oparta na otwartych źródłach
31 technika transportu optymalizująca wydajność przesyłania strumieni po
32 nieprzewidywalnych sieciach, takich jak Internet.
33
34 %package devel
35 Summary:        Header files for SRT library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SRT
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       libstdc++-devel >= 6:4.7
40
41 %description devel
42 Header files for SRT library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki SRT.
46
47 %package static
48 Summary:        Static SRT library
49 Summary(pl.UTF-8):      Statyczna biblioteka SRT
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static SRT library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka SRT.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 %build
64 install -d build
65 cd build
66 # .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
67 %cmake .. \
68         -DCMAKE_INSTALL_INCLUDEDIR=include \
69         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
70         -DENABLE_CXX_DEPS=OFF \
71         %{!?with_static_libs:-DENABLE_STATIC=OFF}
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} -C build install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc README.md docs/apps/*.md docs/{features,misc}/{*.md,images}
90 %attr(755,root,root) %{_bindir}/srt-ffplay
91 %attr(755,root,root) %{_bindir}/srt-file-transmit
92 %attr(755,root,root) %{_bindir}/srt-live-transmit
93 %attr(755,root,root) %{_bindir}/srt-tunnel
94 %attr(755,root,root) %{_libdir}/libsrt.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libsrt.so.1.4
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libsrt.so
100 %{_includedir}/srt
101 %{_pkgconfigdir}/haisrt.pc
102 %{_pkgconfigdir}/srt.pc
103
104 %if %{with static_libs}
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/libsrt.a
108 %endif
This page took 0.059205 seconds and 3 git commands to generate.