]> git.pld-linux.org Git - packages/srt.git/blob - srt.spec
78290e636e000f894b0771f2011536a01252cbeb
[packages/srt.git] / srt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Secure Reliable Transport library
6 Summary(pl.UTF-8):      Biblioteka Secure Reliable Transport
7 Name:           srt
8 Version:        1.4.3
9 Release:        1
10 License:        MPL v2.0
11 Group:          Libraries
12 #Source0Download: https://github.com/Haivision/srt/releases
13 Source0:        https://github.com/Haivision/srt/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  3ed903e5a32b9ee9ec011028fb34f331
15 URL:            https://www.srtalliance.org/
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  libstdc++-devel >= 6:4.7
18 BuildRequires:  pkgconfig
19 BuildRequires:  openssl-devel
20 BuildRequires:  rpmbuild(macros) >= 1.605
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Secure Reliable Transport (SRT) is an open source transport technology
25 that optimizes streaming performance across unpredictable networks,
26 such as the Internet.
27
28 %description -l pl.UTF-8
29 Secure Reliable Transport (SRT) to oparta na otwartych źródłach
30 technika transportu optymalizująca wydajność przesyłania strumieni po
31 nieprzewidywalnych sieciach, takich jak Internet.
32
33 %package devel
34 Summary:        Header files for SRT library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SRT
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       libstdc++-devel >= 6:4.7
39
40 %description devel
41 Header files for SRT library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki SRT.
45
46 %package static
47 Summary:        Static SRT library
48 Summary(pl.UTF-8):      Statyczna biblioteka SRT
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static SRT library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka SRT.
57
58 %prep
59 %setup -q
60
61 %build
62 install -d build
63 cd build
64 # .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
65 %cmake .. \
66         -DCMAKE_INSTALL_INCLUDEDIR=include \
67         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
68         -DENABLE_CXX_DEPS=OFF \
69         %{!?with_static_libs:-DENABLE_STATIC=OFF}
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} -C build install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files
86 %defattr(644,root,root,755)
87 %doc README.md docs/apps/*.md docs/{features,misc}/{*.md,images}
88 %attr(755,root,root) %{_bindir}/srt-ffplay
89 %attr(755,root,root) %{_bindir}/srt-file-transmit
90 %attr(755,root,root) %{_bindir}/srt-live-transmit
91 %attr(755,root,root) %{_bindir}/srt-tunnel
92 %attr(755,root,root) %{_libdir}/libsrt.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libsrt.so.1.4
94
95 %files devel
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/libsrt.so
98 %{_includedir}/srt
99 %{_pkgconfigdir}/haisrt.pc
100 %{_pkgconfigdir}/srt.pc
101
102 %if %{with static_libs}
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/libsrt.a
106 %endif
This page took 0.041323 seconds and 2 git commands to generate.