]> git.pld-linux.org Git - packages/srt.git/blob - srt.spec
- updated to 1.4.1
[packages/srt.git] / srt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Secure Reliable Transport library
6 Summary(pl.UTF-8):      Biblioteka Secure Reliable Transport
7 Name:           srt
8 Version:        1.4.1
9 Release:        1
10 License:        MPL v2.0
11 Group:          Libraries
12 #Source0Download: https://github.com/Haivision/srt/releases
13 Source0:        https://github.com/Haivision/srt/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  8e5a9654933d0af31d78f723fc8fa355
15 URL:            https://www.srtalliance.org/
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  libstdc++-devel >= 6:4.7
18 BuildRequires:  pkgconfig
19 BuildRequires:  openssl-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Secure Reliable Transport (SRT) is an open source transport technology
24 that optimizes streaming performance across unpredictable networks,
25 such as the Internet.
26
27 %description -l pl.UTF-8
28 Secure Reliable Transport (SRT) to oparta na otwartych źródłach
29 technika transportu optymalizująca wydajność przesyłania strumieni po
30 nieprzewidywalnych sieciach, takich jak Internet.
31
32 %package devel
33 Summary:        Header files for SRT library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SRT
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libstdc++-devel >= 6:4.7
38
39 %description devel
40 Header files for SRT library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki SRT.
44
45 %package static
46 Summary:        Static SRT library
47 Summary(pl.UTF-8):      Statyczna biblioteka SRT
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static SRT library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka SRT.
56
57 %prep
58 %setup -q
59
60 %build
61 install -d build
62 cd build
63 # .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
64 %cmake .. \
65         -DCMAKE_INSTALL_INCLUDEDIR=include \
66         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
67         -DENABLE_CXX_DEPS=OFF \
68         %{!?with_static_libs:-DENABLE_STATIC=OFF}
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} -C build install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc README.md docs/{*.md,images}
87 %attr(755,root,root) %{_bindir}/srt-ffplay
88 %attr(755,root,root) %{_bindir}/srt-file-transmit
89 %attr(755,root,root) %{_bindir}/srt-live-transmit
90 %attr(755,root,root) %{_bindir}/srt-tunnel
91 %attr(755,root,root) %{_libdir}/libsrt.so.*.*.*
92 %attr(755,root,root) %ghost %{_libdir}/libsrt.so.1
93
94 %files devel
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_libdir}/libsrt.so
97 %{_includedir}/srt
98 %{_pkgconfigdir}/haisrt.pc
99 %{_pkgconfigdir}/srt.pc
100
101 %if %{with static_libs}
102 %files static
103 %defattr(644,root,root,755)
104 %{_libdir}/libsrt.a
105 %endif
This page took 0.057341 seconds and 3 git commands to generate.