]> git.pld-linux.org Git - packages/sqlitebrowser.git/blob - sqlitebrowser.spec
0a2fe2321ac02c53534074d00dd42499113ea7bf
[packages/sqlitebrowser.git] / sqlitebrowser.spec
1 # TODO: use system-wide QCustomPlot
2 Summary:        DB Browser for SQLite
3 Name:           sqlitebrowser
4 Version:        3.7.0
5 Release:        6
6 License:        MPLv2/GPLv3
7 Group:          Applications/Databases/Interfaces
8 Source0:        https://github.com/sqlitebrowser/sqlitebrowser/archive/v%{version}.tar.gz
9 # Source0-md5:  1033f076944316a713d4831bf581cf3a
10 URL:            http://sqlitebrowser.org/
11 #BuildRequires: QCustomPlot-devel
12 BuildRequires:  QtCore-devel
13 BuildRequires:  QtGui-devel
14 BuildRequires:  QtNetwork-devel
15 BuildRequires:  antlr
16 BuildRequires:  cmake >= 2.8.7
17 BuildRequires:  qscintilla2-qt4-devel
18 BuildRequires:  qt4-build
19 BuildRequires:  qt4-linguist
20 BuildRequires:  rpmbuild(macros) >= 1.596
21 BuildRequires:  sqlite3-devel
22 Requires:       desktop-file-utils
23 Requires:       gtk-update-icon-cache
24 Requires:       hicolor-icon-theme
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 SQLite Database Browser is a freeware, public domain, open source
29 visual tool used to create, design and edit database files compatible
30 with SQLite. It is meant to be used for users and developers that want
31 to create databases, edit and search data using a familiarspreadsheet-
32 -like interface, without the need to learn complicated SQL commands.
33
34 %prep
35 %setup -q
36 # use system-wide qscintilla2
37 sed -e '/QSCINTILLA_DIR[ }][^"]/d' -e 's/qcustomplot qscintilla2/qcustomplot/' -i CMakeLists.txt
38
39 %build
40 mkdir build
41 cd build
42 %cmake ../ \
43         -DBUILD_SHARED_LIBS:BOOL=OFF
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %{__make} -C build install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 %update_desktop_database
56 %update_icon_cache hicolor
57
58 %postun
59 %update_desktop_database
60 %update_icon_cache hicolor
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README.md
65 %attr(755,root,root) %{_bindir}/%{name}
66 %{_desktopdir}/%{name}.desktop
67 %{_iconsdir}/hicolor/*/apps/%{name}.png
68 %{_datadir}/appdata/sqlitebrowser.desktop.appdata.xml
This page took 0.051456 seconds and 2 git commands to generate.