]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- install tcl module in proper libdir
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - fix lib64 in tcl module
3 # - date test fail on tcl8.5 because of missing tcl library initialization
4 #   (and thus unavailable clock command)
5 #
6 # Conditional build:
7 %bcond_without  tests # don't run tests
8 %bcond_without  tcl   # disable tcl extension
9 %bcond_without  doc  # disable documentation building
10 #
11 Summary:        SQLite library
12 Summary(pl.UTF-8):      Biblioteka SQLite
13 Name:           sqlite3
14 Version:        3.5.0
15 Release:        1
16 License:        LGPL
17 Group:          Libraries
18 # Source0Download: http://sqlite.org/download.html
19 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
20 # Source0-md5:  7ff857e572d85b8fa865c7d36886a67b
21 Patch0:         %{name}-sign-function.patch
22 Patch1:         %{name}-pkgconfig.patch
23 URL:            http://sqlite.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  libtool
27 BuildRequires:  readline-devel
28 %{?with_tcl:BuildRequires:      tcl-devel}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %ifarch alpha sparc %{x8664}
32 %undefine       with_tests
33 %endif
34
35 # disabling tcl currently breaks making test target,
36 # some hack in Makefile needs to be done
37 %if !%{with tcl}
38 %undefine       with_tests
39 %endif
40
41 %define         _ulibdir        /usr/lib
42 %define         tclver          %(rpm -q --qf '%{V}' tcl)
43
44 %description
45 SQLite is a C library that implements an SQL database engine. A large
46 subset of SQL92 is supported. A complete database is stored in a
47 single disk file. The API is designed for convenience and ease of use.
48 Applications that link against SQLite can enjoy the power and
49 flexiblity of an SQL database without the administrative hassles of
50 supporting a separate database server. Because it omits the
51 client-server interaction overhead and writes directly to disk, SQLite
52 is also faster than the big database servers for most operations. In
53 addition to the C library, the SQLite distribution includes a
54 command-line tool for interacting with SQLite databases and SQLite
55 bindings for Tcl/Tk.
56
57 %description -l pl.UTF-8
58 SQLite jest biblioteką języka C, która implementuje silnik baz danych
59 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
60 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
61 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
62 danych bez konieczności utrzymywania osobnego serwera baz danych.
63 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
64 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
65 bazodanowych przy większości operacji na bazie danych. Dodatkowo
66 oprócz biblioteki języka C, dostarczany jest program do zarządzania
67 bazami danych.
68
69 %package devel
70 Summary:        Header files for SQLite development
71 Summary(pl.UTF-8):      Pliki nagłówkowe SQLite
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74
75 %description devel
76 SQLite is a C library that implements an SQL database engine. A large
77 subset of SQL92 is supported. A complete database is stored in a
78 single disk file. The API is designed for convenience and ease of use.
79 Applications that link against SQLite can enjoy the power and
80 flexiblity of an SQL database without the administrative hassles of
81 supporting a separate database server. Because it omits the
82 client-server interaction overhead and writes directly to disk, SQLite
83 is also faster than the big database servers for most operations. In
84 addition to the C library, the SQLite distribution includes a
85 command-line tool for interacting with SQLite databases and SQLite
86 bindings for Tcl/Tk.
87
88 This package contains the header files needed to develop programs that
89 use these SQLite.
90
91 %description devel -l pl.UTF-8
92 SQLite jest biblioteką języka C, która implementuje silnik baz danych
93 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
94 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
95 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
96 danych bez konieczności utrzymywania osobnego serwera baz danych.
97 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
98 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
99 bazodanowych przy większości operacji na bazie danych. Dodatkowo
100 oprócz biblioteki języka C, dostarczany jest program do zarządzania
101 bazami danych.
102
103 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
104 używających biblioteki SQLite.
105
106 %package static
107 Summary:        Static libraries for SQLite development
108 Summary(pl.UTF-8):      Statyczne biblioteki SQLite
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111
112 %description static
113 SQLite is a C library that implements an SQL database engine. A large
114 subset of SQL92 is supported. A complete database is stored in a
115 single disk file. The API is designed for convenience and ease of use.
116 Applications that link against SQLite can enjoy the power and
117 flexiblity of an SQL database without the administrative hassles of
118 supporting a separate database server. Because it omits the
119 client-server interaction overhead and writes directly to disk, SQLite
120 is also faster than the big database servers for most operations. In
121 addition to the C library, the SQLite distribution includes a
122 command-line tool for interacting with SQLite databases and SQLite
123 bindings for Tcl/Tk.
124
125 This package contains the static SQLite libraries.
126
127 %description static -l pl.UTF-8
128 SQLite jest biblioteką języka C, która implementuje silnik baz danych
129 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
130 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
131 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
132 danych bez konieczności utrzymywania osobnego serwera baz danych.
133 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
134 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
135 bazodanowych przy większości operacji na bazie danych. Dodatkowo
136 oprócz biblioteki języka C, dostarczany jest program do zarządzania
137 bazami danych.
138
139 Pakiet zawiera statyczne biblioteki SQLite.
140
141 %package -n tcl-%{name}
142 Summary:        sqlite3 tcl extension
143 Summary(pl.UTF-8):      Rozszerzenie sqlite3 dla Tcl
144 Group:          Development/Languages/Tcl
145
146 %description -n tcl-%{name}
147 sqlite3 tcl extension.
148
149 %description -n tcl-%{name} -l pl.UTF-8
150 Rozszerzenie sqlite3 dla Tcl.
151
152 %prep
153 %setup -q -n sqlite-%{version}
154 %patch0 -p1
155 %patch1 -p1
156
157 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
158
159 %build
160 %{__libtoolize}
161 cp -f /usr/share/automake/config.sub .
162 %{__aclocal}
163 %{__autoconf}
164 %configure \
165         %{?with_tcl:--with-tcl=%{_ulibdir}} \
166         %{!?with_tcl:--disable-tcl} \
167         --enable-threadsafe
168 %{__make}
169
170 %if %{with doc}
171 %{__make} doc
172 %endif
173
174 %{?with_tests:LC_ALL=C %{__make} test}
175
176 %install
177 rm -rf $RPM_BUILD_ROOT
178 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
179
180 %{__make} install \
181         DESTDIR=$RPM_BUILD_ROOT \
182         TCLLIBDIR=%{_libdir}/tcl%{tclver}
183
184 %if %{with tcl}
185 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl*/sqlite3/*.tcl
186 %endif
187
188 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %post   -p /sbin/ldconfig
194 %postun -p /sbin/ldconfig
195
196 %files
197 %defattr(644,root,root,755)
198 %doc README
199 %attr(755,root,root) %{_bindir}/sqlite3
200 %attr(755,root,root) %{_libdir}/lib*.so.*.*
201 %{_mandir}/man1/sqlite3.1*
202
203 %files devel
204 %defattr(644,root,root,755)
205 %doc doc/*
206 %attr(755,root,root) %{_libdir}/lib*.so
207 %{_libdir}/lib*.la
208 %{_includedir}/sqlite3.h
209 %{_includedir}/sqlite3ext.h
210 %{_pkgconfigdir}/*.pc
211
212 %files static
213 %defattr(644,root,root,755)
214 %{_libdir}/lib*.a
215
216 %if %{with tcl}
217 %files -n tcl-%{name}
218 %defattr(644,root,root,755)
219 %dir %{_libdir}/tcl*/sqlite3
220 %attr(755,root,root) %{_libdir}/tcl*/sqlite3/*.so
221 %{_libdir}/tcl*/sqlite3/*.tcl
222 %endif
This page took 0.093377 seconds and 4 git commands to generate.