]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- up to 3.2.8
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - fix lib64 in tcl module
3 #
4 # Conditional build:
5 %bcond_without  tests # don't run tests
6 %bcond_without  tcl   # disable tcl extension
7 %bcond_without  docs  # disable documentation building
8 #
9 Summary:        SQLite library
10 Summary(pl):    Biblioteka SQLite
11 Name:           sqlite3
12 Version:        3.2.8
13 Release:        0.1
14 License:        LGPL
15 Group:          Libraries
16 # Source0Download: http://sqlite.org/download.html
17 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
18 # Source0-md5:  9f2c014aaa46565b8163e047166a5686
19 Patch0:         %{name}-test-conflict.patch
20 Patch1:         %{name}-sign-function.patch
21 URL:            http://sqlite.org/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  libtool
25 BuildRequires:  readline-devel
26 %{?with_tcl:BuildRequires:      tcl-devel}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %ifarch alpha %{x8664}
30 %undefine       with_tests
31 %endif
32
33 # disabling tcl currently breaks making test target,
34 # some hack in Makefile needs to be done
35 %if %{without tcl}
36 %undefine       with_tests
37 %endif
38
39 %define         _ulibdir        /usr/lib
40
41 %description
42 SQLite is a C library that implements an SQL database engine. A large
43 subset of SQL92 is supported. A complete database is stored in a
44 single disk file. The API is designed for convenience and ease of use.
45 Applications that link against SQLite can enjoy the power and
46 flexiblity of an SQL database without the administrative hassles of
47 supporting a separate database server. Because it omits the
48 client-server interaction overhead and writes directly to disk, SQLite
49 is also faster than the big database servers for most operations. In
50 addition to the C library, the SQLite distribution includes a
51 command-line tool for interacting with SQLite databases and SQLite
52 bindings for Tcl/Tk.
53
54 %description -l pl
55 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
56 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
57 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
58 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
59 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
60 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
61 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
62 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
63 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
64 bazami danych.
65
66 %package devel
67 Summary:        Header files for SQLite development
68 Summary(pl):    Pliki nag³ówkowe SQLite
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71
72 %description devel
73 SQLite is a C library that implements an SQL database engine. A large
74 subset of SQL92 is supported. A complete database is stored in a
75 single disk file. The API is designed for convenience and ease of use.
76 Applications that link against SQLite can enjoy the power and
77 flexiblity of an SQL database without the administrative hassles of
78 supporting a separate database server. Because it omits the
79 client-server interaction overhead and writes directly to disk, SQLite
80 is also faster than the big database servers for most operations. In
81 addition to the C library, the SQLite distribution includes a
82 command-line tool for interacting with SQLite databases and SQLite
83 bindings for Tcl/Tk.
84
85 This package contains the header files needed to develop programs that
86 use these SQLite.
87
88 %description devel -l pl
89 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
90 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
91 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
92 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
93 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
94 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
95 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
96 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
97 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
98 bazami danych.
99
100 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
101 u¿ywaj±cych biblioteki SQLite.
102
103 %package static
104 Summary:        Static libraries for SQLite development
105 Summary(pl):    Statyczne biblioteki SQLite
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108
109 %description static
110 SQLite is a C library that implements an SQL database engine. A large
111 subset of SQL92 is supported. A complete database is stored in a
112 single disk file. The API is designed for convenience and ease of use.
113 Applications that link against SQLite can enjoy the power and
114 flexiblity of an SQL database without the administrative hassles of
115 supporting a separate database server. Because it omits the
116 client-server interaction overhead and writes directly to disk, SQLite
117 is also faster than the big database servers for most operations. In
118 addition to the C library, the SQLite distribution includes a
119 command-line tool for interacting with SQLite databases and SQLite
120 bindings for Tcl/Tk.
121
122 This package contains the static SQLite libraries.
123
124 %description static -l pl
125 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
126 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
127 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
128 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
129 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
130 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
131 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
132 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
133 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
134 bazami danych.
135
136 Pakiet zawiera statyczne biblioteki SQLite.
137
138 %package -n tcl-%{name}
139 Summary:        sqlite3 tcl extension
140 Summary(pl):    Rozszerzenie sqlite3 dla Tcl
141 Group:          Development/Languages/Tcl
142
143 %description -n tcl-%{name}
144 sqlite3 tcl extension.
145
146 %description -l pl -n tcl-%{name}
147 Rozszerzenie sqlite3 dla Tcl.
148
149 %prep
150 %setup -q -n sqlite-%{version}
151 %patch0 -p1
152 %patch1 -p1
153 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
154
155 %build
156 %{__libtoolize}
157 cp -f /usr/share/automake/config.sub .
158 %{__aclocal}
159 %{__autoconf}
160 %configure \
161         %{?with_tcl:--with-tcl=%{_ulibdir}} \
162         %{!?with_tcl:--disable-tcl} \
163         --enable-threadsafe
164 %{__make}
165
166 %if %{with docs}
167 %{__make} doc
168 %endif
169
170 %{?with_tests:LC_ALL=C %{__make} test}
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
175
176 %{__make} install \
177         DESTDIR=$RPM_BUILD_ROOT
178
179 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %post   -p /sbin/ldconfig
185 %postun -p /sbin/ldconfig
186
187 %files
188 %defattr(644,root,root,755)
189 %doc README
190 %attr(755,root,root) %{_bindir}/sqlite3
191 %attr(755,root,root) %{_libdir}/lib*.so.*.*
192 %{_mandir}/man1/sqlite3.1*
193
194 %files devel
195 %defattr(644,root,root,755)
196 %doc doc/*
197 %attr(755,root,root) %{_libdir}/lib*.so
198 %{_libdir}/lib*.la
199 %{_includedir}/sqlite3.h
200 %{_pkgconfigdir}/*.pc
201
202 %files static
203 %defattr(644,root,root,755)
204 %{_libdir}/lib*.a
205
206 %if %{with tcl}
207 %files -n tcl-%{name}
208 %defattr(644,root,root,755)
209 %dir %{_ulibdir}/tcl*/sqlite3
210 %attr(755,root,root) %{_ulibdir}/tcl*/sqlite3/*.so
211 %{_ulibdir}/tcl*/sqlite3/*.tcl
212 %endif
This page took 0.047619 seconds and 4 git commands to generate.