]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- up to 3.2.7
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - fix lib64 in tcl module
3 #
4 # Conditional build:
5 %bcond_without  tests # don't run tests
6 #
7 Summary:        SQLite library
8 Summary(pl):    Biblioteka SQLite
9 Name:           sqlite3
10 Version:        3.2.7
11 Release:        1
12 License:        LGPL
13 Group:          Libraries
14 # Source0Download: http://sqlite.org/download.html
15 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
16 # Source0-md5:  34c92821b3b46380f192c0aaf2b2b217
17 Patch0:         %{name}-test-conflict.patch
18 URL:            http://sqlite.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRequires:  readline-devel
23 BuildRequires:  tcl-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %ifarch alpha %{x8664}
27 %undefine       with_tests
28 %endif
29
30 %define         _ulibdir        /usr/lib
31
32 %description
33 SQLite is a C library that implements an SQL database engine. A large
34 subset of SQL92 is supported. A complete database is stored in a
35 single disk file. The API is designed for convenience and ease of use.
36 Applications that link against SQLite can enjoy the power and
37 flexiblity of an SQL database without the administrative hassles of
38 supporting a separate database server. Because it omits the
39 client-server interaction overhead and writes directly to disk, SQLite
40 is also faster than the big database servers for most operations. In
41 addition to the C library, the SQLite distribution includes a
42 command-line tool for interacting with SQLite databases and SQLite
43 bindings for Tcl/Tk.
44
45 %description -l pl
46 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
47 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
48 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
49 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
50 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
51 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
52 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
53 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
54 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
55 bazami danych.
56
57 %package devel
58 Summary:        Header files for SQLite development
59 Summary(pl):    Pliki nag³ówkowe SQLite
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description devel
64 SQLite is a C library that implements an SQL database engine. A large
65 subset of SQL92 is supported. A complete database is stored in a
66 single disk file. The API is designed for convenience and ease of use.
67 Applications that link against SQLite can enjoy the power and
68 flexiblity of an SQL database without the administrative hassles of
69 supporting a separate database server. Because it omits the
70 client-server interaction overhead and writes directly to disk, SQLite
71 is also faster than the big database servers for most operations. In
72 addition to the C library, the SQLite distribution includes a
73 command-line tool for interacting with SQLite databases and SQLite
74 bindings for Tcl/Tk.
75
76 This package contains the header files needed to develop programs that
77 use these SQLite.
78
79 %description devel -l pl
80 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
81 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
82 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
83 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
84 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
85 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
86 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
87 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
88 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
89 bazami danych.
90
91 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
92 u¿ywaj±cych biblioteki SQLite.
93
94 %package static
95 Summary:        Static libraries for SQLite development
96 Summary(pl):    Statyczne biblioteki SQLite
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 SQLite is a C library that implements an SQL database engine. A large
102 subset of SQL92 is supported. A complete database is stored in a
103 single disk file. The API is designed for convenience and ease of use.
104 Applications that link against SQLite can enjoy the power and
105 flexiblity of an SQL database without the administrative hassles of
106 supporting a separate database server. Because it omits the
107 client-server interaction overhead and writes directly to disk, SQLite
108 is also faster than the big database servers for most operations. In
109 addition to the C library, the SQLite distribution includes a
110 command-line tool for interacting with SQLite databases and SQLite
111 bindings for Tcl/Tk.
112
113 This package contains the static SQLite libraries.
114
115 %description static -l pl
116 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
117 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
118 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
119 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
120 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
121 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
122 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
123 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
124 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
125 bazami danych.
126
127 Pakiet zawiera statyczne biblioteki SQLite.
128
129 %package -n tcl-%{name}
130 Summary:        sqlite3 tcl extension
131 Summary(pl):    Rozszerzenie sqlite3 dla Tcl
132 Group:          Development/Languages/Tcl
133
134 %description -n tcl-%{name}
135 sqlite3 tcl extension.
136
137 %description -l pl -n tcl-%{name}
138 Rozszerzenie sqlite3 dla Tcl.
139
140 %prep
141 %setup -q -n sqlite-%{version}
142 %patch0 -p1
143 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
144
145 %build
146 %{__libtoolize}
147 cp -f /usr/share/automake/config.sub .
148 %{__aclocal}
149 %{__autoconf}
150 %configure \
151         --with-tcl=%{_ulibdir} \
152         --enable-threadsafe
153 %{__make}
154 %{__make} doc
155
156 %{?with_tests:LC_ALL=C %{__make} test}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 %doc README
176 %attr(755,root,root) %{_bindir}/sqlite3
177 %attr(755,root,root) %{_libdir}/lib*.so.*.*
178 %{_mandir}/man1/sqlite3.1*
179
180 %files devel
181 %defattr(644,root,root,755)
182 %doc doc/*
183 %attr(755,root,root) %{_libdir}/lib*.so
184 %{_libdir}/lib*.la
185 %{_includedir}/sqlite3.h
186 %{_pkgconfigdir}/*.pc
187
188 %files static
189 %defattr(644,root,root,755)
190 %{_libdir}/lib*.a
191
192 %files -n tcl-%{name}
193 %defattr(644,root,root,755)
194 %dir %{_ulibdir}/tcl*/sqlite3
195 %attr(755,root,root) %{_ulibdir}/tcl*/sqlite3/*.so
196 %{_ulibdir}/tcl*/sqlite3/*.tcl
This page took 0.072008 seconds and 4 git commands to generate.