]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- update to 3.3.4
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - fix lib64 in tcl module
3 # - date test fail on tcl8.5 because of missing tcl library initialization
4 #   (and thus unavailable clock command)
5 #
6 # Conditional build:
7 %bcond_without  tests # don't run tests
8 %bcond_without  tcl   # disable tcl extension
9 %bcond_without  docs  # disable documentation building
10 #
11 Summary:        SQLite library
12 Summary(pl):    Biblioteka SQLite
13 Name:           sqlite3
14 Version:        3.3.4
15 Release:        1
16 License:        LGPL
17 Group:          Libraries
18 # Source0Download: http://sqlite.org/download.html
19 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
20 # Source0-md5:  e31b390c294c0ea093f0bed3353fdff2
21 Patch0:         %{name}-sign-function.patch
22 URL:            http://sqlite.org/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  libtool
26 BuildRequires:  readline-devel
27 %{?with_tcl:BuildRequires:      tcl-devel}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %ifarch alpha %{x8664}
31 %undefine       with_tests
32 %endif
33
34 # disabling tcl currently breaks making test target,
35 # some hack in Makefile needs to be done
36 %if %{without tcl}
37 %undefine       with_tests
38 %endif
39
40 %define         _ulibdir        /usr/lib
41
42 %description
43 SQLite is a C library that implements an SQL database engine. A large
44 subset of SQL92 is supported. A complete database is stored in a
45 single disk file. The API is designed for convenience and ease of use.
46 Applications that link against SQLite can enjoy the power and
47 flexiblity of an SQL database without the administrative hassles of
48 supporting a separate database server. Because it omits the
49 client-server interaction overhead and writes directly to disk, SQLite
50 is also faster than the big database servers for most operations. In
51 addition to the C library, the SQLite distribution includes a
52 command-line tool for interacting with SQLite databases and SQLite
53 bindings for Tcl/Tk.
54
55 %description -l pl
56 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
57 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
58 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
59 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
60 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
61 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
62 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
63 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
64 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
65 bazami danych.
66
67 %package devel
68 Summary:        Header files for SQLite development
69 Summary(pl):    Pliki nag³ówkowe SQLite
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description devel
74 SQLite is a C library that implements an SQL database engine. A large
75 subset of SQL92 is supported. A complete database is stored in a
76 single disk file. The API is designed for convenience and ease of use.
77 Applications that link against SQLite can enjoy the power and
78 flexiblity of an SQL database without the administrative hassles of
79 supporting a separate database server. Because it omits the
80 client-server interaction overhead and writes directly to disk, SQLite
81 is also faster than the big database servers for most operations. In
82 addition to the C library, the SQLite distribution includes a
83 command-line tool for interacting with SQLite databases and SQLite
84 bindings for Tcl/Tk.
85
86 This package contains the header files needed to develop programs that
87 use these SQLite.
88
89 %description devel -l pl
90 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
91 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
92 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
93 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
94 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
95 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
96 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
97 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
98 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
99 bazami danych.
100
101 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
102 u¿ywaj±cych biblioteki SQLite.
103
104 %package static
105 Summary:        Static libraries for SQLite development
106 Summary(pl):    Statyczne biblioteki SQLite
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 SQLite is a C library that implements an SQL database engine. A large
112 subset of SQL92 is supported. A complete database is stored in a
113 single disk file. The API is designed for convenience and ease of use.
114 Applications that link against SQLite can enjoy the power and
115 flexiblity of an SQL database without the administrative hassles of
116 supporting a separate database server. Because it omits the
117 client-server interaction overhead and writes directly to disk, SQLite
118 is also faster than the big database servers for most operations. In
119 addition to the C library, the SQLite distribution includes a
120 command-line tool for interacting with SQLite databases and SQLite
121 bindings for Tcl/Tk.
122
123 This package contains the static SQLite libraries.
124
125 %description static -l pl
126 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
127 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
128 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
129 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
130 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
131 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
132 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
133 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
134 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
135 bazami danych.
136
137 Pakiet zawiera statyczne biblioteki SQLite.
138
139 %package -n tcl-%{name}
140 Summary:        sqlite3 tcl extension
141 Summary(pl):    Rozszerzenie sqlite3 dla Tcl
142 Group:          Development/Languages/Tcl
143
144 %description -n tcl-%{name}
145 sqlite3 tcl extension.
146
147 %description -l pl -n tcl-%{name}
148 Rozszerzenie sqlite3 dla Tcl.
149
150 %prep
151 %setup -q -n sqlite-%{version}
152 %patch0 -p1
153 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
154
155 %build
156 %{__libtoolize}
157 cp -f /usr/share/automake/config.sub .
158 %{__aclocal}
159 %{__autoconf}
160 %configure \
161         %{?with_tcl:--with-tcl=%{_ulibdir}} \
162         %{!?with_tcl:--disable-tcl} \
163         --enable-threadsafe
164 %{__make}
165
166 %if %{with docs}
167 %{__make} doc
168 %endif
169
170 %{?with_tests:LC_ALL=C %{__make} test}
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
175
176 %{__make} install \
177         DESTDIR=$RPM_BUILD_ROOT
178
179 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %post   -p /sbin/ldconfig
185 %postun -p /sbin/ldconfig
186
187 %files
188 %defattr(644,root,root,755)
189 %doc README
190 %attr(755,root,root) %{_bindir}/sqlite3
191 %attr(755,root,root) %{_libdir}/lib*.so.*.*
192 %{_mandir}/man1/sqlite3.1*
193
194 %files devel
195 %defattr(644,root,root,755)
196 %doc doc/*
197 %attr(755,root,root) %{_libdir}/lib*.so
198 %{_libdir}/lib*.la
199 %{_includedir}/sqlite3.h
200 %{_pkgconfigdir}/*.pc
201
202 %files static
203 %defattr(644,root,root,755)
204 %{_libdir}/lib*.a
205
206 %if %{with tcl}
207 %files -n tcl-%{name}
208 %defattr(644,root,root,755)
209 %dir %{_ulibdir}/tcl*/sqlite3
210 %attr(755,root,root) %{_ulibdir}/tcl*/sqlite3/*.so
211 %{_ulibdir}/tcl*/sqlite3/*.tcl
212 %endif
This page took 0.077225 seconds and 3 git commands to generate.