]> git.pld-linux.org Git - packages/spirv-tools.git/blob - spirv-tools.spec
fixed snapshot date
[packages/spirv-tools.git] / spirv-tools.spec
1
2 %define snap    20160312
3 %define commit  476989e7b715529aa8063016dc44e31bbf3e08bc
4 %define _ver    %(echo %{version} | tr _ -)
5 Summary:        SPIR-V Tools
6 Name:           spirv-tools
7 Version:        1.0_rev3.s%{snap}
8 Release:        1
9 License:        MIT-like
10 Group:          Applications
11 Source0:        https://github.com/KhronosGroup/SPIRV-Tools/archive/%{commit}/%{name}-s%{snap}.tar.gz
12 # Source0-md5:  c86bbabd5b1efea51c49a46099499f7d
13 Patch0:         cmake-lib64.patch
14 Patch1:         no-git-describe.patch
15 URL:            https://github.com/KhronosGroup/SPIRV-Tools
16 BuildRequires:  cmake
17 Requires:       %{name}-libs = %{version}-%{release}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 The SPIR-V Tools project provides an API and commands for processing
22 SPIR-V modules.
23
24 The project includes an assembler, binary module parser, disassembler,
25 and validator for SPIR-V, all based on a common static library. The
26 library contains all of the implementation details, and is used in the
27 standalone tools whilst also enabling integration into other code
28 bases directly.
29
30 The interfaces are still under development, and are expected to
31 change.
32
33 SPIR-V is defined by the Khronos Group Inc.
34
35 %package libs
36 Summary:        SPIR-V Tools library
37 Group:          Libraries
38
39 %description libs
40 The SPIR-V Tools project provides an API for processing SPIR-V
41 modules.
42
43 %package devel
44 Summary:        Header files for %{name} library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
46 Group:          Development/Libraries
47 Requires:       %{name}-libs = %{version}-%{release}
48
49 %description devel
50 Header files for %{name} library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki %{name}.
54
55 %prep
56 %setup -q -n SPIRV-Tools-%{commit}
57 %patch0 -p1
58 %patch1 -p1
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         ../
65
66 # we know better than utils/update_build_version.py
67 echo '"spirv-tools %{commit}\\n"' > build-version.inc
68
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 cd build
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   libs -p /sbin/ldconfig
82 %postun libs -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc LICENSE README.md syntax.md
87 %attr(755,root,root) %{_bindir}/spirv-*
88
89 %files libs
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libSPIRV-Tools.so
92
93 %files devel
94 %defattr(644,root,root,755)
95 %{_includedir}/spirv
96 %{_includedir}/spirv-tools
This page took 0.052894 seconds and 3 git commands to generate.