]> git.pld-linux.org Git - packages/spirv-tools.git/blob - spirv-tools.spec
- verbose tools list (as glslang also provides some %{_bindir}/spirv-*), requires...
[packages/spirv-tools.git] / spirv-tools.spec
1 Summary:        Khronos SPIR-V Tools
2 Summary(pl.UTF-8):      Narzędzia SPIR-V z projektu Khronos
3 Name:           spirv-tools
4 Version:        2019.4
5 Release:        1
6 Epoch:          1
7 License:        Apache v2.0
8 Group:          Development/Tools
9 #Source0Download: https://github.com/KhronosGroup/SPIRV-Tools/releases
10 # TODO:         https://github.com/KhronosGroup/SPIRV-Tools/archive/v%{version}/SPIRV-Tools-%{version}.tar.gz
11 Source0:        https://github.com/KhronosGroup/SPIRV-Tools/archive/v%{version}.tar.gz
12 # Source0-md5:  c666f17aa0338af05918270885f81a6c
13 Patch0:         no-git-describe.patch
14 URL:            https://github.com/KhronosGroup/SPIRV-Tools
15 BuildRequires:  cmake >= 2.8.12
16 BuildRequires:  libstdc++-devel >= 6:4.7
17 BuildRequires:  python3 >= 1:3
18 BuildRequires:  spirv-headers >= 1.5.1
19 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The SPIR-V Tools project provides an API and commands for processing
24 SPIR-V modules.
25
26 The project includes an assembler, binary module parser, disassembler,
27 and validator for SPIR-V, all based on a common library. The library
28 contains all of the implementation details, and is used in the
29 standalone tools whilst also enabling integration into other code
30 bases directly.
31
32 The interfaces are still under development, and are expected to
33 change.
34
35 SPIR-V is defined by the Khronos Group Inc.
36
37 %description -l pl.UTF-8
38 SPIR-V Tools to projekt udostępniający API i polecenia do
39 przetwarzania modułów SPIR-V.
40
41 Projekt zawiera asembler, parser modułów binarnych, disasembler oraz
42 walidator dla SPIR-V - wszystko oparte o wspólną bibliotekę.
43 Biblioteka zawiera wszystkie szczegóły implementacji i jest używana w
44 samodzielnych narzędziach; może być także zintegrowana do innego kodu.
45
46 Interfejsy są nadal rozwijane i mogą się zmienić.
47
48 SPIR-V jest zdefiniowane przez Khronos Group Inc.
49
50 %package libs
51 Summary:        SPIR-V Tools library
52 Summary(pl.UTF-8):      Biblioteka SPIR-V Tools
53 Group:          Libraries
54
55 %description libs
56 The SPIR-V Tools project provides an API for processing SPIR-V
57 modules.
58
59 %description libs -l pl.UTF-8
60 Projekt SPIR-V Tools udostepnia API do przetwarzania modułów SPIR-V.
61
62 %package devel
63 Summary:        Header files for SPIR-V Tools library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SPIR-V Tools
65 Group:          Development/Libraries
66 Requires:       spirv-headers
67 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
68
69 %description devel
70 Header files for SPIR-V Tools library.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe biblioteki SPIR-V Tools.
74
75 %prep
76 %setup -q -n SPIRV-Tools-%{version}
77 %patch0 -p1
78
79 %build
80 install -d build external/spirv-headers/include
81 ln -s /usr/include/spirv external/spirv-headers/include/spirv
82
83 cd build
84 %cmake ..
85
86 # we know better than utils/update_build_version.py
87 echo '"spirv-tools %{version}\\n"' > build-version.inc
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} -C build install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   libs -p /sbin/ldconfig
101 %postun libs -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc CHANGES README.md syntax.md
106 %attr(755,root,root) %{_bindir}/spirv-as
107 %attr(755,root,root) %{_bindir}/spirv-cfg
108 %attr(755,root,root) %{_bindir}/spirv-dis
109 %attr(755,root,root) %{_bindir}/spirv-lesspipe.sh
110 %attr(755,root,root) %{_bindir}/spirv-link
111 %attr(755,root,root) %{_bindir}/spirv-opt
112 %attr(755,root,root) %{_bindir}/spirv-reduce
113 %attr(755,root,root) %{_bindir}/spirv-val
114
115 %files libs
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libSPIRV-Tools.so
118 %attr(755,root,root) %{_libdir}/libSPIRV-Tools-link.so
119 %attr(755,root,root) %{_libdir}/libSPIRV-Tools-opt.so
120 %attr(755,root,root) %{_libdir}/libSPIRV-Tools-reduce.so
121 %attr(755,root,root) %{_libdir}/libSPIRV-Tools-shared.so
122
123 %files devel
124 %defattr(644,root,root,755)
125 %{_includedir}/spirv-tools
126 %{_pkgconfigdir}/SPIRV-Tools.pc
127 %{_pkgconfigdir}/SPIRV-Tools-shared.pc
This page took 0.095307 seconds and 3 git commands to generate.