]> git.pld-linux.org Git - packages/spice-vdagent.git/blob - spice-vdagent.spec
3ac3d265198d02ffc3e5f5caa39c5bc8d33c5e84
[packages/spice-vdagent.git] / spice-vdagent.spec
1 # TODO:
2 # - package gdm files
3 #
4 # Conditional build:
5 %bcond_with     systemd # use systemd instead of ConsoleKit for session tracking
6 #
7 Summary:        Linux guest agent for SPICE
8 Summary(pl.UTF-8):      Agent gościa linuksowego dla SPICE
9 Name:           spice-vdagent
10 Version:        0.19.0
11 Release:        0.1
12 License:        GPL v3+
13 Group:          X11/Applications
14 Source0:        https://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
15 # Source0-md5:  5f409625f075e35238336ff11af62306
16 Patch0:         %{name}-tmpfile.patch
17 URL:            https://www.spice-space.org/
18 BuildRequires:  alsa-lib-devel >= 1.0.22
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake
21 %{!?with_systemd:BuildRequires: dbus-devel}
22 BuildRequires:  glib2-devel >= 1:2.34
23 BuildRequires:  gtk+3-devel >= 3.10
24 BuildRequires:  libdrm-devel
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpmbuild(macros) >= 1.228
27 BuildRequires:  spice-protocol >= 0.14.0
28 %{?with_systemd:BuildRequires:  systemd-devel >= 209}
29 BuildRequires:  xorg-lib-libX11-devel
30 BuildRequires:  xorg-lib-libXfixes-devel
31 BuildRequires:  xorg-lib-libXinerama-devel
32 BuildRequires:  xorg-lib-libXrandr-devel >= 1.3
33 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
34 Requires:       alsa-lib >= 1.0.22
35 Requires:       glib2 >= 1:2.34
36 Requires:       gtk+3 >= 3.10
37 Requires:       xorg-lib-libXrandr >= 1.3
38 Requires:       xorg-lib-libpciaccess >= 0.10
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 The SPICE agent for Linux consists of 2 parts, a daemon spice-vdagentd
43 and a per X-session process spice-vdagent. The daemon gets
44 automatically started in Spice guests through a udev rule. The per
45 X-session gets automatically started in desktop environments which
46 honor /etc/xdg/autostart, and under gdm.
47
48 %description -l pl.UTF-8
49 Agent SPICE dla Linuksa składa się z 2 części: demona spice-vdagentd
50 oraz procesu dla sesji X spice-vdagent. Demon uruchamia się
51 automatycznie na gościach Spice poprzez regułę udeva. Proces dla sesji
52 X jest uruchamiany automatycznie w środowiskach graficznych
53 honorujących /etc/xdg/autostart oraz pod GDM-em.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 %configure \
61         --disable-silent-rules \
62         --with-init-script=systemd+redhat \
63         --with-session-info=%{?with_systemd:systemd}%{!?with_systemd:console-kit}
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 /sbin/chkconfig --add %{name}
77 %service %{name} restart
78
79 %preun
80 if [ "$1" = "0" ]; then
81         %service -q %{name} stop
82         /sbin/chkconfig --del %{name}
83 fi
84
85 %files
86 %defattr(644,root,root,755)
87 %doc CHANGELOG.md README.md
88 %attr(755,root,root) %{_bindir}/spice-vdagent
89 %attr(755,root,root) %{_sbindir}/spice-vdagentd
90 # TODO: PLDify
91 %attr(754,root,root) /etc/rc.d/init.d/spice-vdagentd
92 /etc/xdg/autostart/spice-vdagent.desktop
93 %{systemdunitdir}/spice-vdagentd.service
94 %{systemdunitdir}/spice-vdagentd.socket
95 /lib/udev/rules.d/70-spice-vdagentd.rules
96 %{systemdtmpfilesdir}/spice-vdagentd.conf
97 %{_mandir}/man1/spice-vdagent.1*
98 %{_mandir}/man1/spice-vdagentd.1*
This page took 0.066972 seconds and 2 git commands to generate.