]> git.pld-linux.org Git - packages/spice-space.git/blob - spice-space.spec
- updated to 0.12.0
[packages/spice-space.git] / spice-space.spec
1 #
2 # Conditional build:
3 %bcond_with     slirp           # build with tunneling support (breaks qemu)
4 #
5 Summary:        SPICE virtualization solution
6 Summary(pl.UTF-8):      System wirtualizacji SPICE
7 # real package name (spice) is already occupied
8 Name:           spice-space
9 Version:        0.12.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Applications/Emulators
13 Source0:        http://spice-space.org/download/releases/spice-%{version}.tar.bz2
14 # Source0-md5:  12c6ea4938215f8f9f10d2925f7bec9b
15 Patch0:         spice-sh.patch
16 Patch1:         spice-link.patch
17 URL:            http://spice-space.org/
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  alsa-lib-devel
20 BuildRequires:  celt051-devel >= 0.5.1.1
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  automake
23 BuildRequires:  cyrus-sasl-devel >= 2
24 BuildRequires:  libcacard-devel >= 0.1.2
25 BuildRequires:  libjpeg-devel
26 %{?with_slirp:BuildRequires:    libslirp-devel}
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool
29 BuildRequires:  openssl-devel
30 BuildRequires:  pixman-devel >= 0.17.7
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.527
33 BuildRequires:  spice-protocol >= 0.10.1
34 BuildRequires:  xorg-lib-libXext-devel
35 BuildRequires:  xorg-lib-libXfixes-devel
36 BuildRequires:  xorg-lib-libXinerama-devel >= 1.0
37 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
38 BuildRequires:  xorg-lib-libXrender-devel
39 BuildRequires:  zlib-devel
40 ExclusiveArch:  %{ix86} %{x8664} arm
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Spice is an open remote computing solution, providing client access to
45 remote machine display and devices (e.g., keyboard, mouse, audio).
46 Spice achieves a user experience similar to an interaction with a
47 local machine, while trying to offload most of the intensive CPU and
48 GPU tasks to the client. Spice is suitable for both LAN and WAN usage,
49 without compromising on the user experience.
50
51 %description -l pl.UTF-8
52 Spice to rozwiązanie do zdalnych obliczeń, zapewniające dostęp
53 kliencki ekranu i urządzeń zdalnej maszyny (klawiatury, myszy,
54 dźwięku). Daje użytkownikowi wrażenie podobne do pracy lokalnej, ale
55 próbuje większość zadań wykorzystujących intensywnie CPU i GPU zrzucić
56 na klienta. Nadaje się do pracy w sieciach LAN i WAN, bez większych
57 poświęceń ze strony doznań użytkownika.
58
59 %package -n spice-server-libs
60 Summary:        SPICE server library
61 Summary(pl.UTF-8):      Biblioteka serwera SPICE
62 Group:          Libraries
63 Requires:       celt051 >= 0.5.1.1
64 Requires:       pixman >= 0.17.7
65
66 %description -n spice-server-libs
67 SPICE server library.
68
69 %description -n spice-server-libs -l pl.UTF-8
70 Biblioteka serwera SPICE.
71
72 %package -n spice-server-devel
73 Summary:        Header files for SPICE server library
74 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki serwera SPICE
75 Group:          Development/Libraries
76 Requires:       celt051-devel >= 0.5.1.1
77 %{?with_slirp:Requires: libslirp-devel}
78 Requires:       openssl-devel
79 Requires:       pixman-devel >= 0.17.7
80 Requires:       spice-server-libs = %{version}-%{release}
81
82 %description -n spice-server-devel
83 Header files for SPICE server library.
84
85 %description -n spice-server-devel -l pl.UTF-8
86 Pliki nagłówkowe biblioteki serwera SPICE.
87
88 %package -n spice-server-static
89 Summary:        Static SPICE server library
90 Summary(pl.UTF-8):      Statyczna biblioteka serwera SPICE
91 Group:          Development/Libraries
92 Requires:       spice-server-devel = %{version}-%{release}
93
94 %description -n spice-server-static
95 Static SPICE server library.
96
97 %description -n spice-server-static -l pl.UTF-8
98 Statyczna biblioteka serwera SPICE.
99
100 %package -n spice-client
101 Summary:        SPICE client for X11
102 Summary(pl.UTF-8):      Klient SPICE dla X11
103 Group:          X11/Applications
104 Requires:       celt051 >= 0.5.1.1
105 Requires:       libcacard >= 0.1.2
106 Requires:       pixman >= 0.17.7
107 Requires:       xorg-lib-libXrandr >= 1.2
108 Requires:       xorg-lib-libXinerama >= 1.0
109
110 %description -n spice-client
111 SPICE client for X11.
112
113 %description -n spice-client -l pl.UTF-8
114 Klient SPICE dla X11.
115
116 %prep
117 %setup -q -n spice-%{version}
118 %patch0 -p1
119 %patch1 -p1
120
121 %build
122 %{__libtoolize}
123 %{__aclocal}
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --disable-silent-rules \
129         --enable-opengl \
130         --enable-smartcard \
131         %{?with_slirp:en}%{!?with_slirp:dis}able-tunnel
132 # --enable-gui          BR: CEGUI-devel >= 0.6.0 < 0.7.0
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 # obsoleted by pkg-config
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libspice-server.la
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -n spice-server-libs -p /sbin/ldconfig
149 %postun -n spice-server-libs -p /sbin/ldconfig
150
151 %files -n spice-server-libs
152 %defattr(644,root,root,755)
153 %doc NEWS README
154 %attr(755,root,root) %{_libdir}/libspice-server.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libspice-server.so.1
156
157 %files -n spice-server-devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libspice-server.so
160 %{_includedir}/spice-server
161 %{_pkgconfigdir}/spice-server.pc
162
163 %files -n spice-server-static
164 %defattr(644,root,root,755)
165 %{_libdir}/libspice-server.a
166
167 %files -n spice-client
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/spicec
This page took 0.076259 seconds and 3 git commands to generate.