]> git.pld-linux.org Git - packages/spice-space.git/blob - spice-space.spec
- updated to 0.15.2
[packages/spice-space.git] / spice-space.spec
1 #
2 # Conditional build:
3 %bcond_without  opengl          # OpenGL support
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        SPICE virtualization solution
7 Summary(pl.UTF-8):      System wirtualizacji SPICE
8 # real package name (spice) is already occupied
9 Name:           spice-space
10 # NOTE: 0.odd.x versions are unstable
11 Version:        0.15.2
12 Release:        1
13 License:        LGPL v2.1+
14 Group:          Applications/Emulators
15 Source0:        https://www.spice-space.org/download/releases/spice-server/spice-%{version}.tar.bz2
16 # Source0-md5:  1de1e9157a1e2396884017978e7cf086
17 URL:            https://www.spice-space.org/
18 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
19 %{?with_opengl:BuildRequires:   OpenGL-devel}
20 BuildRequires:  alsa-lib-devel
21 BuildRequires:  asciidoc
22 BuildRequires:  autoconf >= 2.63
23 BuildRequires:  autoconf-archive
24 BuildRequires:  automake >= 1:1.11
25 BuildRequires:  cyrus-sasl-devel >= 2
26 BuildRequires:  gcc >= 5:4.0
27 BuildRequires:  gdk-pixbuf2-devel >= 2.26
28 BuildRequires:  glib2-devel >= 1:2.38
29 BuildRequires:  gstreamer-devel >= 1.0
30 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
31 BuildRequires:  libcacard-devel >= 2.5.1
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libstdc++-devel >= 6:4.8.1
34 BuildRequires:  libtool >= 2:2
35 BuildRequires:  lz4-devel >= 129
36 BuildRequires:  openssl-devel >= 1.0.0
37 BuildRequires:  opus-devel >= 1.0.0
38 BuildRequires:  orc-devel >= 0.4
39 BuildRequires:  pixman-devel >= 0.17.7
40 BuildRequires:  pkgconfig
41 BuildRequires:  python >= 2
42 BuildRequires:  python-pyparsing
43 BuildRequires:  python-six
44 BuildRequires:  rpmbuild(macros) >= 1.527
45 BuildRequires:  spice-protocol >= 0.14.3
46 BuildRequires:  xorg-lib-libX11-devel
47 BuildRequires:  xorg-lib-libXext-devel
48 BuildRequires:  xorg-lib-libXfixes-devel
49 BuildRequires:  xorg-lib-libXinerama-devel >= 1.0
50 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
51 BuildRequires:  xorg-lib-libXrender-devel
52 BuildRequires:  zlib-devel
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 Spice is an open remote computing solution, providing client access to
57 remote machine display and devices (e.g., keyboard, mouse, audio).
58 Spice achieves a user experience similar to an interaction with a
59 local machine, while trying to offload most of the intensive CPU and
60 GPU tasks to the client. Spice is suitable for both LAN and WAN usage,
61 without compromising on the user experience.
62
63 %description -l pl.UTF-8
64 Spice to rozwiązanie do zdalnych obliczeń, zapewniające dostęp
65 kliencki ekranu i urządzeń zdalnej maszyny (klawiatury, myszy,
66 dźwięku). Daje użytkownikowi wrażenie podobne do pracy lokalnej, ale
67 próbuje większość zadań wykorzystujących intensywnie CPU i GPU zrzucić
68 na klienta. Nadaje się do pracy w sieciach LAN i WAN, bez większych
69 poświęceń ze strony doznań użytkownika.
70
71 %package -n spice-server-libs
72 Summary:        SPICE server library
73 Summary(pl.UTF-8):      Biblioteka serwera SPICE
74 Group:          Libraries
75 Requires:       glib2 >= 1:2.38
76 Requires:       openssl >= 1.0.0
77 Requires:       opus >= 1.0.0
78 Requires:       pixman >= 0.17.7
79 Obsoletes:      spice-client < 0.12.6
80
81 %description -n spice-server-libs
82 SPICE server library.
83
84 %description -n spice-server-libs -l pl.UTF-8
85 Biblioteka serwera SPICE.
86
87 %package -n spice-server-devel
88 Summary:        Header files for SPICE server library
89 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki serwera SPICE
90 Group:          Development/Libraries
91 Requires:       glib2-devel >= 1:2.38
92 Requires:       libcacard-devel >= 2.5.1
93 Requires:       openssl-devel >= 1.0.0
94 Requires:       pixman-devel >= 0.17.7
95 Requires:       spice-protocol >= 0.14.0
96 Requires:       spice-server-libs = %{version}-%{release}
97
98 %description -n spice-server-devel
99 Header files for SPICE server library.
100
101 %description -n spice-server-devel -l pl.UTF-8
102 Pliki nagłówkowe biblioteki serwera SPICE.
103
104 %package -n spice-server-static
105 Summary:        Static SPICE server library
106 Summary(pl.UTF-8):      Statyczna biblioteka serwera SPICE
107 Group:          Development/Libraries
108 Requires:       spice-server-devel = %{version}-%{release}
109
110 %description -n spice-server-static
111 Static SPICE server library.
112
113 %description -n spice-server-static -l pl.UTF-8
114 Statyczna biblioteka serwera SPICE.
115
116 %prep
117 %setup -q -n spice-%{version}
118
119 %build
120 %{__libtoolize}
121 %{__aclocal} -I m4
122 %{__autoconf}
123 %{__autoheader}
124 %{__automake}
125 cd subprojects/spice-common
126 %{__libtoolize}
127 %{__aclocal} -I m4
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 cd ../..
132 %configure \
133         --disable-silent-rules \
134         --enable-lz4 \
135         %{?with_opengl:--enable-opengl} \
136         --enable-smartcard \
137         %{?with_static_libs:--enable-static}
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 # obsoleted by pkg-config
148 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libspice-server.la
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -n spice-server-libs -p /sbin/ldconfig
154 %postun -n spice-server-libs -p /sbin/ldconfig
155
156 %files -n spice-server-libs
157 %defattr(644,root,root,755)
158 %doc AUTHORS CHANGELOG.md README
159 %attr(755,root,root) %{_libdir}/libspice-server.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libspice-server.so.1
161
162 %files -n spice-server-devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libspice-server.so
165 %{_includedir}/spice-server
166 %{_pkgconfigdir}/spice-server.pc
167
168 %if %{with static_libs}
169 %files -n spice-server-static
170 %defattr(644,root,root,755)
171 %{_libdir}/libspice-server.a
172 %endif
This page took 0.123 seconds and 3 git commands to generate.