]> git.pld-linux.org Git - packages/sphinx-pdg.git/blob - sphinx-pdg.spec
f4be9a983eba08b9280f9e8666e4c6353802a235
[packages/sphinx-pdg.git] / sphinx-pdg.spec
1 # there are sphinx.spec, sphinx2.spec...  Sphinx.spec is too confusing
2 # therefore the name for this package is sphinx-pdg (pdg - python
3 # documentation generator)
4 Summary:        Sphinx - Python documentation generator
5 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona
6 Name:           sphinx-pdg
7 Version:        1.1.3
8 Release:        1
9 License:        BSD
10 Group:          Development/Languages/Python
11 Source0:        http://pypi.python.org/packages/source/S/Sphinx/Sphinx-%{version}.tar.gz
12 # Source0-md5:  8f55a6d4f87fc6d528120c5d1f983e98
13 URL:            http://sphinx.pocoo.org/
14 BuildRequires:  python-devel >= 1:2.5
15 BuildRequires:  python-distribute
16 BuildRequires:  python-modules >= 1:2.5
17 BuildRequires:  python3-2to3
18 BuildRequires:  python3-devel
19 BuildRequires:  python3-distribute
20 BuildRequires:  python3-modules
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 Requires:       python-Sphinx = %{version}-%{release}
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Sphinx is a tool that makes it easy to create intelligent and
29 beautiful documentation for Python projects (or other documents
30 consisting of multiple reStructuredText sources), written by Georg
31 Brandl. It was originally created to translate the new Python
32 documentation, but has now been cleaned up in the hope that it will be
33 useful to many other projects.
34
35 %description -l pl.UTF-8
36 Sphinx to narzędzie ułatwiające tworzenie inteligentnej i ładnej
37 dokumentacji dla projektów w Pythonie (lub innych dokumentów
38 składających się z wielu źródeł w formacie reStructuredText), napisane
39 przez Georga Brandla. Pierwotnie powstało do tłumaczenia nowej
40 dokumentacji Pythona, ale potem zostało wyczyszczone w nadziei, że
41 będzie przydatne dla wielu innych projektów.
42
43 %package 3
44 Summary:        Sphinx Python documentation generator (Python 3 version)
45 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (wersja dla Pythona 3)
46 Group:          Development/Languages/Python
47 Requires:       python3-Sphinx = %{version}-%{release}
48
49 %description 3
50 Sphinx is a tool that makes it easy to create intelligent and
51 beautiful documentation for Python projects (or other documents
52 consisting of multiple reStructuredText sources), written by Georg
53 Brandl. It was originally created to translate the new Python
54 documentation, but has now been cleaned up in the hope that it will be
55 useful to many other projects.
56
57 %description 3 -l pl.UTF-8
58 Sphinx to narzędzie ułatwiające tworzenie inteligentnej i ładnej
59 dokumentacji dla projektów w Pythonie (lub innych dokumentów
60 składających się z wielu źródeł w formacie reStructuredText), napisane
61 przez Georga Brandla. Pierwotnie powstało do tłumaczenia nowej
62 dokumentacji Pythona, ale potem zostało wyczyszczone w nadziei, że
63 będzie przydatne dla wielu innych projektów.
64
65 %package -n python-Sphinx
66 Summary:        Sphinx Python documentation generator (Python 2.x modules)
67 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły Pythona 2.x)
68 Group:          Development/Languages/Python
69 Requires:       python-distribute
70 Requires:       python-docutils >= 0.7
71 Requires:       python-jinja2 >= 2.3
72 Requires:       python-pygments >= 1.2
73 %pyrequires_eq  python-modules
74 Conflicts:      sphinx-pdg < 1.0.7-2
75
76 %description -n python-Sphinx
77 Sphinx Python documentation generator (Python 2.x modules).
78
79 For command-line utilities, see sphinx-pdg package.
80
81 %description -n python-Sphinx -l pl.UTF-8
82 Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły
83 Pythona 2.x).
84
85 Narzędzia działające z linii poleceń znajdują się w pakiecie
86 sphinx-pdg.
87
88 %package -n python3-Sphinx
89 Summary:        Sphinx Python documentation generator (Python 3.x modules)
90 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły Pythona 3.x)
91 Group:          Development/Languages/Python
92 Requires:       python3-distribute
93 Requires:       python3-docutils >= 0.8
94 Requires:       python3-jinja2 >= 2.3
95 Requires:       python3-pygments >= 1.2
96 Conflicts:      sphinx-pdg-3 < 1.0.7-2
97
98 %description -n python3-Sphinx
99 Sphinx Python documentation generator (Python 3.x modules).
100
101 For command-line utilities, see sphinx-pdg-3 package.
102
103 %description -n python3-Sphinx -l pl.UTF-8
104 Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły
105 Pythona 3.x).
106
107 Narzędzia działające z linii poleceń znajdują się w pakiecie
108 sphinx-pdg-3.
109
110 %prep
111 %setup -q -n Sphinx-%{version}
112
113 %build
114 %{__python} setup.py build -b build-2
115 rm sphinx/__init__.pyc
116 %{__python3} setup.py build -b build-3
117 rm -r sphinx/__pycache__
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__python3} setup.py build -b build-3 install \
123         --optimize=2 \
124         --root=$RPM_BUILD_ROOT
125 rm -r sphinx/__pycache__
126
127 for f in $RPM_BUILD_ROOT%{_bindir}/*; do
128         mv "${f}" "${f}-3"
129 done
130
131 %{__python} setup.py build -b build-2 install \
132         --optimize=2 \
133         --root=$RPM_BUILD_ROOT
134 rm sphinx/__init__.pyc
135
136 %py_postclean
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS CHANGES EXAMPLES LICENSE PKG-INFO README TODO
144 %attr(755,root,root) %{_bindir}/sphinx-autogen
145 %attr(755,root,root) %{_bindir}/sphinx-apidoc
146 %attr(755,root,root) %{_bindir}/sphinx-build
147 %attr(755,root,root) %{_bindir}/sphinx-quickstart
148
149 %files 3
150 %defattr(644,root,root,755)
151 %doc AUTHORS CHANGES EXAMPLES LICENSE PKG-INFO README TODO
152 %attr(755,root,root) %{_bindir}/sphinx-autogen-3
153 %attr(755,root,root) %{_bindir}/sphinx-apidoc-3
154 %attr(755,root,root) %{_bindir}/sphinx-build-3
155 %attr(755,root,root) %{_bindir}/sphinx-quickstart-3
156
157 %files -n python-Sphinx
158 %defattr(644,root,root,755)
159 %{py_sitescriptdir}/sphinx
160 %{py_sitescriptdir}/Sphinx-%{version}-py*.egg-info
161
162 %files -n python3-Sphinx
163 %defattr(644,root,root,755)
164 %{py3_sitescriptdir}/sphinx
165 %{py3_sitescriptdir}/Sphinx-%{version}-py*.egg-info
This page took 0.053194 seconds and 2 git commands to generate.