]> git.pld-linux.org Git - packages/sphinx-pdg.git/blob - sphinx-pdg.spec
Version: 1.3.1
[packages/sphinx-pdg.git] / sphinx-pdg.spec
1 # there are sphinx.spec, sphinx2.spec...  Sphinx.spec is too confusing
2 # therefore the name for this package is sphinx-pdg (pdg - python
3 # documentation generator)
4 Summary:        Sphinx - Python documentation generator
5 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona
6 Name:           sphinx-pdg
7 Version:        1.3.1
8 Release:        1
9 License:        BSD
10 Group:          Development/Languages/Python
11 Source0:        https://pypi.python.org/packages/source/S/Sphinx/Sphinx-%{version}.tar.gz
12 # Source0-md5:  8786a194acf9673464c5455b11fd4332
13 URL:            http://sphinx.pocoo.org/
14 BuildRequires:  python-devel >= 1:2.5
15 BuildRequires:  python-setuptools > 7.0
16 BuildRequires:  python-modules >= 1:2.5
17 BuildRequires:  python3-2to3
18 BuildRequires:  python3-devel
19 BuildRequires:  python3-setuptools > 7.0
20 BuildRequires:  python3-modules
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 Requires:       python-Sphinx = %{version}-%{release}
24 Requires:       python-devel-tools
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Sphinx is a tool that makes it easy to create intelligent and
30 beautiful documentation for Python projects (or other documents
31 consisting of multiple reStructuredText sources), written by Georg
32 Brandl. It was originally created to translate the new Python
33 documentation, but has now been cleaned up in the hope that it will be
34 useful to many other projects.
35
36 %description -l pl.UTF-8
37 Sphinx to narzędzie ułatwiające tworzenie inteligentnej i ładnej
38 dokumentacji dla projektów w Pythonie (lub innych dokumentów
39 składających się z wielu źródeł w formacie reStructuredText), napisane
40 przez Georga Brandla. Pierwotnie powstało do tłumaczenia nowej
41 dokumentacji Pythona, ale potem zostało wyczyszczone w nadziei, że
42 będzie przydatne dla wielu innych projektów.
43
44 %package 3
45 Summary:        Sphinx Python documentation generator (Python 3 version)
46 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (wersja dla Pythona 3)
47 Group:          Development/Languages/Python
48 Requires:       python3-Sphinx = %{version}-%{release}
49
50 %description 3
51 Sphinx is a tool that makes it easy to create intelligent and
52 beautiful documentation for Python projects (or other documents
53 consisting of multiple reStructuredText sources), written by Georg
54 Brandl. It was originally created to translate the new Python
55 documentation, but has now been cleaned up in the hope that it will be
56 useful to many other projects.
57
58 %description 3 -l pl.UTF-8
59 Sphinx to narzędzie ułatwiające tworzenie inteligentnej i ładnej
60 dokumentacji dla projektów w Pythonie (lub innych dokumentów
61 składających się z wielu źródeł w formacie reStructuredText), napisane
62 przez Georga Brandla. Pierwotnie powstało do tłumaczenia nowej
63 dokumentacji Pythona, ale potem zostało wyczyszczone w nadziei, że
64 będzie przydatne dla wielu innych projektów.
65
66 %package -n python-Sphinx
67 Summary:        Sphinx Python documentation generator (Python 2.x modules)
68 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły Pythona 2.x)
69 Group:          Development/Languages/Python
70 Requires:       python-setuptools > 7.0
71 Requires:       python-docutils >= 0.7
72 Requires:       python-jinja2 >= 2.3
73 Requires:       python-modules
74 Requires:       python-pygments >= 1.2
75 Conflicts:      sphinx-pdg < 1.0.7-2
76
77 %description -n python-Sphinx
78 Sphinx Python documentation generator (Python 2.x modules).
79
80 For command-line utilities, see sphinx-pdg package.
81
82 %description -n python-Sphinx -l pl.UTF-8
83 Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły
84 Pythona 2.x).
85
86 Narzędzia działające z linii poleceń znajdują się w pakiecie
87 sphinx-pdg.
88
89 %package -n python3-Sphinx
90 Summary:        Sphinx Python documentation generator (Python 3.x modules)
91 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły Pythona 3.x)
92 Group:          Development/Languages/Python
93 Requires:       python3-setuptools > 7.0
94 Requires:       python3-docutils >= 0.8
95 Requires:       python3-jinja2 >= 2.3
96 Requires:       python3-pygments >= 1.2
97 Conflicts:      sphinx-pdg-3 < 1.0.7-2
98
99 %description -n python3-Sphinx
100 Sphinx Python documentation generator (Python 3.x modules).
101
102 For command-line utilities, see sphinx-pdg-3 package.
103
104 %description -n python3-Sphinx -l pl.UTF-8
105 Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły
106 Pythona 3.x).
107
108 Narzędzia działające z linii poleceń znajdują się w pakiecie
109 sphinx-pdg-3.
110
111 %prep
112 %setup -q -n Sphinx-%{version}
113
114 %build
115 %{__python} setup.py build -b build-2
116 %{__rm} sphinx/__init__.pyc
117 %{__python3} setup.py build -b build-3
118 %{__rm} -r sphinx/__pycache__
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__python3} setup.py build -b build-3 install \
124         --optimize=2 \
125         --root=$RPM_BUILD_ROOT
126 %{__rm} -r sphinx/__pycache__
127
128 for f in $RPM_BUILD_ROOT%{_bindir}/*; do
129         mv "${f}" "${f}-3"
130 done
131
132 %{__python} setup.py build -b build-2 install \
133         --optimize=2 \
134         --root=$RPM_BUILD_ROOT
135 %{__rm} sphinx/__init__.pyc
136
137 %py_postclean
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS CHANGES EXAMPLES LICENSE PKG-INFO README.rst
145 %attr(755,root,root) %{_bindir}/sphinx-autogen
146 %attr(755,root,root) %{_bindir}/sphinx-apidoc
147 %attr(755,root,root) %{_bindir}/sphinx-build
148 %attr(755,root,root) %{_bindir}/sphinx-quickstart
149
150 %files 3
151 %defattr(644,root,root,755)
152 %doc AUTHORS CHANGES EXAMPLES LICENSE PKG-INFO README.rst
153 %attr(755,root,root) %{_bindir}/sphinx-autogen-3
154 %attr(755,root,root) %{_bindir}/sphinx-apidoc-3
155 %attr(755,root,root) %{_bindir}/sphinx-build-3
156 %attr(755,root,root) %{_bindir}/sphinx-quickstart-3
157
158 %files -n python-Sphinx
159 %defattr(644,root,root,755)
160 %{py_sitescriptdir}/sphinx
161 %{py_sitescriptdir}/Sphinx-%{version}-py*.egg-info
162
163 %files -n python3-Sphinx
164 %defattr(644,root,root,755)
165 %{py3_sitescriptdir}/sphinx
166 %{py3_sitescriptdir}/Sphinx-%{version}-py*.egg-info
This page took 0.066603 seconds and 3 git commands to generate.