]> git.pld-linux.org Git - packages/sphinx-pdg.git/blob - sphinx-pdg.spec
c9d96ba857f065a52cb05d62107a53ff6c200bb1
[packages/sphinx-pdg.git] / sphinx-pdg.spec
1 # there are sphinx.spec, sphinx2.spec...  Sphinx.spec is too confusing
2 # therefore the name for this package is sphinx-pdg (pdg - python
3 # documentation generator)
4 Summary:        Sphinx - Python documentation generator
5 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona
6 Name:           sphinx-pdg
7 Version:        1.1.3
8 Release:        4
9 License:        BSD
10 Group:          Development/Languages/Python
11 Source0:        http://pypi.python.org/packages/source/S/Sphinx/Sphinx-%{version}.tar.gz
12 # Source0-md5:  8f55a6d4f87fc6d528120c5d1f983e98
13 Patch0:         sphinx-docutils-0.10.patch
14 URL:            http://sphinx.pocoo.org/
15 BuildRequires:  python-devel >= 1:2.5
16 BuildRequires:  python-distribute
17 BuildRequires:  python-modules >= 1:2.5
18 BuildRequires:  python3-2to3
19 BuildRequires:  python3-devel
20 BuildRequires:  python3-distribute
21 BuildRequires:  python3-modules
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.219
24 Requires:       python-Sphinx = %{version}-%{release}
25 Requires:       python-devel-tools
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Sphinx is a tool that makes it easy to create intelligent and
31 beautiful documentation for Python projects (or other documents
32 consisting of multiple reStructuredText sources), written by Georg
33 Brandl. It was originally created to translate the new Python
34 documentation, but has now been cleaned up in the hope that it will be
35 useful to many other projects.
36
37 %description -l pl.UTF-8
38 Sphinx to narzędzie ułatwiające tworzenie inteligentnej i ładnej
39 dokumentacji dla projektów w Pythonie (lub innych dokumentów
40 składających się z wielu źródeł w formacie reStructuredText), napisane
41 przez Georga Brandla. Pierwotnie powstało do tłumaczenia nowej
42 dokumentacji Pythona, ale potem zostało wyczyszczone w nadziei, że
43 będzie przydatne dla wielu innych projektów.
44
45 %package 3
46 Summary:        Sphinx Python documentation generator (Python 3 version)
47 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (wersja dla Pythona 3)
48 Group:          Development/Languages/Python
49 Requires:       python3-Sphinx = %{version}-%{release}
50
51 %description 3
52 Sphinx is a tool that makes it easy to create intelligent and
53 beautiful documentation for Python projects (or other documents
54 consisting of multiple reStructuredText sources), written by Georg
55 Brandl. It was originally created to translate the new Python
56 documentation, but has now been cleaned up in the hope that it will be
57 useful to many other projects.
58
59 %description 3 -l pl.UTF-8
60 Sphinx to narzędzie ułatwiające tworzenie inteligentnej i ładnej
61 dokumentacji dla projektów w Pythonie (lub innych dokumentów
62 składających się z wielu źródeł w formacie reStructuredText), napisane
63 przez Georga Brandla. Pierwotnie powstało do tłumaczenia nowej
64 dokumentacji Pythona, ale potem zostało wyczyszczone w nadziei, że
65 będzie przydatne dla wielu innych projektów.
66
67 %package -n python-Sphinx
68 Summary:        Sphinx Python documentation generator (Python 2.x modules)
69 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły Pythona 2.x)
70 Group:          Development/Languages/Python
71 Requires:       python-distribute
72 Requires:       python-docutils >= 0.7
73 Requires:       python-jinja2 >= 2.3
74 Requires:       python-modules
75 Requires:       python-pygments >= 1.2
76 Conflicts:      sphinx-pdg < 1.0.7-2
77
78 %description -n python-Sphinx
79 Sphinx Python documentation generator (Python 2.x modules).
80
81 For command-line utilities, see sphinx-pdg package.
82
83 %description -n python-Sphinx -l pl.UTF-8
84 Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły
85 Pythona 2.x).
86
87 Narzędzia działające z linii poleceń znajdują się w pakiecie
88 sphinx-pdg.
89
90 %package -n python3-Sphinx
91 Summary:        Sphinx Python documentation generator (Python 3.x modules)
92 Summary(pl.UTF-8):      Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły Pythona 3.x)
93 Group:          Development/Languages/Python
94 Requires:       python3-distribute
95 Requires:       python3-docutils >= 0.8
96 Requires:       python3-jinja2 >= 2.3
97 Requires:       python3-pygments >= 1.2
98 Conflicts:      sphinx-pdg-3 < 1.0.7-2
99
100 %description -n python3-Sphinx
101 Sphinx Python documentation generator (Python 3.x modules).
102
103 For command-line utilities, see sphinx-pdg-3 package.
104
105 %description -n python3-Sphinx -l pl.UTF-8
106 Sphinx - narzędzie do tworzenia dokumentacji dla Pythona (moduły
107 Pythona 3.x).
108
109 Narzędzia działające z linii poleceń znajdują się w pakiecie
110 sphinx-pdg-3.
111
112 %prep
113 %setup -q -n Sphinx-%{version}
114 %patch0 -p1
115
116 %build
117 %{__python} setup.py build -b build-2
118 %{__rm} sphinx/__init__.pyc
119 %{__python3} setup.py build -b build-3
120 %{__rm} -r sphinx/__pycache__
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__python3} setup.py build -b build-3 install \
126         --optimize=2 \
127         --root=$RPM_BUILD_ROOT
128 %{__rm} -r sphinx/__pycache__
129
130 for f in $RPM_BUILD_ROOT%{_bindir}/*; do
131         mv "${f}" "${f}-3"
132 done
133
134 %{__python} setup.py build -b build-2 install \
135         --optimize=2 \
136         --root=$RPM_BUILD_ROOT
137 %{__rm} sphinx/__init__.pyc
138
139 %py_postclean
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS CHANGES EXAMPLES LICENSE PKG-INFO README TODO
147 %attr(755,root,root) %{_bindir}/sphinx-autogen
148 %attr(755,root,root) %{_bindir}/sphinx-apidoc
149 %attr(755,root,root) %{_bindir}/sphinx-build
150 %attr(755,root,root) %{_bindir}/sphinx-quickstart
151
152 %files 3
153 %defattr(644,root,root,755)
154 %doc AUTHORS CHANGES EXAMPLES LICENSE PKG-INFO README TODO
155 %attr(755,root,root) %{_bindir}/sphinx-autogen-3
156 %attr(755,root,root) %{_bindir}/sphinx-apidoc-3
157 %attr(755,root,root) %{_bindir}/sphinx-build-3
158 %attr(755,root,root) %{_bindir}/sphinx-quickstart-3
159
160 %files -n python-Sphinx
161 %defattr(644,root,root,755)
162 %{py_sitescriptdir}/sphinx
163 %{py_sitescriptdir}/Sphinx-%{version}-py*.egg-info
164
165 %files -n python3-Sphinx
166 %defattr(644,root,root,755)
167 %{py3_sitescriptdir}/sphinx
168 %{py3_sitescriptdir}/Sphinx-%{version}-py*.egg-info
This page took 0.077937 seconds and 2 git commands to generate.