]> git.pld-linux.org Git - packages/sord.git/blob - sord.spec
- updated to 0.16.14
[packages/sord.git] / sord.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs # API documentation
4
5 Summary:        Lightweight C library for storing RDF data in memory
6 Summary(pl.UTF-8):      Lekka biblioteka C do przechowywania danych RDF w pamięci
7 Name:           sord
8 Version:        0.16.14
9 Release:        1
10 License:        ISC
11 Group:          Libraries
12 Source0:        http://download.drobilla.net/%{name}-%{version}.tar.xz
13 # Source0-md5:  73ed5c03c43ef3cc62558c6826b15fa4
14 URL:            http://drobilla.net/software/sord/
15 BuildRequires:  meson >= 0.56.0
16 BuildRequires:  ninja >= 1.5
17 BuildRequires:  pcre-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  serd-devel >= 0.30.10
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 %if %{with apidocs}
23 BuildRequires:  doxygen
24 %endif
25 Requires:       serd >= 0.30.10
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Sord is a lightweight C library for storing RDF data in memory.
30
31 %description -l pl.UTF-8
32 Sort to lekka biblioteka C do przechowywania danych RDF w pamięci.
33
34 %package devel
35 Summary:        Header files for sord library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sord
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       serd-devel >= 0.30.10
40
41 %description devel
42 Header files for sord library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki sord.
46
47 %prep
48 %setup -q
49
50 %build
51 %meson build \
52         --default-library=shared \
53         %{!?with_apidocs:-Ddocs=disabled}
54
55 %ninja_build -C build
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %ninja_install -C build
61
62 %if %{without apidocs}
63 # -Ddocs=disabled disables man page installation
64 install -d $RPM_BUILD_ROOT%{_mandir}/man1
65 cp -p doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
66 %endif
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post   -p /sbin/ldconfig
72 %postun -p /sbin/ldconfig
73
74 %files
75 %defattr(644,root,root,755)
76 %doc AUTHORS COPYING NEWS README.md
77 %attr(755,root,root) %{_bindir}/sord_validate
78 %attr(755,root,root) %{_bindir}/sordi
79 %attr(755,root,root) %{_libdir}/libsord-0.so.*.*.*
80 %attr(755,root,root) %ghost %{_libdir}/libsord-0.so.0
81 %{_mandir}/man1/sord_validate.1*
82 %{_mandir}/man1/sordi.1*
83
84 %files devel
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_libdir}/libsord-0.so
87 %{_includedir}/sord-0
88 %{_pkgconfigdir}/sord-0.pc
This page took 0.080743 seconds and 3 git commands to generate.