]> git.pld-linux.org Git - packages/snapmakerjs.git/blob - snapmakerjs.spec
cf9a4f4efdff7ecceb4e92696932a87bc1fd499f
[packages/snapmakerjs.git] / snapmakerjs.spec
1 Summary:        Snapmaker 3-in-1 Software for 3D Printing, Laser Engraving and CNC Cutting
2 Name:           snapmakerjs
3 Version:        2.6.1
4 Release:        1
5 License:        MIT
6 Group:          Applications
7 Source0:        https://s3-us-west-2.amazonaws.com/snapmaker.com/download/snapmakerjs/%{name}-%{version}-linux-x64.tar.gz
8 # Source0-md5:  d73263375129a4645b7143458153955e
9 Source1:        https://s3-us-west-2.amazonaws.com/snapmaker.com/download/snapmakerjs/%{name}-%{version}-linux-ia32.tar.gz
10 # Source1-md5:  e41e89a361cdec177083d6a179477be1
11 Source2:        %{name}.desktop
12 Source3:        %{name}.png
13 URL:            https://snapmaker.com/
14 BuildRequires:  ImageMagick
15 ExclusiveArch:  %{ix86} %{x8664}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         no_install_post_strip   1
19 %define         _enable_debug_packages  0
20
21 %description
22 Snapmaker 3-in-1 Software for 3D Printing, Laser Engraving and CNC
23 Cutting.
24
25 %prep
26 %ifarch %{x8664}
27 %setup -q -T -b0 -n %{name}-%{version}-linux-x64
28 %endif
29 %ifarch %{ix86}
30 %setup -q -T -b1 -n %{name}-%{version}-linux-ia32
31 %endif
32
33 %build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir},%{_desktopdir}} \
38         $RPM_BUILD_ROOT%{_iconsdir}/hicolor/256x256/apps
39
40 cp -a * $RPM_BUILD_ROOT%{_libdir}/%{name}
41 ln -s %{_libdir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
42
43 for i in 16 24 32 48 64 96 128 ; do
44   install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
45   convert -geometry ${i}x${i} %{SOURCE3} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/%{name}.png
46 done
47
48 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
49 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/256x256/apps
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 %update_icon_cache hicolor
56
57 %postun
58 %update_icon_cache hicolor
59
60 %triggerpostun -- snapmakerjs < 2.6.1-1
61 %groupremove snapmaker
62
63 %files
64 %defattr(644,root,root,755)
65 %doc LICENSE.electron.txt LICENSES.chromium.html
66 %attr(755,root,root) %{_bindir}/%{name}*
67 %dir %{_libdir}/%{name}
68 %{_libdir}/%{name}/locales
69 %dir %{_libdir}/snapmakerjs/resources
70 %{_libdir}/%{name}/resources/electron.asar
71 %dir %{_libdir}/snapmakerjs/resources/app
72 %{_libdir}/snapmakerjs/resources/app/app
73 %{_libdir}/snapmakerjs/resources/app/electron-app
74 %{_libdir}/snapmakerjs/resources/app/node_modules
75 %{_libdir}/snapmakerjs/resources/app/*.js
76 %{_libdir}/snapmakerjs/resources/app/*.json
77 %dir %{_libdir}/snapmakerjs/resources/app/resources
78 %{_libdir}/snapmakerjs/resources/app/resources/fonts
79 %dir %{_libdir}/snapmakerjs/resources/app/resources/CuraEngine
80 %{_libdir}/snapmakerjs/resources/app/resources/CuraEngine/Config
81 %dir %{_libdir}/snapmakerjs/resources/app/resources/CuraEngine/3.6
82 %dir %{_libdir}/snapmakerjs/resources/app/resources/CuraEngine/3.6/Linux
83 %attr(755,root,root) %{_libdir}/snapmakerjs/resources/app/resources/CuraEngine/3.6/Linux/CuraEngine
84 %dir %{_libdir}/snapmakerjs/resources/app/server
85 %{_libdir}/snapmakerjs/resources/app/server/index.js
86 %dir %{_libdir}/snapmakerjs/resources/app/server/i18n
87 %lang(cs) %{_libdir}/snapmakerjs/resources/app/server/i18n/cs
88 %lang(de) %{_libdir}/snapmakerjs/resources/app/server/i18n/de
89 %lang(en) %{_libdir}/snapmakerjs/resources/app/server/i18n/en
90 %lang(es) %{_libdir}/snapmakerjs/resources/app/server/i18n/es
91 %lang(fr) %{_libdir}/snapmakerjs/resources/app/server/i18n/fr
92 %lang(hu) %{_libdir}/snapmakerjs/resources/app/server/i18n/hu
93 %lang(it) %{_libdir}/snapmakerjs/resources/app/server/i18n/it
94 %lang(ja) %{_libdir}/snapmakerjs/resources/app/server/i18n/ja
95 %lang(pt_BR) %{_libdir}/snapmakerjs/resources/app/server/i18n/pt-br
96 %lang(ru) %{_libdir}/snapmakerjs/resources/app/server/i18n/ru
97 %lang(zh_CN) %{_libdir}/snapmakerjs/resources/app/server/i18n/zh-cn
98 %lang(zh_TW) %{_libdir}/snapmakerjs/resources/app/server/i18n/zh-tw
99 %{_libdir}/snapmakerjs/resources/app/server/views
100 %{_libdir}/%{name}/*.dat
101 %{_libdir}/%{name}/*.bin
102 %{_libdir}/%{name}/*.pak
103 %attr(755,root,root) %{_libdir}/%{name}/libffmpeg.so
104 %attr(755,root,root) %{_libdir}/%{name}/libnode.so
105 %attr(755,root,root) %{_libdir}/%{name}/snapmakerjs
106 %{_desktopdir}/%{name}.desktop
107 %{_iconsdir}/hicolor/*x*/apps/%{name}.png
This page took 1.987302 seconds and 2 git commands to generate.