]> git.pld-linux.org Git - packages/slim.git/blob - slim.spec
- rel 2
[packages/slim.git] / slim.spec
1 #
2 # TODO:
3 # - update slim-configuration.patch for pending WM-s
4 #
5 Summary:        SLiM - a desktop-independent graphical login manager
6 Summary(pl.UTF-8):      SLiM - niezależny od środowiska graficzny zarządca logowania
7 Name:           slim
8 Version:        1.3.5
9 Release:        2
10 License:        GPL v2
11 Group:          X11/Applications
12 Source0:        http://download.berlios.de/slim/%{name}-%{version}.tar.gz
13 # Source0-md5:  1153e6993f9c9333e4cf745411d03472
14 Source1:        %{name}.init
15 Source2:        %{name}.sysconfig
16 Source3:        %{name}.pamd
17 Patch0:         %{name}-configuration.patch
18 Patch1:         cmake.patch
19 Patch2:         default-session.patch
20 URL:            http://slim.berlios.de/
21 BuildRequires:  ConsoleKit-devel
22 BuildRequires:  cmake
23 BuildRequires:  dbus-devel
24 BuildRequires:  freeglut-devel
25 BuildRequires:  freetype-devel
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel >= 2:1.4.0
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  pam-devel
30 BuildRequires:  pkgconfig >= 1:0.19
31 BuildRequires:  rpmbuild(macros) >= 1.450
32 BuildRequires:  xorg-lib-libXft-devel
33 BuildRequires:  xorg-lib-libXmu-devel
34 BuildRequires:  xorg-lib-libXrender-devel
35 BuildRequires:  zlib-devel
36 Requires(post,preun):   /sbin/chkconfig
37 Requires(post,postun):  systemd-units >= 38
38 Requires:       mktemp
39 Requires:       rc-scripts >= 0.4.0.10
40 Requires:       systemd-units >= 0.38
41 Requires:       xinitrc-ng >= 1.0
42 Provides:       XDM
43 Obsoletes:      slim-systemd
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 SLiM is a Desktop-independent graphical login manager for X11, derived
48 from Login.app.
49
50 It aims to be light and simple, although completely configurable
51 through themes and an option file; is suitable for machines on which
52 remote login functionalities are not needed.
53
54 Features included:
55 - PNG and XFT support for alpha transparency and antialiased fonts
56 - External themes support
57 - Configurable runtime options: X server, login / shutdown / reboot
58   commands
59 - Single (GDM-like) or double (XDM-like) input control
60 - Can load predefined user at startup
61 - Configurable welcome / shutdown messages
62 - Random theme selection
63
64 %description -l pl.UTF-8
65 SLiM jest niezależnym od środowiska graficznym zarządcą ekranów dla
66 X11 wzorowanym na Login.app.
67
68 W założeniu ma być lekki i prosty, i jednocześnie całkowicie
69 konfigurowalny za pomocą motywów i pliku konfiguracyjnego; jest
70 przeznaczony dla maszyn, na których funkcjonalność zdalnego logowania
71 nie jest potrzebna.
72
73 Możliwości:
74 - obsługa PNG i XFT dla przezroczystości alpha oraz czcionek
75   antyaliasowanych,
76 - wsparcie dla dodatkowych motywów,
77 - konfigurowalne opcje: serwer X, polecenia do logowania, wyłączania
78   oraz restartu komputera,
79 - pojedyncza (jak w GDM) lub podwójna (jak w XDM) kontrola wejścia,
80 - możliwość automatycznego zalogowania danego użytkownika,
81 - konfigurowalne komunikaty powitania / pożegnania,
82 - losowy wybór motywu.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89
90 %build
91 install -d build
92 cd build
93 %cmake \
94         -DUSE_PAM=ON \
95         -DUSE_CONSOLEKIT=ON \
96         -DSYSCONF_INSTALL_DIR=%{_sysconfdir}/X11/slim \
97         ..
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT/etc/{security,pam.d}
104 %{__make} -C build install \
105         CFGDIR=%{_sysconfdir}/X11/slim \
106         MANDIR=%{_mandir} \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 :> $RPM_BUILD_ROOT/etc/security/blacklist.slim
110 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/slim
111
112 # initscript
113 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,security}
114 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
115 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
116
117 # systemd
118 install -d $RPM_BUILD_ROOT%{systemdunitdir}
119 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/slim.service
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post
125 /sbin/chkconfig --add slim
126 # -n option not to actually restart as it will terminate all sessions opened from slim!
127 %service -n slim restart "SLiM Display Manager"
128 %systemd_reload
129
130 %preun
131 if [ "$1" = "0" ]; then
132         /sbin/chkconfig --del slim
133         %service slim stop
134 fi
135
136 %postun
137 %systemd_reload
138
139 %files
140 %defattr(644,root,root,755)
141 %doc ChangeLog README THEMES TODO xinitrc.sample
142 %dir %{_sysconfdir}/X11/slim
143 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/X11/slim/slim.conf
144 %attr(754,root,root) /etc/rc.d/init.d/slim
145 %{systemdunitdir}/slim.service
146 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/slim
147 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.slim
148 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/slim
149 %attr(755,root,root) %{_bindir}/%{name}
150 %{_mandir}/man1/slim.1*
151 %{_datadir}/%{name}
This page took 0.26734 seconds and 3 git commands to generate.