]> git.pld-linux.org Git - packages/slib.git/blob - slib.spec
- update guile paths, rel 4
[packages/slib.git] / slib.spec
1 # TODO: integration with other Scheme implementations (see Makefile catalogs target)
2 Summary:        Scheme library
3 Summary(pl.UTF-8):      Biblioteka Scheme
4 Name:           slib
5 Version:        3b6
6 Release:        4
7 License:        distributable (BSD and Public Domain parts)
8 Group:          Development/Languages/Scheme
9 Source0:        http://groups.csail.mit.edu/mac/ftpdir/scm/%{name}-%{version}.tar.gz
10 # Source0-md5:  c895d74d769c5072c4c6d1b1700db83f
11 Patch0:         %{name}-info.patch
12 URL:            http://people.csail.mit.edu/jaffer/SLIB.html
13 BuildRequires:  scm
14 BuildRequires:  texinfo
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 SLIB is a portable scheme library meant to provide compatibility and
20 utility functions for all standard scheme implementations. Slib
21 conforms to Revised^5 Report on the Algorithmic Language Scheme and
22 the IEEE P1178 specification.
23
24 %description -l pl.UTF-8
25 SLIB jest przenośną biblioteką scheme mającą zapewnić kompatybilność i
26 funkcje użytkowe dla wszystkich implementacji scheme. SLIB jest zgodne
27 ze specyfikacją Revised^5 Report on the Algorithmic Language Scheme
28 oraz IEEE P1178.
29
30 %package -n guile-slib
31 Summary:        Scheme library for Guile
32 Summary(pl.UTF-8):      Biblioteka Scheme dla Guile
33 Group:          Development/Languages/Scheme
34 Requires(post): /usr/bin/guile
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       guile >= 5:2.2
37
38 %description -n guile-slib
39 SLIB is a portable scheme library meant to provide compatibility and
40 utility functions for all standard scheme implementations. Slib
41 conforms to Revised^5 Report on the Algorithmic Language Scheme and
42 the IEEE P1178 specification.
43
44 This package integrates SLIB with Guile implementation.
45
46 %description -n guile-slib -l pl.UTF-8
47 SLIB jest przenośną biblioteką scheme mającą zapewnić kompatybilność i
48 funkcje użytkowe dla wszystkich implementacji scheme. SLIB jest zgodne
49 ze specyfikacją Revised^5 Report on the Algorithmic Language Scheme
50 oraz IEEE P1178.
51
52 Ten pakiet integruje SLIB z implementacją Guile.
53
54 %package -n scm-slib
55 Summary:        Scheme library for SCM
56 Summary(pl.UTF-8):      Biblioteka Scheme dla SCM-a
57 Group:          Development/Languages/Scheme
58 Requires(post): /usr/bin/scm
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       scm
61
62 %description -n scm-slib
63 SLIB is a portable scheme library meant to provide compatibility and
64 utility functions for all standard scheme implementations. Slib
65 conforms to Revised^5 Report on the Algorithmic Language Scheme and
66 the IEEE P1178 specification.
67
68 This package integrates SLIB with SCM implementation.
69
70 %description -n scm-slib -l pl.UTF-8
71 SLIB jest przenośną biblioteką scheme mającą zapewnić kompatybilność i
72 funkcje użytkowe dla wszystkich implementacji scheme. SLIB jest zgodne
73 ze specyfikacją Revised^5 Report on the Algorithmic Language Scheme
74 oraz IEEE P1178.
75
76 Ten pakiet integruje SLIB z implementacją SCM.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 %build
83 %{__make}
84
85 %{__make} slib.info
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_infodir},%{_datadir}/slib,%{_bindir},%{_mandir}/man1}
90
91 cp -p *.scm $RPM_BUILD_ROOT%{_datadir}/slib
92 cp -p guile.init guile-2.init $RPM_BUILD_ROOT%{_datadir}/slib
93 cp -p scm.init $RPM_BUILD_ROOT%{_datadir}/slib
94 # TODO (and possibly other, not present yet in PLD)
95 #cp -p scheme48.init umbscheme.init $RPM_BUILD_ROOT%{_datadir}/slib
96
97 cat > $RPM_BUILD_ROOT%{_bindir}/slib <<EOF
98 #!/bin/sh
99 SCHEME_LIBRARY_PATH=%{_datadir}/slib/
100 EOF
101 cat slib.sh >>$RPM_BUILD_ROOT%{_bindir}/slib
102
103 install slib.1 $RPM_BUILD_ROOT%{_mandir}/man1
104 install slib.info $RPM_BUILD_ROOT%{_infodir}
105
106 # guile
107 install -d $RPM_BUILD_ROOT%{_datadir}/guile/site/3.0
108 :> $RPM_BUILD_ROOT%{_datadir}/guile/site/3.0/slibcat
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/postshell
114 -/usr/sbin/fix-info-dir -c %{_infodir}
115
116 %postun -p /sbin/postshell
117 -/usr/sbin/fix-info-dir -c %{_infodir}
118
119 %post -n guile-slib
120 # old (guile < 2) location
121 rm -f %{_datadir}/guile/site/slibcat
122 umask 022
123 /usr/bin/guile -l %{_datadir}/slib/guile.init -c "(use-modules (ice-9 slib)) (require 'new-catalog)" >/dev/null 2>&1
124
125 %post -n scm-slib
126 umask 022
127 scm -c "(require 'new-catalog)" >/dev/null 2>&1
128
129 %triggerin -n scm-slib -- scm
130 # force regeneration after scm upgrade
131 umask 022
132 scm -c "(require 'new-catalog)" >/dev/null 2>&1
133
134 %files
135 %defattr(644,root,root,755)
136 %doc ANNOUNCE COPYING ChangeLog FAQ README
137 %attr(755,root,root) %{_bindir}/slib
138 %dir %{_datadir}/slib
139 %{_datadir}/slib/*.scm
140 %{_mandir}/man1/slib.1*
141 %{_infodir}/slib.info*
142
143 %files -n guile-slib
144 %defattr(644,root,root,755)
145 %{_datadir}/slib/guile.init
146 %{_datadir}/slib/guile-2.init
147 %ghost %{_datadir}/guile/site/3.0/slibcat
148
149 %files -n scm-slib
150 %defattr(644,root,root,755)
151 %{_datadir}/slib/scm.init
152 # impossible due to main package being noarch
153 #%ghost %{_libdir}/scm/slibcat
This page took 0.143115 seconds and 3 git commands to generate.