]> git.pld-linux.org Git - packages/slib.git/blob - slib.spec
- added scm integration package (here, not in scm, to handle slib upgrades)
[packages/slib.git] / slib.spec
1 # TODO: integration with other Scheme implementations (see Makefile catalogs target)
2 Summary:        Scheme library
3 Summary(pl.UTF-8):      Biblioteka Scheme
4 Name:           slib
5 Version:        3b4
6 Release:        2
7 License:        distributable (BSD and Public Domain parts)
8 Group:          Development/Languages/Scheme
9 Source0:        http://groups.csail.mit.edu/mac/ftpdir/scm/%{name}-%{version}.tar.gz
10 # Source0-md5:  dcada65c4df4209c8f71211095bcef8e
11 Patch0:         %{name}-info.patch
12 URL:            http://people.csail.mit.edu/jaffer/SLIB.html
13 BuildRequires:  texinfo
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 SLIB is a portable scheme library meant to provide compatibility and
19 utility functions for all standard scheme implementations. Slib
20 conforms to Revised^5 Report on the Algorithmic Language Scheme and
21 the IEEE P1178 specification.
22
23 %description -l pl.UTF-8
24 SLIB jest przenośną biblioteką scheme mającą zapewnić kompatybilność i
25 funkcje użytkowe dla wszystkich implementacji scheme. SLIB jest zgodne
26 ze specyfikacją Revised^5 Report on the Algorithmic Language Scheme
27 oraz IEEE P1178.
28
29 %package -n guile-slib
30 Summary:        Scheme library for Guile
31 Summary(pl.UTF-8):      Biblioteka Scheme dla Guile
32 Group:          Development/Languages/Scheme
33 Requires(post): /usr/bin/guile
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       guile >= 5:2.0
36
37 %description -n guile-slib
38 SLIB is a portable scheme library meant to provide compatibility and
39 utility functions for all standard scheme implementations. Slib
40 conforms to Revised^5 Report on the Algorithmic Language Scheme and
41 the IEEE P1178 specification.
42
43 This package integrates SLIB with Guile implementation.
44
45 %description -n guile-slib -l pl.UTF-8
46 SLIB jest przenośną biblioteką scheme mającą zapewnić kompatybilność i
47 funkcje użytkowe dla wszystkich implementacji scheme. SLIB jest zgodne
48 ze specyfikacją Revised^5 Report on the Algorithmic Language Scheme
49 oraz IEEE P1178.
50
51 Ten pakiet integruje SLIB z implementacją Guile.
52
53 %package -n scm-slib
54 Summary:        Scheme library for SCM
55 Summary(pl.UTF-8):      Biblioteka Scheme dla SCM-a
56 Group:          Development/Languages/Scheme
57 Requires(post): /usr/bin/scm
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       scm
60
61 %description -n scm-slib
62 SLIB is a portable scheme library meant to provide compatibility and
63 utility functions for all standard scheme implementations. Slib
64 conforms to Revised^5 Report on the Algorithmic Language Scheme and
65 the IEEE P1178 specification.
66
67 This package integrates SLIB with SCM implementation.
68
69 %description -n scm-slib -l pl.UTF-8
70 SLIB jest przenośną biblioteką scheme mającą zapewnić kompatybilność i
71 funkcje użytkowe dla wszystkich implementacji scheme. SLIB jest zgodne
72 ze specyfikacją Revised^5 Report on the Algorithmic Language Scheme
73 oraz IEEE P1178.
74
75 Ten pakiet integruje SLIB z implementacją SCM.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 %build
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{_infodir},%{_datadir}/slib,%{_bindir},%{_mandir}/man1}
87
88 cp -p *.scm $RPM_BUILD_ROOT%{_datadir}/slib
89 cp -p guile.init guile-2.init $RPM_BUILD_ROOT%{_datadir}/slib
90 cp -p scm.init $RPM_BUILD_ROOT%{_datadir}/slib
91 # TODO (and possibly other, not present yet in PLD)
92 #cp -p scheme48.init umbscheme.init $RPM_BUILD_ROOT%{_datadir}/slib
93
94 cat > $RPM_BUILD_ROOT%{_bindir}/slib <<EOF
95 #!/bin/sh
96 SCHEME_LIBRARY_PATH=%{_datadir}/slib/
97 EOF
98 cat slib.sh >>$RPM_BUILD_ROOT%{_bindir}/slib
99
100 install slib.1 $RPM_BUILD_ROOT%{_mandir}/man1
101 install slib.info $RPM_BUILD_ROOT%{_infodir}
102
103 # guile
104 install -d $RPM_BUILD_ROOT%{_datadir}/guile/site/2.0
105 :> $RPM_BUILD_ROOT%{_datadir}/guile/site/2.0/slibcat
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/postshell
111 -/usr/sbin/fix-info-dir -c %{_infodir}
112
113 %postun -p /sbin/postshell
114 -/usr/sbin/fix-info-dir -c %{_infodir}
115
116 %post -n guile-slib
117 # old (guile < 2) location
118 rm -f %{_datadir}/guile/site/slibcat
119 umask 022
120 /usr/bin/guile -l %{_datadir}/slib/guile.init -c "(use-modules (ice-9 slib)) (require 'new-catalog)" >/dev/null 2>&1
121
122 %post -n scm-slib
123 umask 022
124 scm -c "(require 'new-catalog)" >/dev/null 2>&1
125
126 %files
127 %defattr(644,root,root,755)
128 %doc ANNOUNCE COPYING ChangeLog FAQ README
129 %attr(755,root,root) %{_bindir}/slib
130 %dir %{_datadir}/slib
131 %{_datadir}/slib/*.scm
132 %{_mandir}/man1/slib.1*
133 %{_infodir}/slib.info*
134
135 %files -n guile-slib
136 %defattr(644,root,root,755)
137 %{_datadir}/slib/guile.init
138 %{_datadir}/slib/guile-2.init
139 %ghost %{_datadir}/guile/site/2.0/slibcat
140
141 %files -n scm-slib
142 %defattr(644,root,root,755)
143 %{_datadir}/slib/scm.init
144 # impossible due to main package being noarch
145 #%ghost %{_libdir}/scm/slibcat
This page took 0.077204 seconds and 3 git commands to generate.