]> git.pld-linux.org Git - packages/sleuthkit.git/blob - sleuthkit.spec
- disable java, does not build without downloading stuff
[packages/sleuthkit.git] / sleuthkit.spec
1 #
2 # TODO:
3 #       - add libvhdi bcond and support
4 #       - add libvmdk bcond and support
5 #
6 # Conditional build:
7 %bcond_without  aff             # Without Advanced Forensic Format (aff) support
8 %bcond_with     java            # Build Java bindings and jar file
9 #
10 Summary:        The Sleuth Kit - an forensic toolkit for analyzing file systems and disks
11 Summary(pl.UTF-8):      The Sleuth Kit - zestaw narzędzi wspomagających analizę systemów plików
12 Name:           sleuthkit
13 Version:        4.9.0
14 Release:        1
15 License:        IBM Public License/Common Public License
16 Group:          Applications
17 Source0:        https://github.com/sleuthkit/sleuthkit/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  01f04162de36cd23038a9d8f75b1c48a
19 Patch0:         libewf.patch
20 URL:            http://www.sleuthkit.org/sleuthkit/
21 %{?with_aff:BuildRequires:      afflib-devel}
22 #BuildRequires: autoconf
23 #BuildRequires: automake
24 BuildRequires:  libewf-devel
25 BuildRequires:  libstdc++-devel
26 #BuildRequires: libtool
27 BuildRequires:  openssl-devel
28 BuildRequires:  perl-base
29 BuildRequires:  sed >= 4.0
30 Requires:       coreutils
31 Requires:       file
32 # XXX: openssl library (should be autodetected) or openssl-tools or perl-OpenSSL-??? ?
33 Requires:       openssl
34 Requires:       perl-Date-Manip
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The Sleuth Kit is an open source forensic toolkit for analyzing
39 Microsoft and UNIX file systems and disks. The Sleuth Kit enables
40 investigators to identify and recover evidence from images acquired
41 during incident response or from live systems. The Sleuth Kit is open
42 source, which allows investigators to verify the actions of the tool
43 or customize it to specific needs.
44
45 It is recommended that these command line tools can be used with the
46 Autopsy Forensic Browser. Autopsy,
47 (<http://www.sleuthkit.org/autopsy/>), is a graphical interface to the
48 tools of The Sleuth Kit and automates many of the procedures and
49 provides features such as image searching and MD5 image integrity
50 checks.
51
52 As with any investigation tool, any results found with The Sleuth Kit
53 should be be recreated with a second tool to verify the data.
54
55 %description -l pl.UTF-8
56 The Sleuth Kit to mający otwarte źródła zestaw narzędzi do analizy
57 systemów plików i dysków z systemami Microsoftu i uniksowymi. The
58 Sleuth Kit umożliwia badającym zidentyfikować i odtworzyć dowody
59 uzyskane podczas reakcji na incydent lub z żywych systemów. The Sleuth
60 Kit ma otwarte źródła, co pozwala badającym zweryfikować działania
61 narzędzia lub przystosować je do określonych potrzeb.
62
63 Zalecane jest używanie tych narzędzi działających z linii poleceń wraz
64 z przeglądarką Autopsy (<http://www.sleuthkit.org/autopsy/>), będącą
65 graficznym interfejsem do narzędzi z The Sleuth Kit i automatyzującą
66 wiele procedur oraz udostępniającą możliwości takie jak przeszukiwanie
67 obrazów i sprawdzanie integralności obrazów za pomocą sum MD5.
68
69 Podobnie jak przy dowolnym narzędziu badawczym wszelkie wyniki
70 uzyskane przy użyciu tego zestawu powinny być odtworzone przy użyciu
71 drugiego narzędzia dla zweryfikowania wiarygodności.
72
73 %package libs
74 Summary:        Sleuthkit shared library
75 Summary(pl.UTF-8):      Biblioteka współdzielona Sleuthkita
76 Group:          Libraries
77
78 %description libs
79 Sleuthkit shared library.
80
81 %description libs -l pl.UTF-8
82 Biblioteka współdzielona Sleuthkita.
83
84 %package devel
85 Summary:        Header files for %{name} library
86 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89
90 %description devel
91 Header files for %{name} library.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe biblioteki %{name}.
95
96 %package devel
97 Summary:        Header files for %{name} library
98 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}-%{release}
101
102 %description devel
103 Header files for %{name} library.
104
105 %description devel -l pl.UTF-8
106 Pliki nagłówkowe biblioteki %{name}.
107
108 %package static
109 Summary:        Static %{name} library
110 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 Static %{name} library.
116
117 %description static -l pl.UTF-8
118 Statyczna biblioteka %{name}.
119
120 %package java
121 Summary:        Java bindings for sleuthkit
122 Summary(pl.UTF-8):      Dowiązania Javy do sleuthkit
123 Group:          Development/Languages/Java
124 Requires:       %{name} = %{version}-%{release}
125
126 %description java
127 Java bindings for sleuthkit.
128
129 %description java -l pl.UTF-8
130 Dowiązania Javy do sleuthkit.
131
132 %prep
133 %setup -q
134 %patch0 -p1
135
136 %{__sed} -i -e 's/-static//' {samples,tests,tools/*tools}/Makefile.in
137
138 %build
139 %{__aclocal}
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 %configure \
144         %{!?with_aff:--without-afflib} \
145         %{!?with_java:--disable-java}
146
147 %{__sed} -i -e 's/^\(LIBS = -lewf\)/\1 -ldl -lpthread/' {tools/autotools,tsk}/Makefile
148
149 %{__make}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %{__make} install \
155      DESTDIR=$RPM_BUILD_ROOT
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %files
161 %defattr(644,root,root,755)
162 %doc API-CHANGES.txt ChangeLog.txt NEWS.txt README.md licenses/*
163 %attr(755,root,root) %{_bindir}/*
164 %{_datadir}/tsk
165 %{_mandir}/man1/*
166
167 %files libs
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libtsk.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libtsk.so.19
171 %if %{with java}
172 %attr(755,root,root) %{_libdir}/libtsk_jni.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libtsk_jni.so.0
174 %endif
175
176 %files devel
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libtsk.so
179 %{_libdir}/libtsk.la
180 %if %{with java}
181 %attr(755,root,root) %{_libdir}/libtsk_jni.so
182 %{_libdir}/libtsk_jni.la
183 %endif
184 %{_includedir}/tsk
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/libtsk.a
189 %{?with_java:%{_libdir}/libtsk_jni.a}
190
191 %if %{with java}
192 %files java
193 %defattr(644,root,root,755)
194 %{_javadir}/%{name}-%{version}.jar
195 %endif
This page took 0.088134 seconds and 3 git commands to generate.