]> git.pld-linux.org Git - packages/skype.git/blob - skype.spec
updated to 4.2.0.11
[packages/skype.git] / skype.spec
1 %define         pkgname skype
2 %define         qtver   4.7
3 %define         dbus    1.0
4 %define         bluez   4.0.0
5 %define         asound  1.0.18
6 %define         pulseaudio      1.0
7 Summary:        p2p VoIP application
8 Summary(pl.UTF-8):      Aplikacja VoIP p2p
9 Name:           skype
10 Version:        4.2.0.11
11 Release:        1
12 # http://www.skype.com/company/legal/promote/distributionterms.html
13 # distributing on CD-ROM and similar media requires approval
14 License:        Commercial, redistributable (see LICENSE)
15 Group:          Applications/Communications
16 Source0:        http://download.skype.com/linux/%{pkgname}-ubuntu-lucid_%{version}-1_i386.deb
17 # Source0-md5:  cae1e6c6a504bd08f84f4b9674df3967
18 Source1:        %{name}.sh
19 Patch0:         %{name}-desktop.patch
20 URL:            http://www.skype.com/
21 BuildRequires:  rpm-utils
22 # to force 32bit iconv
23 Requires:       %{_libdir}/gconv
24 Requires:       QtCore >= %{qtver}
25 Requires:       QtDBus >= %{qtver}
26 Requires:       QtGui >= %{qtver}
27 Requires:       QtNetwork >= %{qtver}
28 Requires:       alsa-lib >= %{asound}
29 Requires:       dbus-libs > %{dbus}
30 Requires:       iconv
31 Requires:       libsigc++ >= 2.0
32 Suggests:       pulseaudio >= %{pulseaudio}
33 Suggests:       bluez-libs >= %{bluez}
34 Provides:       skype-program = %{version}
35 Conflicts:      skype-static
36 ExclusiveArch:  %{ix86}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _enable_debug_packages  0
40 # https://developer.skype.com/jira/browse/SCL-569
41 %define         no_install_post_strip   1
42
43 # So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
44 %define         _noautoreqdep   libstdc++.so.6
45
46 %description
47 p2p VoIP application.
48
49 License requirement: The Software originates from Skype and use the
50 links and graphics as published and indicated on
51 <http://www.skype.com/go/redistribution/>.
52
53 %description -l pl.UTF-8
54 Aplikacja VoIP p2p.
55
56 Wymaganie licencyjne: to oprogramowanie pochodzi od Skype i
57 wykorzystuje odnośniki i grafikę w postaci opublikowanej i oznaczonej
58 na <http://www.skype.com/go/redistribution/>.
59
60 %prep
61 %setup -qcT
62 ar x %{SOURCE0}
63 tar xzf data.tar.gz
64 mv usr/share/doc/skype/copyright LICENSE
65 mv usr/share/doc/skype/* .
66 mv usr/share/skype/avatars .
67 mv usr/bin/skype .
68 mv usr/share/skype/sounds .
69 mv usr/share/skype/lang .
70 mv etc/dbus-1/system.d/skype.conf .
71 mv usr/share/pixmaps/skype.png .
72 mv usr/share/applications/skype.desktop .
73 %patch0 -p1
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_datadir}/%{pkgname},%{_datadir}/%{pkgname}/{lang,sounds,avatars},%{_desktopdir},%{_pixmapsdir},/etc/dbus-1/system.d}
78
79 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}
80 install -p %{pkgname} $RPM_BUILD_ROOT%{_libdir}/%{name}
81 cp -p sounds/*.wav $RPM_BUILD_ROOT%{_datadir}/%{pkgname}/sounds
82 cp -p lang/*.qm $RPM_BUILD_ROOT%{_datadir}/%{pkgname}/lang
83 cp -p avatars/*.png $RPM_BUILD_ROOT%{_datadir}/%{pkgname}/avatars
84 cp -p skype.conf $RPM_BUILD_ROOT/etc/dbus-1/system.d
85 cp -p *.desktop $RPM_BUILD_ROOT%{_desktopdir}
86 cp -p skype.png $RPM_BUILD_ROOT%{_pixmapsdir}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README LICENSE third-party_attributions.txt
94 /etc/dbus-1/system.d/skype.conf
95 %attr(755,root,root) %{_bindir}/skype
96 %attr(755,root,root) %{_libdir}/skype
97
98 %dir %{_datadir}/%{pkgname}
99 %{_datadir}/%{pkgname}/sounds
100 %{_datadir}/%{pkgname}/avatars
101
102 %dir %{_datadir}/%{pkgname}/lang
103 %lang(bg) %{_datadir}/%{pkgname}/lang/skype_bg.qm
104 %lang(cs) %{_datadir}/%{pkgname}/lang/skype_cs.qm
105 %lang(de) %{_datadir}/%{pkgname}/lang/skype_de.qm
106 %lang(en) %{_datadir}/%{pkgname}/lang/skype_en.qm
107 %lang(es) %{_datadir}/%{pkgname}/lang/skype_es.qm
108 %lang(et) %{_datadir}/%{pkgname}/lang/skype_et.qm
109 %lang(fr) %{_datadir}/%{pkgname}/lang/skype_fr.qm
110 %lang(it) %{_datadir}/%{pkgname}/lang/skype_it.qm
111 %lang(ja) %{_datadir}/%{pkgname}/lang/skype_ja.qm
112 %lang(ko) %{_datadir}/%{pkgname}/lang/skype_ko.qm
113 %lang(lt) %{_datadir}/%{pkgname}/lang/skype_lt.qm
114 %lang(lv) %{_datadir}/%{pkgname}/lang/skype_lv.qm
115 %lang(nb) %{_datadir}/%{pkgname}/lang/skype_no.qm
116 %lang(pl) %{_datadir}/%{pkgname}/lang/skype_pl.qm
117 %lang(pt) %{_datadir}/%{pkgname}/lang/skype_pt_pt.qm
118 %lang(pt_BR) %{_datadir}/%{pkgname}/lang/skype_pt_br.qm
119 %lang(ro) %{_datadir}/%{pkgname}/lang/skype_ro.qm
120 %lang(ru) %{_datadir}/%{pkgname}/lang/skype_ru.qm
121 %lang(th) %{_datadir}/%{pkgname}/lang/skype_th.qm
122 %lang(tr) %{_datadir}/%{pkgname}/lang/skype_tr.qm
123 %lang(uk) %{_datadir}/%{pkgname}/lang/skype_uk.qm
124 %lang(zh) %{_datadir}/%{pkgname}/lang/skype_zh_s.qm
125 %lang(zh_TW) %{_datadir}/%{pkgname}/lang/skype_zh_t.qm
126 %{_pixmapsdir}/*.png
127 %{_desktopdir}/*.desktop
This page took 0.034435 seconds and 4 git commands to generate.