]> git.pld-linux.org Git - packages/skipfish.git/blob - skipfish.spec
- updated to 2.08b
[packages/skipfish.git] / skipfish.spec
1 %define         subver  b
2 %define         rel             1
3 Summary:        Web application security scanner
4 Name:           skipfish
5 Version:        2.08
6 Release:        0.%{subver}.%{rel}
7 License:        Apache v2.0
8 Group:          Applications/Networking
9 Source0:        http://skipfish.googlecode.com/files/%{name}-%{version}%{subver}.tgz
10 # Source0-md5:  fb928f803c6228ab8ae46ccdf3ce65f0
11 URL:            http://code.google.com/p/skipfish/
12 BuildRequires:  libidn-devel
13 BuildRequires:  openssl-devel
14 BuildRequires:  pcre-devel
15 BuildRequires:  sed >= 4.0
16 BuildRequires:  zlib-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 A fully automated, active web application security reconnaissance
21 tool.
22
23 Key features:
24 - High speed: pure C code, highly optimized HTTP handling, minimal CPU
25   footprint - easily achieving 2000 requests per second with responsive
26   targets.
27 - Ease of use: heuristics to support a variety of quirky web
28   frameworks and mixed-technology sites, with automatic learning
29   capabilities, on-the-fly wordlist creation, and form autocompletion.
30 - Cutting-edge security logic: high quality, low false positive,
31   differential security checks, capable of spotting a range of subtle
32   flaws, including blind injection vectors.
33
34 %prep
35 %setup -q -n %{name}-%{version}%{subver}
36
37 %{__sed} -i -e 's,-O3,$(OPTCFLAGS),' Makefile
38 %{__sed} -i -e 's,-L/usr/local/lib/ -L/opt/local/lib,$(OPTLDFLAGS),' Makefile
39 %{__sed} -i -e 's,"assets","%{_datadir}/%{name}/assets",' src/config.h
40
41 %build
42 %{__make} \
43         CC="%{__cc}" \
44         OPTCFLAGS="%{rpmcflags} %{rpmcppflags}" \
45         OPTLDFLAGS="%{rpmldflags}"
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name},%{_mandir}/man1}
50
51 install -p %{name} $RPM_BUILD_ROOT%{_bindir}
52 cp -ar doc/%{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
53 cp -ar assets dictionaries $RPM_BUILD_ROOT%{_datadir}/%{name}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc ChangeLog README doc/*.txt
61 %attr(755,root,root) %{_bindir}/skipfish
62 %{_datadir}/%{name}
63 %{_mandir}/man1/%{name}.1*
This page took 0.098415 seconds and 3 git commands to generate.