]> git.pld-linux.org Git - packages/skipfish.git/blob - skipfish.spec
16ada94ee7e67fe9b029905c7a5e40ef3b532a47
[packages/skipfish.git] / skipfish.spec
1 %define         subver  b
2 %define         rel             1
3 Summary:        Web application security scanner
4 Name:           skipfish
5 Version:        2.07
6 Release:        0.%{subver}.%{rel}
7 License:        Apache v2.0
8 Group:          Applications/Networking
9 Source0:        http://skipfish.googlecode.com/files/%{name}-%{version}%{subver}.tgz
10 # Source0-md5:  91ee5616b22366745e8b6ba00c3a29e1
11 URL:            http://code.google.com/p/skipfish/
12 BuildRequires:  libidn-devel
13 BuildRequires:  openssl-devel
14 BuildRequires:  sed >= 4.0
15 BuildRequires:  zlib-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 A fully automated, active web application security reconnaissance
20 tool.
21
22 Key features:
23 - High speed: pure C code, highly optimized HTTP handling, minimal CPU
24   footprint - easily achieving 2000 requests per second with responsive
25   targets.
26 - Ease of use: heuristics to support a variety of quirky web
27   frameworks and mixed-technology sites, with automatic learning
28   capabilities, on-the-fly wordlist creation, and form autocompletion.
29 - Cutting-edge security logic: high quality, low false positive,
30   differential security checks, capable of spotting a range of subtle
31   flaws, including blind injection vectors.
32
33 %prep
34 %setup -q -n %{name}-%{version}%{subver}
35
36 %{__sed} -i -e 's,-O3,$(OPTCFLAGS),' Makefile
37 %{__sed} -i -e 's,-L/usr/local/lib/ -L/opt/local/lib,$(OPTLDFLAGS),' Makefile
38 %{__sed} -i -e 's,"assets","%{_datadir}/%{name}/assets",' config.h
39
40 %build
41 %{__make} \
42         CC="%{__cc}" \
43         OPTCFLAGS="%{rpmcflags} %{rpmcppflags}" \
44         OPTLDFLAGS="%{rpmldflags}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name},%{_mandir}/man1}
49
50 install -p %{name} $RPM_BUILD_ROOT%{_bindir}
51 cp -ar %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
52 cp -ar assets dictionaries $RPM_BUILD_ROOT%{_datadir}/%{name}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc ChangeLog README
60 %attr(755,root,root) %{_bindir}/skipfish
61 %{_datadir}/%{name}
62 %{_mandir}/man1/%{name}.1*
This page took 0.053734 seconds and 2 git commands to generate.