]> git.pld-linux.org Git - packages/skia.git/blob - skia.spec
new, attempt to package skia
[packages/skia.git] / skia.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  verbose                 # verbose build (V=1)
5
6 %define         subver  20130302
7 %define         rel             0.1
8 Summary:        2D graphic library
9 Name:           skia
10 Version:        0
11 Release:        0.%{rel}.%{subver}
12 License:        BSD
13 Group:          Development/Libraries
14 Source0:        %{name}-%{subver}.tar.xz
15 # Source0-md5:  d3338ba25a4130d8a5e0678cb416cf02
16 Source1:        get-source.sh
17 Source2:        gclient.conf
18 URL:            https://sites.google.com/site/skiadocs/
19 #BuildRequires: cityhash-devel
20 BuildRequires:  libstdc++-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Skia is a complete 2D graphic library for drawing Text, Geometries,
25 and Images.
26
27 %package devel
28 Summary:        The development files for skia
29 Summary(pl.UTF-8):      Pliki programistyczne skia
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Header files for development with skia.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe do tworzenia programów z użyciem skia.
38
39 %package static
40 Summary:        Static skia library
41 Summary(pl.UTF-8):      Statyczna biblioteka skia
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 Static skia library.
47
48 %description static -l pl.UTF-8
49 Statyczna biblioteka skia.
50
51 %prep
52 %setup -qn %{name}-%{subver}
53
54 mv skia/{README,LICENSE} .
55
56 %build
57 cd skia
58 %{__python} gyp_skia \
59         --format=make \
60         --depth=. \
61         skia.gyp
62
63 %{__make} -r \
64         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
65         %{?with_verbose:V=1} \
66         CC="%{__cc}" \
67         CXX="%{__cxx}" \
68         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
69         CC.host="%{__cc}" \
70         CXX.host="%{__cxx}" \
71         LDFLAGS.host="%{rpmldflags}" \
72         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
73         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
74         skia_base_libs
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/%{name}}
79
80 cd skia
81 cp -a include/* $RPM_BUILD_ROOT%{_includedir}/%{name}
82
83 cd out/%{!?debug:Release}%{?debug:Debug}
84
85 cp -p lib*.a $RPM_BUILD_ROOT%{_libdir}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README LICENSE
93
94 %files devel
95 %defattr(644,root,root,755)
96 %{_includedir}/%{name}
97
98 %if %{with static_libs}
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/libskia_core.a
102 %{_libdir}/libskia_gr.a
103 %{_libdir}/libskia_opts.a
104 %{_libdir}/libskia_opts_ssse3.a
105 %{_libdir}/libskia_ports.a
106 %{_libdir}/libskia_skgr.a
107 %{_libdir}/libskia_utils.a
108 %endif
This page took 0.094042 seconds and 3 git commands to generate.